Corporate information

Rocket Software, Inc. develops enterprise infrastructure products in four key areas: storage, networks, and compliance; database servers and tools; business information and analytics; and application development, integration, and modernization.

Website: www.rocketsoftware.com

Rocket Global Headquarters
77 4th Avenue, Suite 100
Waltham, MA 02451-1468
USA

To contact Rocket Software by telephone for any reason, including obtaining pre-sales information and technical support, use one of the following telephone numbers.

<table>
<thead>
<tr>
<th>Country</th>
<th>Toll-free telephone number</th>
</tr>
</thead>
<tbody>
<tr>
<td>United States</td>
<td>1-855-577-4323</td>
</tr>
<tr>
<td>Australia</td>
<td>1-800-823-405</td>
</tr>
<tr>
<td>Belgium</td>
<td>0800-266-65</td>
</tr>
<tr>
<td>Canada</td>
<td>1-855-577-4323</td>
</tr>
<tr>
<td>China</td>
<td>800-720-1170</td>
</tr>
<tr>
<td>France</td>
<td>0800-180-0882</td>
</tr>
<tr>
<td>Germany</td>
<td>08-05-08-05-62</td>
</tr>
<tr>
<td>Italy</td>
<td>800-878-295</td>
</tr>
<tr>
<td>Japan</td>
<td>0800-170-5464</td>
</tr>
<tr>
<td>Netherlands</td>
<td>0-800-022-2961</td>
</tr>
<tr>
<td>New Zealand</td>
<td>0800-003210</td>
</tr>
<tr>
<td>South Africa</td>
<td>0-800-980-818</td>
</tr>
<tr>
<td>United Kingdom</td>
<td>0800-520-0439</td>
</tr>
</tbody>
</table>

Contacting Technical Support

The Rocket Customer Portal is the primary method of obtaining support. If you have current support and maintenance agreements with Rocket Software, you can access the Rocket Customer Portal and report a problem, download an update, or find answers to in the U2 Knowledgebase. To log in to the Rocket Customer Portal or to request a Rocket Customer Portal account, go to www.rocketsoftware.com/support.

In addition to using the Rocket Customer Portal to obtain support, you can send an email to u2support@rocketsoftware.com or use one of the following telephone numbers.

<table>
<thead>
<tr>
<th>Country</th>
<th>Telephone number</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America</td>
<td>+1 800 729 3553</td>
</tr>
<tr>
<td>United Kingdom/France</td>
<td>+44 (0) 800 773 771 or +44 (0) 20 8867 3691</td>
</tr>
<tr>
<td>Europe/Africa</td>
<td>+44 (0) 20 8867 3692</td>
</tr>
<tr>
<td>Australia</td>
<td>+1 800 707 703 or +61 (0) 29412 5450</td>
</tr>
<tr>
<td>New Zealand</td>
<td>+0800 505 515</td>
</tr>
</tbody>
</table>
## Contents

**Notices**................................................................................................................................................................................................. 2

**Corporate information**.................................................................................................................................................................................. 3

**Chapter 1: wIntegrate overview**.............................................................................................................................................................. 6

  **Introduction**........................................................................................................................................................................................... 6

  **wIntegrate features**................................................................................................................................................................................. 6

**Chapter 2: Getting started**........................................................................................................................................................................... 7

  **Starting a session**.................................................................................................................................................................................. 7

  **Opening multiple sessions**................................................................................................................................................................... 7

  **Setting up default startup sessions**............................................................................................................................................... 8

  **Setting up terminal emulation**....................................................................................................................................................... 8

  **Setting up communications**............................................................................................................................................................ 12

    **Setting up serial communications**........................................................................................................................................... 13

    **Setting up U2 SSH communications**....................................................................................................................................... 15

    **Setting up U2 SSL communications**....................................................................................................................................... 18

    **Setting up Windows Sockets (Telnet) communications**.......................................................................................................... 21

**Installing host programs**.......................................................................................................................................................................... 23

**Sharing the host programs**................................................................................................................................................................. 25

**Setting up shortcuts on the desktop**.............................................................................................................................................. 25

**Setting up the printer**......................................................................................................................................................................... 25

**Viewing the program settings**......................................................................................................................................................... 26

**Chapter 3: Customizing wIntegrate**....................................................................................................................................................... 27

  **Customizing the splash screen**......................................................................................................................................................... 27

  **Disabling the splash screen**........................................................................................................................................................... 27

  **Adding or removing toolbars**.......................................................................................................................................................... 28

  **Navigating through backpages**.................................................................................................................................................... 29

  **Changing the window colors**.......................................................................................................................................................... 29

  **Changing the colors of specific screen attributes**..................................................................................................................... 30

  **Changing the text style**................................................................................................................................................................. 31

  **Changing the character display**.................................................................................................................................................... 32

  **Resizing the window**....................................................................................................................................................................... 34

  **Changing the session title**............................................................................................................................................................. 34

  **Adding or removing scroll bars and the status bar**................................................................................................................... 35

  **Changing the session name**.......................................................................................................................................................... 35

  **Changing the communications’ port saving options**.................................................................................................................. 36

  **Closing the session automatically when the port is closed**......................................................................................................... 36

  **Preventing the session from closing if the port is open**............................................................................................................ 36

  **Trimming trailing spaces with clipboard operations**................................................................................................................ 37

  **Using edit keys for local editing**.................................................................................................................................................. 37

  **Consuming one U2 license for multiple host connections using Device Licensing**........................................................................ 37

  **Changing application preferences**.............................................................................................................................................. 38

  **Adding custom scripts**..................................................................................................................................................................... 39

  **Creating custom scripts**............................................................................................................................................................... 39

  **Customizing mouse and keyboard functions**.......................................................................................................................... 40

    **Assigning functions the mouse**................................................................................................................................................ 40

    **Assigning functions to the keyboard**...................................................................................................................................... 42

    **Creating a macro**...................................................................................................................................................................... 42

  **Creating a login script**................................................................................................................................................................. 44

  **Copying text**.................................................................................................................................................................................. 45

  **Copying text with Copy Special to**.......................................................................................................................................... 47

  **Recording and playing back data**............................................................................................................................................... 48

**Chapter 4: Transferring multivalued data**................................................................................................................................................. 50
Chapter 1: wIntegrate overview

wIntegrate is a connectivity tool that integrates host-based applications with the desktop. The initial interface is a terminal emulator with data transfer features designed for the multi-valued environments of UniVerse, UniData, D3, and mvBase. You can share data with popular Windows applications, including Microsoft Word and Excel.

For developers, a comprehensive programming language enables a range of options for integrating host environments with the desktop. You can add GUI features incrementally or create full GUI applications driven from the host.

A suite of host-based subroutines is supplied to control the PC. These subroutines are created for multi-valued environments, but the techniques used can be adapted to any host.

Developer tools include the Editor and a Tools menu with useful utilities. You can choose to display the Tools menu in Setup > Preferences. Select the Scripts tab and then use the Menu Bar Script drop-down list.

Introduction

This document provides a complete step-by-step guide to installing and setting up wIntegrate.

wIntegrate can be installed locally, as a thin client on Windows, or run as a thin client Java application/applet in a Web browser on Windows, Linux, and Macintosh. The Administrator and Monitor components are only applicable to the thin client installation.

wIntegrate features

All wIntegrate features are supported with Rocket's UniVerse, UniData, D3, and mvBase databases.

With wIntegrate, you can do the following tasks:

▪ Run concurrent sessions
▪ Customize a wIntegrate session
▪ Control any aspect of the application using powerful scripting language
▪ Optionally deploy a thin client on Windows or Java
▪ Run scripts from supplied host-based subroutines
▪ Define terminal emulations
▪ Export files from your PC to a host computer
▪ Import host computer files to your PC
▪ Transfer files from one host computer to another host computer
▪ Simplify deployment through optional thin client and browser interfaces
Chapter 2: Getting started

When wIntegrate is successfully installed, you can start a session and begin to customize and use wIntegrate.

For information about the configuration of terminal emulation, communications, and more, see Installation and Configuration.

Starting a session

When you start wIntegrate for the first time, the Session Wizard guides you through the process of creating a session.

1. Click the Windows Start button and select All Programs > wIntegrate > wIntegrate.
2. Follow the steps in the Session Wizard. Click Finish to complete the Session Wizard.

The login for your host computer appears.

After you save the wIntegrate session, the Session Wizard no longer appears each time that you start the application. If you need to use the wizard later, select File > Session Wizard from the wIntegrate toolbar.

The wIntegrate sessions are saved as .wic (configuration) files in the My Documents \wIntegrate\Session folder. You cannot edit these files with a text editor because the files are in a binary format; however, you can use the wIntegrate Editor to edit these files. For more information about the Editor, see the Client Scripting Reference guide.

The Session Wizard goes through the process of setting up communications and terminal emulation, as described in Setting up terminal emulation, on page 8 and Setting up communications, on page 12.

If you created a shortcut, as described in Setting up shortcuts on the desktop, on page 25, you can double-click it to open up a specific session.

Opening multiple sessions

You can open multiple sessions to the same host or to different hosts, subject to the hosts’ ability to support multiple connections.

About this task

When you start the wIntegrate application wInteg.exe, wIntegrate opens with the sessions listed in the Start Up Sessions tab from Setup > Application.

You can also start a specific session .wic file by double-clicking it. Many users leave the session .wic files in the default My Documents\wIntegrate\Sessions folder and put a shortcut to them on the desktop.

wIntegrate uses configuration files with .wic extension by default. These .wic files are non-editable binary files. You cannot use the same .wic file to open many sessions; instead, wIntegrate can make a temporary copy for each additional session. When you use a copy of a .wic file, you might want to make it a default session, but it is preferable to save the copied session with a new name by using File > Save As and changing the name. When you exit wIntegrate, you can set the session as default.

The number of sessions that can be opened is limited by Windows memory and resources.
Tip: The session .WIC files are stored in a binary format, so they cannot be edited by a text editor such as Notepad. However, you can edit them with syntax coloring with the wIntegrate Editor, which is installed with the local version when you enable Developer Additions during installation.

Procedure

1. If you have a session open, and want to open an additional one, from the wIntegrate toolbar, select File > Another.
2. From the Open Another Session dialog box, select the .wic file for the session that you want to open, and click Open.

Setting up default startup sessions

When you start wIntegrate, a single session is opened using Session1.wic. If you open more than one session, when you exit, you can configure wIntegrate to open those additional sessions at startup, as well.

Prerequisite

wIntegrate must be configured to display the Exit dialog box on exit in order to set up default startup sessions. To enable this option, select Setup > Application, and then select the Confirm exit check box.

Procedure

1. To set up a default startup session, from an opened session in wIntegrate, select File > Exit. The Exit dialog box appears.
2. Optional: Select the Save changes to session parameters check box. All of the settings for the current session such as font size, window size, position, and more options from the Setup > Preferences dialog box are saved to the session file that you are using.
3. Select the Default startup session check box. The current session starts automatically when you restart wIntegrate. You can select this option for each session that you want to start automatically.

To discontinue the automatic startup of any session, clear the Default startup session on the Exit dialog box when exiting the session. Do not delete the .wic file without first removing the session from the default startup list.

You can add or remove session from the startup list by selecting Setup > Application and clicking the Start up Sessions tab.

Setting up terminal emulation

In wIntegrate, you can select the type of terminal you want to emulate and set up terminal behavior options.
1. From the wIntegrate toolbar, select **Setup > Terminal**.

   The Terminal options appear.

   **Figure 1: Terminal options**

2. Select the terminal options:

   a. From the **Terminal emulation** list, select a terminal emulation type to select it.

      A short description of the type that is selected is displayed in the information box below the terminal emulation box.

      **Note:** If the terminal type you want to emulate is not listed in the Terminal Emulation box, you can create your own terminal emulation file. See the *Emulation Commands Reference* and *Client Scripting Reference* manuals for more information about modifying the behavior of the supplied emulation files or creating your own.

   b. From the **Extensions** list, select the type of extension setting to append additional emulation instructions to the selected terminal emulation. An extension is a separate file created with the emulation file syntax that is appended to the selected terminal emulation. You can select multiple extensions. For any extensions you do not need, click them to deselect them.

      A short description of the extension that is selected is displayed in the information box below the terminal emulation box.

      If you use a standard keyboard for a language other than English, select the extension with the corresponding country name to display local language character; for example, the **uk.wit** extension displays the pound sign (#) as (£).

      **Note:** Two extensions, cp437 and cp850, provide mapping of host characters from OEM code pages 437 and 850. Because these extensions are available, mapping for OEM code pages 437 and 850 is not supported in the ANSI, AT386, scoansi, VT100, VT220, and VT240 emulations.

   The following table describes the extensions.
### Table 1: Terminal emulation extensions

<table>
<thead>
<tr>
<th>Extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ansiprt</td>
<td>Converts the new page sequence that is used by ANDI and VT emulations to a standard FormFeed character when printing</td>
</tr>
<tr>
<td>arev</td>
<td>Supplements an ANSI/VT emulation to support escape used by AREV</td>
</tr>
<tr>
<td>cp437</td>
<td>Code page 437, providing 8-bit characters for both American and UK English languages</td>
</tr>
<tr>
<td>cp850</td>
<td>Code page 850, providing 8-bit characters for European languages</td>
</tr>
<tr>
<td>denmark</td>
<td>Provides character mapping for the Danish language</td>
</tr>
<tr>
<td>destructive_bs</td>
<td>Often required on AIX to ensure that the backspace key works as expected; select this option and the <strong>Delete (127)</strong> option in the Backspace drop-down menu</td>
</tr>
<tr>
<td>dontprt0</td>
<td>Prevents printing CHAR(0) when sending a report to the printer</td>
</tr>
<tr>
<td>dtapi</td>
<td>Provides subset character mapping for the Deskterm API</td>
</tr>
<tr>
<td>finland</td>
<td>Provides character mapping for the Finnish language</td>
</tr>
<tr>
<td>france</td>
<td>Provides character mapping for the French language</td>
</tr>
<tr>
<td>germany</td>
<td>Provides character mapping for the German language</td>
</tr>
<tr>
<td>id</td>
<td>Sends the wIntegrate version number in response to a request from the host. The host can check wIntegrate is active on this session before sending wIntegrate-specific instructions.</td>
</tr>
<tr>
<td>italy</td>
<td>Provides character mapping for the Italian language</td>
</tr>
<tr>
<td>key_ctrl</td>
<td>Enables viewing of backpages by using the Ctrl key with the up and down arrow keys or the page up and down keys</td>
</tr>
<tr>
<td>key_norm</td>
<td>Enables viewing of backpages by using the up and down arrow keys or the page up and down keys.</td>
</tr>
<tr>
<td>latinam</td>
<td>Provides character mapping for Latin American characters</td>
</tr>
<tr>
<td>mvdisp</td>
<td>Displays multi-value and multi-subvalue marks in more readable ASCII characters</td>
</tr>
<tr>
<td>norway</td>
<td>Provides character mapping for the Norwegian language</td>
</tr>
<tr>
<td>p9altkey</td>
<td>Alternate, long key definitions for Prism 9 keys</td>
</tr>
<tr>
<td>p9uk</td>
<td>Character mapping for Prism9 United Kingdom characters</td>
</tr>
<tr>
<td>sb</td>
<td>Provides SB/XA extensions for the VT100 emulation, allowing display of SB/XA boxes and more</td>
</tr>
<tr>
<td>sb_keys</td>
<td>Enables arrow keys that are required by some users of SB/XA</td>
</tr>
<tr>
<td>spain</td>
<td>Provides character mapping for the Spanish language</td>
</tr>
<tr>
<td>sweden</td>
<td>Provides character mapping for the Swedish language</td>
</tr>
<tr>
<td>tek</td>
<td>Provides extensions for the Tektronics emulation</td>
</tr>
<tr>
<td>uk</td>
<td>Provides character mapping for United Kingdom characters. For example, <strong>Shift+3</strong> shows the pound (£) sign</td>
</tr>
<tr>
<td>vtalkey</td>
<td>Provides the alternative keyboard for the VT100 emulation</td>
</tr>
<tr>
<td>vtcuroff</td>
<td>Disables host programming of the cursor keys</td>
</tr>
<tr>
<td>vtnumoff</td>
<td>Disables host programming of the numeric keys</td>
</tr>
<tr>
<td>wpu_vt</td>
<td>Provides WordPerfect for UNIX extensions for the VT340 emulation</td>
</tr>
</tbody>
</table>

**c.** In the Screen section, select the number of **columns**, **lines**, and **backpages**. Columns affect the width of the main window. The default setting is 80 columns; 132 columns is often used to view reports. You can select any value up to 255.
Lines affect the height of the main window. The default setting is 24 lines per page; you can select any value up to 255.

Backpages are previous pages of text that is displayed in the wIntegrate window. The default setting is 33; you can select any number up to 999.

d. From the **Cursor** box, select the type of cursor you want wIntegrate to display.
   - **Block:** ▌
   - **Line:** _

Select the **Blink** check box to make the selected cursor type flash.

e. From the **Backspace** drop-down menu, select how the host accepts the backspace instruction.

The default option, **Normal**, sets the backspace to ASCII character 8. The **Delete** option sets the backspace to ASCII character 127.

f. If you want the function and edit key definition to be automatically set according to the selected terminal emulation or extensions, select the **Load key definitions** check box.

The check box is selected by default. Be sure to clear this check box if you have reopened the Terminal options without the intention of loading key definitions.

---

**Warning:** If you remapped your function keys or edit keys, for example, by assigning a script or a macro, your changes are overwritten if you select the **Load key definitions** check box. Clear the **Load key definitions** check box if you have custom settings for the function keys or edit keys.

---

g. From the **Host Encoding** drop-down menu, specify the host encoding to take place between characters that are entered and displayed on the PC and on the host.

Your selection should match the character encoding on the U2 server. In some cases, these options overlap. The objective is to match the PC and host settings. The following table describes each host encoding option.

<table>
<thead>
<tr>
<th>Encoding type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>wIntegrate uses Latin I on a single-byte language version of Windows, and “Local” on multibyte Windows. This setting works for western languages.</td>
</tr>
<tr>
<td>Latin I</td>
<td>No conversion. This is how previous versions of wIntegrate worked. It is usable only for 8-bit character sets (for example, when European languages are used on the PC and host). In these circumstances, the Local option achieves the same results as Latin I; however, Latin I is faster because it does no conversion.</td>
</tr>
<tr>
<td>Local</td>
<td>Uses the same settings as the local Windows computer. Use Local for multi-byte languages other than Simplified Chinese, for example Japanese and Korean. The character set must be the same on Windows and the host. This option also works for single-byte character sets, but Latin I is a better option in these circumstances.</td>
</tr>
<tr>
<td>GB18030</td>
<td>Use this option with Simplified Chinese. Characters are sent to and received from the host in the GB18030 format that is required for Chinese systems.</td>
</tr>
<tr>
<td>Thai</td>
<td>Use this option with Thai.</td>
</tr>
<tr>
<td>Encoding type</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
</tr>
<tr>
<td>UTF-8</td>
<td>UTF-8 is the standard encoding method for Unicode characters, which is the universal character set designed to encode every written character. Use UTF-8 when you want to display characters that are not part of the current Windows language setting. For example, use UTF-8 when the local PC is set to English and the U2 host application is Japanese. UniVerse NLS stores data in UTF-8 format.</td>
</tr>
<tr>
<td>UVUTF-8</td>
<td>UVUTF-8 is a modified version of UTF-8, more appropriate for users of multi-valued systems. There are some issues when using UTF-8 with UniVerse NLS because of the characters 255 (IM), 254 (AM), 253 (VM), 252 (SVM), and 251 (Text Mark). These have a special function as delimiters within UniVerse. Internally, wintegrate uses the following Unicode characters to represent the multi-valued delimiters: 255 (IM) - U+F8FF 254 (AM) - U+F8FE (also known as FM) 253 (VM) - U+F8FD 252 (SVM) - U+F8FC 251 (TM) - U+F8FB There is no visual representation for these characters, so they show on the wintegrate window as squares.</td>
</tr>
</tbody>
</table>

h. If you want to convert Unicode characters as they are sent to the host, select the *Smart Input Conversion* check box.

Smart input conversion is useful if you use programs that use the “smart” characters; for example, Microsoft Word might automatically convert simple quotation marks to look like they are opening or closing. If you paste text into the wintegrate window from Word with the Smart Input Conversion selected, the characters are converted to ASCII characters that the U2 host can work with.

The characters that are converted are located in the `inputmap.txt` file in the `C:\Program Files\wIntegrate` folder and can be manually changed. The following describes entered characters and their conversions.

<table>
<thead>
<tr>
<th>Entered character</th>
<th>Conversion</th>
</tr>
</thead>
<tbody>
<tr>
<td>'</td>
<td>'</td>
</tr>
<tr>
<td>'</td>
<td>'</td>
</tr>
<tr>
<td>“</td>
<td>&quot;</td>
</tr>
<tr>
<td>”</td>
<td>&quot;</td>
</tr>
<tr>
<td>TM</td>
<td>TM</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
</tr>
</tbody>
</table>

3. Click **OK**.

4. From the wintegrate toolbar, select **File > Save** to save the session with the terminal settings or select **Save As** if you want to save the session as a new wintegrate session configuration (.wic) file.

**Setting up communications**

In wintegrate, you can set up or change communications with a host computer. After you set up communications, you can save your settings as part of the configuration file for the session. You can
set up multiple wIntegrate sessions to communicate with different host computers or to communicate with the same host computer.

wIntegrate offers the following types of communications:

▪ Serial, as described in Setting up serial communications, on page 13
▪ U2 SSH as described in Setting up U2 SSH communications, on page 15
▪ U2 SSL as described in Setting up U2 SSL communications, on page 18
▪ Windows Sockets as described in Setting up Windows Sockets (Telnet) communications, on page 21

Setting up serial communications

To set up serial communications, perform the following steps:

1. From the wIntegrate toolbar, select Setup > Communications.
2. In the Communications dialog box, select Serial.
3. Click Setup.
   The Serial Communications dialog box appears.

4. From the Port drop-down menu, select a port.
5. Select a Baud Rate and Parity option.

   Baud is a unit of signaling speed. The baud rate controls the speed of data transfer between the PC and the host. If a parity is selected, a parity bit is used to ensure that data is transmitted accurately. The parity options are described in the following table:

   Table 3: Parity checking options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>No parity checking.</td>
</tr>
<tr>
<td>Odd</td>
<td>Odd parity checking. Bits are counted in each group before it is sent. If a group has an even number of bits, the parity bit is set to 1 so that the total number of bits transmitted is an odd number. If a group already has an odd number of bits, the parity bit is set to 0. If you select this option, the host computer must also use odd parity checking.</td>
</tr>
<tr>
<td>Even</td>
<td>Even parity checking. Bits are counted in each group before it is sent. If a group has an odd number of bits, the parity bit is set to 1 so the total number of bits transmitted is an even number. If a group already has an even number of bits, the parity bit is set to 0. If you select this option, the host computer must also use even parity checking.</td>
</tr>
</tbody>
</table>
Chapter 2: Getting started

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mark</td>
<td>Always sets the parity bit to 1.</td>
</tr>
<tr>
<td>Space</td>
<td>Always sets the parity bit to 0.</td>
</tr>
</tbody>
</table>

6. Click the **Advanced** tab.

Figure 3: Serial Communications – Advanced tab

7. Select the number of **Data Bits** to represent each character that is transmitted between the PC and the host.

8. Select the number of **Stop Bits**. This number represents the end of each character that is transmitted between the PC and the host.

9. Select the **Flow Control**. Flow control adjusts the flow of data between the PC and the host computer to ensure that the receiver can process all of the incoming data. This is important when the sender can send data faster than the receiver can receive it. Flow control can be implemented in software or hardware.

   **Note:** It is not recommended to select **None** because you can lose characters, and your communication line can hang.

10. If you are experiencing a problem with garbage characters appearing on your screen, select the **Zero Top Bit** check box. This option is only available if the Data Bits option is set to 8.

    Garbage character problems sometimes occur when certain computers communicate. You usually need to use the zero top bit option on UNIX computers.

11. If you want wIntegrate to report parity errors, select the **Parity Check** check box.

12. If you want wIntegrate to display framing errors, select the **Report Errors** check box.

13. In the **Transmit Delay** field, enter the number of milliseconds to pause between blocks of characters that are transmitted to the host.

    The larger the value, the slower the communications are. The default setting of 0 is recommended if you are not losing data between the PC and the host computer.

14. In the **Transmit Block Size** field, enter the number of characters in each block that is transmitted to the host computer.

    Enter 0 to specify the fastest possible transmission with no restriction on the number of characters in each block. Numbers greater than 0 indicate the number of bytes to transmit at a time. The larger the number, the faster the communication is. The default setting of 0 is recommended if you are not losing data between the PC and the host computer.

   **Tip:** You typically have to adjust Transmit Delay and Transmit Block Size when a fast PC is communicating with a slow host and can send characters faster than the host can process them. As a first step in troubleshooting lost characters, try setting **Transmit Block Size** to
1. Set the Connect Speed to 100 and Transmit Delay to 50; then tune the parameters to find the optimum combination of performance and reliability.

15. On the Serial Communications dialog box, click OK.
16. On the Communications dialog box, verify that the Open check box is selected. Click OK.
17. The wIntegrate window prompts you for your login credentials. Log in using the credentials for the host computer.
18. Save the communications as part of your current configuration file by selecting from the toolbar File > Save, or select Save As if you want to save the session as a new .wic file.

Setting up U2 SSH communications

To set up U2 SSH communications, perform the following steps:
1. From the wIntegrate toolbar, select Setup > Communications.
2. In the Communications dialog box, select U2 SSH.
3. Click Setup.
   The U2 SSH Communications dialog box appears.

4. In the Host field, enter the name or IP address of the host computer with which you want to communicate.
5. If your server uses another port for Telnet or you are not using Telnet to communicate with the host computer, enter a different number in the Port field. Otherwise, the default value is sufficient.
6. Click the SSH tab.

![Figure 5: U2 SSH Communications – SSH tab](image)

7. In the Protocol section, select a protocol type.

8. The Terminal Type drop-down menu contains the same terminal emulation types as defined in Setting up terminal emulation, on page 8. In some cases, a host does not support communications with the terminal type you are emulating, but it supports a close approximation. In this case, select a terminal type from the Terminal Type drop-down menu, or enter a custom value.

   If you change the terminal emulation type in Setup > Terminal after you select a different Telnet terminal type, wIntegrate resets the Telnet terminal type to the setting taken from the terminal emulation .wic file. This is usually the same as the terminal name.

9. In the Client Authentication Key Filename field, click the ellipsis button (…) to open a file browser, and select a file.

10. Click the Logging tab.

![Figure 6: U2 SSH Communications – Logging tab](image)

11. In the Log Filename field, enter the name that you want for the file.

12. In the Log File Mode section, select whether to append to the existing file or to overwrite the existing file every time a new session starts.

   **Warning:** If you select Append mode, be aware that the log file will grow until it fills up your hard disk.

13. In the Log section, select the types of information to log.
14. Click the Advanced tab.

**Figure 7: U2 SSH Communications – Advanced tab**

15. In the Transmit Delay field, enter the number of milliseconds to pause between blocks of characters that are transmitted to the host.
   
   The larger the value, the slower the communications are. The default setting of 0 is recommended if you are not losing data between the PC and the host computer.

16. In the Transmit Block Size field, enter the number of characters in each block that is transmitted to the host computer.
   
   Enter 0 to specify the fastest possible transmission with no restriction on the number of characters in each block. Numbers greater than 0 indicate the number of bytes to transmit at a time. The larger the number, the faster the communication will be. The default setting of 0 is recommended if you are not losing data between the PC and the host computer.

   **Note:** You do not typically need to use the transmit settings with a U2 SSH connection; however, you might encounter an instance where hardware on slow servers is unable to keep up with incoming data, and transmit settings are necessary.

17. Select the D3 Enterprise Licensing check box if you want to take advantage of Enterprise Licensing when connecting to a D3 host.
   
   This causes a D3 host to treat all connections that use this feature from the same computer as a single user for licensing purposes.
   
   D3 Enterprise licensing is not available on the Java thin client as it requires a Windows-specific library.

18. Select the Keep Alive check box to enable the TCP/IP function.
   
   This function sends meaningless packets to the host to prevent it from closing the connection because of inactivity.
   
   If selected, enter the interval time (in seconds) to send packets. This value should be less than the length of time before the host closes an inactive session.

19. On the U2 SSH Communications dialog box, click OK.

20. On the Communications dialog box, verify that the Open check box is selected. Click OK.

21. The wIntegrate window prompts you for your login credentials. Log in using the credentials for the host computer.

22. Save the communications as part of your current configuration file by selecting from the toolbar File > Save, or select Save As if you want to save the session as a new .wic file.
Setting up U2 SSL communications

To set up U2 SSL communications, perform the following steps:

1. From the wIntegrate toolbar, select **Setup > Communications**.
2. In the Communications dialog box, select **U2 SSL**.
3. Click **Setup**.
   
The U2 SSL Communications dialog box appears.

4. In the **Host** field, enter the name or IP address of the host computer with which you want to communicate.
5. If your server uses another port for Telnet or you are not using Telnet to communicate with the host computer, enter a different number in the **Port** field. Otherwise, the default value is sufficient.
6. Click the **Telnet** tab.

7. **Terminal Type** drop-down menu contains the same terminal emulation types as defined in **Setting up terminal emulation**, on page 8. In some cases, a host does not support communications with the terminal type you are emulating, but it supports a close approximation. In this case, select a terminal type from the **Terminal Type** drop-down menu, or enter a custom value.
   
   If you change the terminal emulation type in **Setup > Terminal** after you select a different Telnet terminal type, wIntegrate resets the Telnet terminal type to the setting taken from the terminal emulation .wic file. This is usually the same as the terminal name.
8. From the **Break Signal** drop-down menu, specify what action is taken when you press the **Ctrl + Break** keys.
   - **Break**: Sends the Telnet Break instruction. This can be used by a host system to break an application program and show options such as Continue and Quit.
   - **Interrupt**: Sends the Telnet Interrupt instruction. This usually closes the communications port and disconnects the PC.
9. Select the **Host Echo** check box if you want the host to transmit the data it receives back to your PC so you can see what you entered.
10. Select the **Binary Mode** check box if you want to enable communications in binary mode.
    Most PCs and hosts communicate by using seven-bit ASCII displayable characters. Binary mode enables the host and PC to send and receive eight-bit non-displayable characters. Most hosts support eight-bit communication even when not in binary mode.
11. Select the **TCP No Delay** check box if you want to speed up communications with the host.
    This option disables the Nagle algorithm, which can delay each outgoing packet for 200 ms while waiting for any additional data for the packet. When TCP No Delay is selected, packets are sent immediately. This might improve the speed of response, but make network utilization a little less efficient by sending a larger number of smaller packets.

    UniVerse and UniData also support options to disable the Nagle algorithm. See the relevant documentation regarding details on how to disable it.
12. Select the **Keep Alive** check box to enable the TCP/IP function.
    This function sends meaningless packets to the host to prevent it from closing the connection because of inactivity.
    If selected, enter the interval time (in seconds) to send packets. This value should be less than the length of time before the host closes an inactive session.
13. In the **Transmit Delay** field, enter the number of milliseconds to pause between blocks of characters that are transmitted to the host.
    The larger the value, the slower the communications are. The default setting of 0 is recommended if you are not losing data between the PC and the host computer.
14. In the **Transmit Block Size** field, enter the number of characters in each block that is transmitted to the host computer.
    Enter 0 to specify the fastest possible transmission with no restriction on the number of characters in each block. Numbers greater than 0 indicate the number of bytes to transmit at a time. The larger the number, the faster the communication will be. The default setting of 0 is recommended if you are not losing data between the PC and the host computer.

**Note:** You do not typically need to use the transmit settings with a U2 SSL connection; however, you might encounter an instance where hardware on slow servers is unable to keep with incoming data, and transmit settings are necessary.
15. Click the SSL tab.

![Figure 10: U2 SSL Communications – SSL tab](image)

16. In the Protocol section, select a protocol type.

17. In the Server Check section, select whether the server certificate should be checked with the Strict setting.

18. In the Tracing section, select the depth tracing should be performed.

   The default location of the trace file is the Documents folder.

   **Note:** Tracing should be used with caution as the trace files can grow to any size on disk. Trace files will grow continuously while the connection is open, even though you are not active on the session.

19. In the Server Certificate Check section, select Automatic, or enter a specific CA certificate. You can enable Client Authentication by entering a certificate name in the Client Certificate field. Client Authentication is where the server authenticates the client attempting to make a connection to it by examining the client’s certificate. It should be the name of a certificate as it appears in the local Windows Certificate Stores (typically the personal or “My” user store is used). If there is no certificate name specified, then no Client Authentication will take place.

20. If you only want to proceed with connections where the server certificate has a specific name, then enter that name in the Trusted Name field.

   Provided a server certificate is valid, a connection will proceed if the server certificate name matches the value entered here. If there is no match, a warning message displays before a connection can proceed. The name matching is case-insensitive.

   If no value is entered for Trusted Name, then the name or address used to specify the server to connect to will be automatically assumed.

   There are two mechanisms that provide flexibility when specifying a Trusted Name:
     - Multiple names can be specified each separated by a semicolon (;). The server certificate name must match one of these names for a connection to proceed.
     - A name can contain wildcard characters. The underscore (_) character matches a single character in the server certificate name, and the percent symbol (%) matches any sequence of characters. For example, a trusted name of %.mydomain.com will match server certificate names of myserver.mydomain.com or herserver.mydomain.com and a trusted name of server_.mydomain.com will match server certificate names of server1.mydomain.com or server2.mydomain.com.

21. On the U2 SSL Communications dialog box, click OK.

22. On the Communications dialog box, verify that the Open check box is selected. Click OK.
Setting up Windows Sockets (Telnet) communications

To set up Windows Sockets (Telnet) communications, perform the following steps:

1. From the wIntegrate toolbar, select **Setup > Communications**.
2. In the Communications dialog box, select **Windows Sockets**.
3. Click **Setup**.
   
   The Windows Sockets Communications dialog box appears.

4. In the **Host** field, enter the name or IP address of the host computer with which you want to communicate.
5. Click the **Advanced** tab.

6. If your server uses another port for Telnet or you are not using Telnet to communicate with the host computer, enter a different number in the **Port** field. Otherwise, the default value is sufficient.
7. The **TELNET** check box is selected by default. Leave this selected if you want wIntegrate to perform Telnet negotiation with the host server.
   
   If you clear the **TELNET** check box, the Telnet negotiation is disabled and you can work with non-Telnet connections. For example, you might want to disable Telnet negotiation when two computers running wIntegrate are communicating with each other.
8. If you are experiencing a problem with garbage characters appearing on your screen, select the **Zero Top Bit** check box.

23. The wIntegrate window prompts you for your login credentials. Log in using the credentials for the host computer.

24. Save the communications as part of your current configuration file by selecting from the toolbar **File > Save**, or select **Save As** if you want to save the session as a new `.wic` file.
Garbage character problems sometimes occur when certain computers communicate. You most likely do not need to change this setting with a Telnet connection.

9. Select the **TCP No Delay** check box if you want to speed up communications with the host.
   
   This option disables the Nagle algorithm, which can delay each outgoing packet for 200 ms while waiting for any additional data for the packet. When TCP No Delay is selected, packets are sent immediately. This might improve the speed of response, but make network utilization a little less efficient by sending a larger number of smaller packets.
   
   UniVerse and UniData also support options to disable the Nagle algorithm. See the relevant documentation regarding details on how to disable it.

10. Select the **Keep Alive** check box to enable the TCP/IP function.
   
   This function sends meaningless packets to the host to prevent it from closing the connection because of inactivity.
   
   If selected, enter the interval time (in seconds) to send packets. This value should be less than the length of time before the host closes an inactive session.

11. In the **Transmit Delay** field, enter the number of milliseconds to pause between blocks of characters that are transmitted to the host.

   The larger the value, the slower the communications are. The default setting of 0 is recommended if you are not losing data between the PC and the host computer.

12. In the **Transmit Block Size** field, enter the number of characters in each block that is transmitted to the host computer.

   Enter 0 to specify the fastest possible transmission with no restriction on the number of characters in each block. Numbers greater than 0 indicate the number of bytes to transmit at a time. The larger the number, the faster the communication will be. The default setting of 0 is recommended if you are not losing data between the PC and the host computer.

   **Note:** You do not typically need to use the transmit settings with a Windows Sockets connection; however, you might encounter an instance where hardware on slow servers is unable to keep with incoming data, and transmit settings are necessary.

13. Click the **Telnet** tab.

   **Figure 13: Windows Sockets Communications – Telnet tab**

14. The **Terminal Type** drop-down menu contains the same terminal emulation types as defined in Setting up terminal emulation, on page 8. In some cases, a host does not support communications with the terminal type you are emulating, but it supports a close approximation. In this case, select a terminal type from the **Terminal Type** drop-down menu, or enter a custom value.

   If you change the terminal emulation type in Setup > Terminal after you select a different Telnet terminal type, wintegrate resets the Telnet terminal type to the setting taken from the terminal emulation .wic file. This is usually the same as the terminal name.
Installing host programs

15. From the **Break Signal** drop-down menu, specify what action is taken when you press the **Ctrl + Break** keys.
   - **Break**: Sends the Telnet Break instruction. This can be used by a host system to break an application program and show options such as Continue and Quit.
   - **Interrupt**: Sends the Telnet Interrupt instruction. This usually closes the communications port and disconnects the PC.

16. Select the **Host Echo** check box if you want the host to transmit the data it receives back to your PC so you can see what you entered.

17. Select the **Binary Mode** check box if you want to enable communications in binary mode.
   Most PCs and hosts communicate by using seven-bit ASCII displayable characters. Binary mode enables the host and PC to send and receive eight-bit non-displayable characters. Most hosts support eight-bit communication even when not in binary mode.

18. Select the **D3 Enterprise Licensing** check box if you want to take advantage of Enterprise Licensing when connecting to a D3 host.
   This causes a D3 host to treat all connections that use this feature from the same computer as a single user for licensing purposes.
   D3 Enterprise licensing is not available on the Java thin client as it requires a Windows-specific library.

19. On the Windows Sockets Communications dialog box, click **OK**.

20. On the Communications dialog box, verify that the **Open** check box is selected. Click **OK**.

21. The wIntegrate window prompts you for your login credentials. Log in using the credentials for the host computer.

22. Save the communications as part of your current configuration file by selecting from the toolbar **File > Save**, or select **Save As** if you want to save the session as a new **.wic** file.

### Installing host programs

The wIntegrate host programs support file transfers and other advanced communication between the PC and the host computer. You must install these programs before you can transfer information and perform other operations between the host computer and the PC. New versions of the host programs are always backward-compatible with earlier releases of the program. New releases do not disable earlier functionality.

#### Prerequisite

- The wIntegrate communications protocol must match the host computer protocol. For steps, see Setting up communications, on page 12.

#### About this task

Because some wIntegrate host programs are host-dependent, you must specify the type of host computer that you are using.

The host programs consist of the file transfer and host API programs. The two types of programs can be installed at the same time or separately. If you want to use wIntegrate’s Query Builder to create reports, you must install the host API.

You can install the host programs in any account on your system where you have adequate permissions to create files and compile and catalog programs.
**Note:** If the host programs are already installed in another account on the host computer, you can share the programs by using the WIN.SHARE program. See *Sharing the host programs, on page 25.*

**Procedure**

1. Start a wIntegrate session, and log on to the host computer.
2. Open the host system database prompt.
3. From the wIntegrate window toolbar, select **Run > Script**. A Run Script file browser appears.
4. In the Run Script file browser, navigate to `C:\Program Files (x86)\wIntegrate\Host`, and select `inst_pgm.wis`. Click **Open**. The Host program information dialog box appears.

**Figure 14: Host program installation**

5. From the Host program installation dialog box, select the check box next to the type of programs you want to install.

**Note:** You can install the host API only if you previously installed the file transfer programs or if you are installing the file transfer programs at the same time.

6. In the Machine Name list, select the host database that you are using with wIntegrate. If your machine is not listed, select one with a GENERIC type.
7. **Click OK**. The installation script performs the following tasks:
   - Creates the WIN.PROGS program directory in the database account.
   - Creates the MACHINE.TYPE record in the WIN.PROGS directory, defining the database/machine type in attribute 1.
   - Installs the WIN.BOOT program in the WIN.PROGS directory.
   - Compiles and runs WIN.BOOT. This program has only one function—to initiate the error-checked export of programs from the PC to the host. wIntegrate exports the same programs to the host computer regardless of machine type. During export to the host computer, the Export File Monitor appears.
If you chose to install the host API, the file BP_HAPI.TXT is also exported to WIN.PROGS.

- Compiles and catalogs the host programs.

8. Verify wIntegrate window reads, “Host Application Program Interface INSTALLED.”

Sharing the host programs

After you install the host programs in one account, you can run the WIN.SHARE program to enable another account to run the host programs.

1. Start a wIntegrate session, and log on to the account in which you installed the host programs.
2. Type WIN.SHARE, and press Enter.
3. Enter the full UNIX path for the account to share the host programs, and press Enter.
   A pointer is created from the shared account to the host programs account. You can now use the host programs to transfer files into the other account.

Setting up shortcuts on the desktop

You might want to set up several wIntegrate shortcuts on your desktop if you run sessions on different host computers, or if you run sessions with different configurations connected to the same host. For example, you might want one session for email and another for a host application.

Prerequisite

Before you start this procedure, open a wIntegrate session and configure it as you want. Save the session as a .wic file.

 Procedure

1. On your desktop, right-click and select New > Shortcut.
2. In the Create Shortcut wizard, navigate to the location of the wIntegrate configuration file for the session for which you want to create a shortcut. Click Next.
3. Enter a name for the shortcut. Click Finish.
4. To customize the icon that is used for the shortcut, right-click the shortcut and select Properties.
5. Click the Shortcut tab. Click the Change Icon button.
6. Change the path to C:\Program Files (x86)\wIntegrate\wInteg.exe, and select a shortcut icon. Click OK.

Setting up the printer

You can select a printer for a wIntegrate session without changing the Windows default printer, for example if you want to print on custom stationery as part of your application.

1. From the main toolbar, select File > Printer Setup.
2. In the Printer Setup dialog box, select the Specific Printer option.
3. Select a printer from the list.
4. Optional: Select the other options for font, character mapping, and more as needed.
   - If you want wIntegrate to send data directly to the printer without any formatting, select the Print direct check box. Use this option to print host data in the same format as you received it.
5. Click OK.
6. **Optional:** Save the custom settings as part of the session configuration file by selecting **File > Save** from the toolbar, or select **Save As** if you want to save the session as a new .wic file.

### Viewing the program settings

Windows uses its Registry to store references to applications and their components. You can use the Check Installation program to view these settings. This is not normally required, but it is a useful troubleshooting aid if you have any unexpected issues with the application.

To open the wCheck program, click the Windows **Start** button and select **All Programs > wIntegrate > Check Installation**.

The wCheck program opens with a list of the components that are used by the application, including the main “wIntegrate Document” called wInteg.exe.

*Figure 15: Environment*

A full discussion of modifying the Registry is beyond the scope of this document. However, what you should see in the wCheck program is that all of the components are checked to denote that they are registered, they are in the same folder location, and they are of the same version.
Chapter 3: Customizing wIntegrate

You can customize how wIntegrate looks by editing the properties using the File and Setup toolbar options. You can name a session, change screen colors and keyboard settings, and select toolbars to help you perform your everyday tasks more efficiently. Moreover, you can create custom scripts to run automatically and modify the settings or perform tasks.

Customizing a wIntegrate session helps you distinguish one session from another. If you save each configuration as a unique .wic file, you can have wIntegrate sessions that connect to different host computers, or multiple sessions for different purposes on the same computer. For example, you can save a wIntegrate configuration with blue text on a black background that you use for your data entry, and save another configuration with black text on a white background that you use for running reports.

Tip: Some of the dialog boxes for customization options have a Default button. If you make changes and decide not to use them, click the Default button to change the settings back to the wIntegrate defaults. The actions of the Default buttons are defined by scripts in the C:\Program Files (x86)\wIntegrate\wIntSys\Default folder. You can modify these scripts to customize the behavior of the Default buttons.

Customizing the splash screen

When wIntegrate is started, the wIntegrate splash screen is displayed before the session completes its opening. The same screen is displayed when you select Help > About in wIntegrate. You can customize both the splash screen and About screen by adding a custom image.

1. Navigate to the installation directory.
   If you installed wIntegrate in the default folder, the location is C:\Program Files (x86)\wIntegrate.

2. Open the Image folder.
   For the splash screen, the startup procedure looks for a bitmap named OEM_ST.BMP in the Image folder. If found, this image is used in place of the standard wIntegrate image on both the splash screen and the Help > About screen. If a different image is required for Help > About, create a second image OEM_AB.BMP.
   The product version, user license information, and copyright statement are overlaid on the bitmap using a white font and cannot be changed.

3. Add your customized OEM_ST.BMP file for the splash screen image, and optionally add the OEM_AB.BMP file for a different About screen image.
   For best results, the bitmap should be 650x460 pixels saved as a 24-bit bitmap.

Disabling the splash screen

If you do not want to see the splash screen upon startup, you can disable it.

1. Navigate to where the shortcut for wIntegrate is installed.
   When wIntegrate is installed, it is placed in the wIntegrate program group in the Windows Start menu (Start > All Programs > wIntegrate). You could have also installed a shortcut to the desktop.

2. Open the properties of the shortcut by right-clicking the shortcut and selecting Properties.
3. In the Target field, append `-nobanner` after the closed quotation mark, as shown in the following example.

Figure 16: wIntegrate properties

![wIntegrate properties dialog box](image)

4. Click **Apply**.
5. Click **OK**.

Adding or removing toolbars

You can modify which toolbars are displayed in the main window. You can do this in a couple of ways. One way is using the **Setup > Preferences** method, described in the following steps.

1. From the main wIntegrate toolbar, select **Setup > Preferences**.
2. Click the **Toolbars** tab.
3. Select the check box next to the toolbars that you want. Clear the check boxes next to the toolbars that you do not want. Click **OK**.
   The toolbars appear on the wIntegrate window.

Another way to add or remove toolbars is right-clicking anywhere near the toolbars to show a context menu where the same toolbar options are available that are in the Preferences dialog box, as shown in the following figure.
Navigating through backpages

The navigation icons on the general toolbar allow you to navigate through up to 33 backpages.

You can change the default value of 33 by selecting **Setup > Terminal** from the main toolbar. For more details, see Setting up terminal emulation, on page 8.

**Note:** When navigating through backpages, you might not realize that your screen is on a backpage. The keystrokes do not appear, and the session appears to be hanging. You can check whether a backpage is displayed by looking at the Status bar.

Changing the window colors

You can customize the look of the wIntegrate window by modifying the background and foreground colors. You can select a standard theme or create your own.

You can do this task in a couple of ways. One way is using the **Setup > Colors** method, described in the following steps.

---

**Figure 17: Right-click context menu**

Select any of the options that you want to add to the wIntegrate window. If you removed the main toolbar (named MainMenu), you can right-click the title bar and select **Restore Menu** to restore it.

Additionally, you can move the toolbars and dock them to the bottom of the window.

**Note:** You can modify any of the toolbars and even create your own by using scripting. For more information, see Client Scripting Reference.
1. From the main toolbar, select **Setup > Colors**.

   ![Colors dialog box](image)

   **Figure 18: Colors**

2. Click **Open**.

3. From the Load Color Settings dialog box, select a color scheme, and then click **Open**.

4. Click **OK** to close the Colors dialog box.

   The display changes to the selected color scheme.

5. **Optional:** Save the custom settings as part of the session configuration file by selecting **File > Save** from the toolbar, or select **Save As** if you want to save the session as a new .wic file.

   Another way to change the window color is right-clicking anywhere near the toolbars, and selecting **bar_tech** to show the technical toolbar, as shown in the following figure.

   ![Technical toolbar](image)

   **Figure 19: Technical toolbar**

   From the top drop-down menu, select a different color scheme, and click the **Apply** icon to apply a standard theme. Note that the options that are available in the **bar_tech** toolbar are the same options that are listed in the Load Color Settings dialog box.

**Changing the colors of specific screen attributes**

You can customize the look of the wIntegrate window by modifying the specific screen attributes that are shown.
1. From the main toolbar, select **Setup > Colors**.

![Colors dialog box](image)

2. Verify that the **Normal** attribute is selected.
   The Normal attribute defines the colors of the text that you most often see in the wIntegrate window.
3. Click **Foreground** to select a color for the text.
4. Click **Background** to select a background color.
5. After you change the colors, click **Apply**.
   The wIntegrate window updates to the colors that are selected.
6. Select other attributes to modify by using the same process that is described in steps 2-5.

   **Tip:** Click each attribute until the text in the Example Text box looks like the highlighted text in the wIntegrate main window. You can change the color and style of highlighted text to your preference.

7. To save the foreground and background color combination as a script that you can use in future sessions, click **Save**, and enter a name for the wIntegrate script file for the color combination that you selected. wIntegrate appends the .wis file extension by default. Click **Save**.
   You can select this script later by clicking **Open** in the Colors dialog box or by selecting it from the drop-down menu on the **bar_tech** toolbar, where it is automatically added.
8. Click **OK** to close the Colors dialog box.
9. **Optional:** Save the custom settings as part of the session configuration file by selecting **File > Save** from the toolbar, or select **Save As** if you want to save the session as a new .wic file.

### Changing the text style

You can superimpose a graphical style on specific screen attributes such as Normal and Dim. Results will depend on how your application uses screen attributes. You can change the style in the Colors dialog box.

1. From the main toolbar, select **Setup > Colors**.
2. From the **Attributes** list, select an attribute.
3. From the **Styles** drop-down menu, select a text style to apply to the selected attribute.
   If you select any text style other than None, the text style has borders.
4. You might want to join consecutive lines of the same effect to prevent wIntegrate from drawing extra borders between them. If you do not want wIntegrate to draw the border style between lines of the same effect, select the Join Lines check box.

5. If you selected any text style other than None, select the Use Styles check box. This option enables wIntegrate to display styles as the etched chiseled effect based on the attributes that are used in the terminal screen. If you do not select this check box, a chiseled effect might be displayed with no border.

**Tip:** The added borders are displayed around the screen text so that they can overlap into the lines above and below. You can insert extra line space between the lines to accommodate the borders, as described in Changing the character display, on page 32.

6. Click OK to close the Colors dialog box.

7. **Optional:** Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.

---

### Changing the character display

You can select a different font style and size in the Character dialog box for the wIntegrate window. The font size controls the width and height of displayed characters. You can also auto scale the wIntegrate window to accommodate a new font size.

#### About this task

The font size is the limiting factor in what size a window can be, and the width of the font has priority over the height. For a given window size, if there is no font available that can display the 80 or 132 columns exactly, and Auto Scaling is off, the text will either extend to the right of the window border, requiring a horizontal scroll bar, or not fill the full width of the window. In either case, the vertical dimension of the window changes to fit the selected number of lines using the height of the font. If Auto Scaling is on, you cannot set the window dimensions; they are set automatically to fit the closest available font.

By selecting a different font size, you can set up your display to suit the current task. For example, if you are working exclusively on the host, you might want the host window to fill the screen. At other times, you might want to shrink the host window and work in other application windows.
Procedure

1. From the main toolbar, select **Setup > Character**.

Figure 21: Character

```
 Character
 Font: @B5font 
 Size: 8x12 
 Extra Line Space: 0 

Invalid characters: 
 Display
 Do Not Display
 Decimal Display

Sample: This is sample text
```

2. Select the font face and size.
   Only fixed-pitch Windows fonts such as Consolas, Courier, and Terminal are available.

   **Tip:** You can also change the font size without using the Character dialog box by selecting the increase font (▲) or decrease font (▼) icons on the general toolbar. If the general toolbar is not visible, see [Adding or removing toolbars, on page 28](#) for instructions on how to add it.

3. In the **Extra Line Space** drop-down menu, you can add vertical space (measured in pixels) between lines in the display.

4. If you select the **Auto Scaling** check box, when you click and drag a window border or corner, the font automatically changes to fit the new window size to accommodate the number of Columns and Lines that are specified in the **Setup > Terminal** dialog box.

   **Note:** If the window is too small for the selected font size, some of the text and toolbars that no longer fit in the window are cropped.

   **Tip:** Auto Scaling works best when Snap To Size is enabled on the **General** tab in **Setup > Application**. Snap To Size cause the window to be trimmed to remove any border around the displayed characters.

5. From the **Invalid characters** options, select whether to display, not display, or only show decimal characters for invalid characters, such as control codes that are not associated with a legible character. These are most often seen with serial connections.
   The decimal display shows the character number of the invalid character within angle brackets, for example, <4>.

6. Click **OK** to close the Character dialog box.

7. **Optional:** Save the custom settings as part of the session configuration file by selecting **File > Save** from the toolbar, or select **Save As** if you want to save the session as a new .wic file.
Resizing the window

You can change the size of the wIntegrate window in the following ways:

- Drag a corner, side, or the top or bottom of the window
- Click the increase font (увеличить) or decrease (уменьшить) font icons on the general toolbar
- Select a specific size as described in Changing the character display, on page 32

You can also change the window size to be reduced to a thumbnail size by using the Teeny (миниатюра) icon on the general toolbar.

When you use the Teeny icon, wIntegrate stays on top of other applications that you might use so you can use another application full-screen while monitoring the wIntegrate host screen. You can make all your sessions this thumbnail size and place them at the bottom of the screen.

You can change the Always on Top variable at any time in the System menu, which is accessed by right-clicking the wIntegrate title bar.

**Important:** You should restore the normal size by clicking the Teeny icon again. If you make it bigger by dragging the border, the menu and toolbars do not reappear automatically, so you would have to click Restore Menu in the System menu and restore the menus manually.

Changing the session title

You can change the title of a session and have the title bar of the wIntegrate window change. Additionally, when you minimize the session, the new title is displayed on the Taskbar icon so that you can distinguish this session from others.

The Setup > Preferences dialog changes settings for the current session only. The settings are stored in the session .wic file. This is different to the options set in Setup > Application, which apply to the Application as a whole and therefore all sessions. These settings are stored in the Registry.

1. From the main toolbar, select Setup > Preferences.
2. In the Preferences dialog box, verify that the View tab is open.
3. In the Title field, enter a descriptive title for your wIntegrate session. The title is displayed in the title bar.

   The following table describes symbols that are replaced with text in the session title:

   **Table 4: Port symbols**

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Replacement value</th>
</tr>
</thead>
<tbody>
<tr>
<td>~</td>
<td>Displays the type of connection, such as U2 SSH or Windows Sockets.</td>
</tr>
<tr>
<td>@</td>
<td>Displays the name of the host that you are connected to.</td>
</tr>
<tr>
<td></td>
<td>Displays the port status: Open or Closed.</td>
</tr>
</tbody>
</table>

4. Click OK to save your changes.
5. **Optional:** Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.
Adding or removing scroll bars and the status bar

The scroll bars are hidden by default. You can show them to see data or graphics that require more lines or columns than the wIntegrate window can display. The status bar gives you a Ready status if you are not selecting an option from a menu.

The status bar also shows:

- the line and column position of the cursor in the wIntegrate main window
- the backpage number when viewing backpages
- REC if the Edit Record option is in use
- PRT if the printer is the current output destination
- CAPS if the Caps Lock key is on
- NUM if the for the numeric key lock (on certain keyboards)

If you place your cursor over a menu option, the status bar displays a short description of the menu option.

1. From the main toolbar, select **Setup > Preferences**.
2. In the Preferences dialog box, verify that the **View** tab is open.
3. Select the **Vertical Scroll Bar** check box for a vertical scroll bar to appear on the right of the window.
   The vertical scroll bar is an alternative to using the Up and Down buttons on the General toolbar.
4. Select the **Horizontal Scroll Bar** check box for a horizontal scroll bar to appear at the bottom of the window.

   **Note:** If you selected the **Auto Scaling** option as described in Changing the character display, on page 32, then the window accommodates the full width of text that is displayed by the host, and the horizontal scroll bar is not needed.

5. Select the **Status Bar** check box to view a status bar below the bottom horizontal scroll bar.
6. Click **OK** to save your changes.
7. **Optional:** Save the custom settings as part of the session configuration file by selecting **File > Save** from the toolbar, or select **Save As** if you want to save the session as a new .wic file.

Changing the session name

The session name is unrelated to the file name for the .wic file for the session. The session name is assigned as the Dynamic Data Exchange (DDE) topic name that is used by remote applications. You can change the name of a session by performing the following steps.

These steps do not change the title bar. For information about how to change a session’s title bar, see Changing the session title, on page 34.

1. From the main toolbar, select **Setup > Preferences**.
2. Click the **Options** tab.
3. In the **Name** field, enter a new session name.
4. Click **OK** to save your changes.
5. **Optional:** Save the custom settings as part of the session configuration file by selecting **File > Save** from the toolbar, or select **Save As** if you want to save the session as a new .wic file.
Changing the communications’ port saving options

When you save a wIntegrate session, each aspect of its communications is saved so that communications can be restored the next time that the session is opened. The communications’ state at the time of saving is also saved, for example, whether communications are open or closed. You can override how the communications’ state are saved by performing the following steps.

1. From the main toolbar, select Setup > Preferences.
2. Click the Options tab.
3. From the Save Port Open drop-down menu, select one of the following options:
   - **Normal**: the current communications state is saved when the session is saved.
   - **Open**: the communications state is saved as open when the session is saved, regardless of the current state.
   - **Closed**: the communications state is saved as closed when the session is saved, regardless of the current state.
4. Click OK to save your changes.
5. **Optional**: Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.

Closing the session automatically when the port is closed

You can set wIntegrate to close the application automatically when you log off from the host and the communications port is closed.

1. From the main toolbar, select Setup > Preferences.
2. Click the Options tab.
3. Select the Exit Session on Port Close check box to have the session exit when communications are closed.
4. Click OK to save your changes.
5. **Optional**: Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.

Preventing the session from closing if the port is open

If you inadvertently close the application while logged on to the host, you can leave files locked. To prevent this from happening, perform the following steps.

1. From the main toolbar, select Setup > Preferences.
2. Click the Options tab.
3. Select the Prevent Session Exit While Port Open check box.
4. Click OK to save your changes.
   - With the check box enabled, when you select File > Exit, a message appears that says you must log off and close the connection before exiting the session.
5. **Optional**: Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.
Trimming trailing spaces with clipboard operations

When you copy or paste data, you might want to remove the spaces at the end of each line. To trim trailing spaces with clipboard operations, perform the following steps.

1. From the main toolbar, select Setup > Preferences.
2. Click the Options tab.
3. Select the Trim Trailing Spaces on Copy check box to remove trailing spaces before copying data to the clipboard.
4. Select the Trim Trailing Spaces on Paste check box to remove trailing spaces when pasting data from the clipboard.
5. Click OK to save your changes.
6. Optional: Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.

Using edit keys for local editing

You can change key settings to perform specific tasks. For example, you might want the up and down arrow key to scroll up or down through the backpage memory.

About this task

wIntegrate has a feature that is sometimes used by developers called local editing, which is useful for editing long text fields over multiple lines. However, local editing temporarily uses the up and down arrow keys for regular editing functionality, possibly conflicting with your own custom settings such as scrolling through backpages. If your application makes use of local editing for text fields, then you should enable this option to make the edit keys work there. To enable this option, perform the following steps.

Procedure

1. From the main toolbar, select Setup > Preferences.
2. Click the Options tab.
3. Select the Edit Input Keys check box.
4. Click OK to save your changes.
5. Optional: Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.

Consuming one U2 license for multiple host connections using Device Licensing

wIntegrate supports U2 Device Licensing, meaning you can connect to a UniVerse or UniData host with multiple sessions/applications and consume a single U2 license. When U2 is running on Windows, Device Licensing is enabled automatically as part of the initial connection process. When U2 is running on Unix or Linux, Device Licensing is an option. To enable this option, perform the following steps:

1. From the main toolbar, select Setup > Preferences.
2. Click the Options tab.
4. Click OK to save your changes.
5. **Optional:** Save the custom settings as part of the session configuration file by selecting **File > Save** from the toolbar, or select **Save As** if you want to save the session as a new `.wic` file.

### Changing application preferences

You can set up options to automatically confirm each exit from your wIntegrate session, save your changes, and more. The options that are selected in **Setup > Application** apply to the Application as a whole, and therefore all sessions, and are stored in the Registry. Perform the following steps to specify these options.

**Note:** Application settings are stored in the Registry. This differs from the preferences, which are stored in the session `.wic` files.

1. From the main toolbar, select **Setup > Application**.

   **Figure 22: Application**

2. From the **General** tab, select the check boxes next to the application options that you want.
   - **Confirm exit:** A dialog box appears when you close a wIntegrate session, asking you to save changes and confirm your exit.
     **Note:** If you clear the **Confirm exit** check box, you might consider selecting the **Save changes** check box to automatically save changes.
   - **Save changes:** This sets the default value for the "Save changes to session parameters" check box on the Confirm Exit dialog box. If you choose to disable the Confirm Exit dialog box, the Save Changes setting is applied when the session closes.
   - **Snap to size:** When you click and drag a window border or corner to resize the screen, Snap to size removes excess borders.
     **Note:** If you also select the **Auto Scaling** check box in the Character dialog box, wIntegrate snaps the window to fit 80 columns and 24 lines, or the number of columns and lines that are selected in the Character dialog box. For more information, see [Changing the character display, on page 32](#).
   - **Connect Message:** The destination for displaying network connection messages.
   - **Show session copy dialog:** When you start a second session by using a session file that is already being used, wIntegrate warns you that you are already running this session and lets...
you confirm that you want to start a duplicate session. If this check box is not selected, the
duplicate session is created automatically without the message.

3. To change the startup session, click the **Start up Sessions** tab.
   a. Click **Add**.
      Select from where to get settings. If you are using the regular local version, select the
      **Standard location**. Thin client users should select the **Specify location** option.

      **Note:** You can also make a session one of your startup sessions by clicking the
      appropriate check box on the **File > Exit** dialog box.

   b. Click **Remove** to remove a session from the startup list.

4. To change the text, bitmap, and HTML editor you want to use with wIntegrate, click the **Editors**
tab.
Click the ellipsis (…) buttons to browse to a different default program to open for each editor
type.

5. To change the pre-session open and post-session open scripts that run every time you start a
   session, click the **Scripts** tab.
   Click the ellipsis (…) buttons to browse to a different script to open for both open options.
   ▪ The pre-session open script runs every time that you start a session before the configuration
     file is loaded. The default pre-session open script is \wIntSys\Script\NewSess.wis. It is
     used to modify every session, for example, to add or remove menu options.
   ▪ The post-session open script runs every time that you start a session after the configuration
     file is loaded and after the configuration’s load script has been run. The post-session script
     field is blank by default, so no post-session open script runs.
     This script is available for developers who want to customize the application’s behavior after
     the configuration file is loaded, for example, to customize toolbars according to the connected
     host.

6. You can use custom folder locations to store files used by the application. To change the default
   folders, click the **Folders** tab.
   Select a folder location and click **Modify** to browse to a different folder to open.

7. You can view the dialogs and messages in English or Chinese. To change the language, click the
   **Language** tab.

   **Note:** This setting does not affect input and display in the terminal emulation window, which
   is always enabled for display in supported multi-byte languages.

Select the language, and then enter the surrogate font. Surrogate fonts are advanced Unicode
fonts that provide many more characters than are available in the standard Unicode fonts. If you
want to use a surrogate font, enter the name of the font in the **Surrogate Font** field. Note that
you must first ensure that the font is installed.

8. Click **OK** to close the Application dialog box.

9. **Optional:** Save the custom settings as part of the session configuration file by selecting **File >
    Save** from the toolbar, or select **Save As** if you want to save the session as a new .wic file.

## Adding custom scripts

You can run custom wIntegrate scripts each time a specific session is started, for example, a script to
log you in to the host. To add a custom script, perform the following steps.

1. From the main toolbar, select **Setup > Preferences**.
2. Click the **Scripts** tab.
3. To load scripts, click Add.
4. In the Browse for load script dialog box, select and open the script file that you want to use.
5. Continue adding or removing scripts as necessary.

![Figure 23: Scripts tab](image)

6. If you have more than one script loaded, and you want to change the order in which they are loaded, select a script and then click Move Up or Move Down to change the order.
7. If you have created a custom wIntegrate menu script that you want to run each time that a specific session is started, from the Menu Bar Script drop-down menu, select the name of the script file.

   **Note:** Menu bar scripts add to the existing wIntegrate menu rather than replacing it.

8. Click OK to save your changes.
9. **Optional:** Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.

### Customizing mouse and keyboard functions

You can customize the buttons on your mouse as well as keyboard keys to have more functionality.

### Assigning functions the mouse

You can assign different functions to the mouse buttons.

**About this task**

Standard mouse actions are:

- **Left Button Drag** – Selects complete lines of text from the point at which you click the button to the point at which you release the button.
- **Right Button Drag** – Selects columns of text from the point at which you click the button to point at which you release the button.
You can assign other tasks to the mouse buttons by using scripts.

**Procedure**

1. From the main toolbar, select **Setup > Mouse**.
   The Keyboard dialog box appears. The Key List section has **Mouse Buttons** selected by default, and the Key/Macro/Definition section lists all of the mouse button and mouse + key combinations.

   **Figure 24: Keyboard**

   ![Keyboard dialog box](image)

   2. Select an option for the left-click or right-click button on the mouse. In this example, **S_MouseRight** (Shift + right-click) is selected.
      The top section of the dialog box updates based on your selection.

   3. Add a script to the selection. The following steps describe how to add a Copy Special To script to the Shift + right-click combination.

      **Note:** In the **Definition** field, you can enter either a script statement, for example `Show EditCopyTo`, or reference a script stored in a folder, for example `Script "WintSys\Script\CopyMenu"`.

      a. If there is a value in the **Definition** field, highlight it and delete it.
      b. In the **Definition** field, type `Show EditCopyTo`.
      c. Select the **Macro** check box.
         wIntegrate interprets a macro definition internally as a script. If the **Macro** check box is cleared, the definition is sent to the host as text.
      d. Click **Set**.

   4. Click **OK** to close the Keyboard dialog box.
   5. Verify the Shift + right-click combination works. The Copy Special To dialog box should open.
   6. **Optional:** Save the custom settings as part of the session configuration file by selecting **File > Save** from the toolbar, or select **Save As** if you want to save the session as a new .wic file.
For information about the types of scripts, see Copy menu scripts, on page 87.

Assigning functions to the keyboard

You can assign a different function to a function key by using a wIntegrate script.

About this task

When you set up terminal emulation and select a keyboard extension, wIntegrate maps some of the keys on your keyboard to perform the most commonly used functions. For example, when you use VT220 emulation and the key_norm extension, the Up arrow key scrolls up through backpages one line at a time. You can use the default settings for the function keys or customize the settings to perform other functions.

You can remap, or assign a different function to, most keys or key combinations. For example, you can assign a new function to F1 and to the key combinations Shift+F1, Ctrl+F1, and Alt+F1. However, you cannot remap the Shift keys themselves and a few other keys that are reserved by Microsoft Windows for special uses.

Procedure

1. From the main toolbar, select Setup > Keyboard. The Keyboard dialog box appears. The Key List section has Function Keys selected by default, and the Key/Macro/Definition section lists all of the function key combinations.
2. Select an option for a function key. In this example, F5 is selected.
3. Add a script to the selection. The following steps describe how to add a script that opens the Preferences dialog box.
   a. If there is a value in the Definition field, highlight it and delete it.
   b. In the Definition field, type Show SetupPreferences.
   c. Select the Macro check box.
      wIntegrate interprets a macro definition internally as a script. If the Macro check box is cleared, the definition is sent to the host as text.
   d. Click Set.
4. Click OK to close the Keyboard dialog box.
5. Verify that the F5 function key works. The Preferences dialog box should open.
6. Optional: Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.

Creating a macro

You can create a macro and assign it to a function key.

About this task

A macro specifies how a certain input sequence should be mapped to a replacement output sequence according to a defined procedure.

For example, assume that you use an accounting application to perform your daily work. On the main menu of your application, you select option 2 and press Enter to go to an Accounts Payable menu, then select option 4 and press Enter for the Check Processing menu, and finally select option 1 and press Enter to open the Print Checks dialog box.
To navigate to the Print Checks dialog box, you performed six keystrokes: one for each option and another for each time you pressed Enter. If this is a common activity for you, you might want to map this series of keystrokes to a function key.

**Procedure**

1. From the main toolbar, select Setup > Keyboard, and then click the US Keyboard tab.

   **Note:** The keyboard layout and the title on the tab will change according to your keyboard settings. For example, in the United Kingdom, UK Keyboard appears on the tab, and the UK keyboard layout appears.

   ![Figure 25: US Keyboard tab](image)

   - From the main toolbar, select Setup > Keyboard, and then click the US Keyboard tab.

2. Define the macro. The following steps describe how to define a macro for the Shift+F12 combination using the accounting application described previously.
   a. Select the Shift check box.
   b. Click the F12 button.
   c. In the Definition field, type ENTER 2;ENTER 4;ENTER 1.
      - The wIntegrate script ENTER command sends text to the host, followed by a carriage return. When you enter the definition for a macro, use a semicolon to separate each command.
   d. Select the Macro check box.
      - wIntegrate interprets a macro definition internally as a script. If the Macro check box is cleared, the definition is sent to the host as text.
   e. Click Set.

3. Click OK to close the Keyboard dialog box.

4. **Optional:** Save the custom settings as part of the session configuration file by selecting File > Save from the toolbar, or select Save As if you want to save the session as a new .wic file.
Creating a login script

You can create login script to automatically log in to your host computer when you start a macro, and you can assign it to a wIntegrate session.

Prerequisite

If you are connected to a host computer, enter the logout command at the UNIX prompt to close the connection.

Procedure

1. From the wIntegrate main toolbar, select Run > Script.
2. From the Run Script dialog box, navigate to C:\Program Files (x86)\wIntegrate\wIntSys\Script and select learn.wis. Click Open. The Parameters for Learning dialog box appears.

   ![Parameters for Learning](image)

3. Enter the parameters as described in the following steps:
   a. Enter the login user name and password that is used on the host computer.
   b. In the Filename field, enter a name for this login script file. The host computer name is the default value.
   c. Optional: In the Description field, enter a description of the script.
   d. Select the check boxes next to the options you want.

   Selecting the **Store login script for starting new sessions** check box automatically runs the script each time you start wIntegrate with the current session name. Selecting this check box has the same effect as entering the name of the script file that is created by this procedure in the Load Scripts box in the Preferences dialog box, as described in **Adding custom scripts**, on page 39.

   Selecting the **Store Password in script** check box stores the user name and password in a non-readable format in the login script file that you are creating. If this check box is cleared, you must enter the password each time the login procedure runs. It is recommended that you do not store passwords in the login script.
4. Click **Start Learning**.
   A Learning connection dialog box appears.

![Learning connection dialog box](image)

**Figure 27: Learning connection**

5. Click **Enter Login**.
   wIntegrate uses the login name that you entered in the Parameters for Learning dialog box. Your login name is entered automatically in the wIntegrate main window, and the Learning connection contains the text of the password prompt in the **Prompt** field.

6. Click **Enter Password**
   wIntegrate uses the password that you entered in the Parameters for Learning dialog box. Your password is entered automatically in the wIntegrate main window.

7. Click **Stop Learning**.
   wIntegrate creates a script file containing the sequence of characters that are received and sent during the learning procedure. This script is written to the **C:\Program Files (x86)\wIntegrate** folder with the file name that you entered in the Parameters for Learning dialog box. The file extension **.wis** is automatically added to the file name. Capable users can edit the script manually if necessary to change its functionality.

8. Test the login script.
   - If you selected the **Store logon script for starting new sessions** check box, the login script runs automatically when you close and restart this wIntegrate session.
   - If you selected the **View logon dialog box before every log on** check box, when you start a new wIntegrate session, a Login dialog box appears, confirming the script worked.

**Copying text**

wIntegrate allows you to copy text from a right-click menu.

The functionality described here is driven by the **CopyMenu.wis** script in the **C:\Program Files (x86)\wIntegrate\wIntSys\Script** folder. Capable users can modify this script to customize the functionality.

**Note:** You can select lines on the current page and backpages by using the left mouse button, or by column by using the right mouse button.

To copy text, select the text, then right-click the screen and select an option.

The requested Windows application opens a new file if you do not already have a file open. If you have a file open in the application, wIntegrate pastes your selection into the open file.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copies selected text.</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes text from the clipboard.</td>
</tr>
<tr>
<td>Text to Notepad</td>
<td>Copies selected text, starts the Notepad application if it is not running, and pastes the copied text into a Notepad document.</td>
</tr>
<tr>
<td>Text to Wordpad</td>
<td>Copies selected text, starts the WordPad application if it is not running, and pastes the copied text into a WordPad document.</td>
</tr>
<tr>
<td>Bitmap to Paint</td>
<td>Copies a selected part of the window as a graphic, starts the Paint application if it is not running, and pastes the graphic as a bitmap into a Paint session.</td>
</tr>
<tr>
<td>Table to Report Viewer</td>
<td>Copies the selected text, parses it into tab-separated columns with consistent vertical spaces, starts the built-in Report viewer grid, and pastes in the data.</td>
</tr>
<tr>
<td>Table to Excel</td>
<td>Copies the selected text, parses it into tab-separated columns using consistent vertical spaces, starts the Microsoft Excel application if it is not running, and pastes the data into an Excel spreadsheet. If you have an Excel spreadsheet open, winIntegrate pastes the selected table into the spreadsheet starting at the current cell position.</td>
</tr>
<tr>
<td>Table to Lotus 123</td>
<td>Copies the selected text, parses it into tab-separated columns using consistent vertical spaces, starts the Lotus 1-2-3 application if it is not running, and pastes the data into a Lotus 1-2-3 spreadsheet.</td>
</tr>
<tr>
<td>Table to Word</td>
<td>Copies the selected text, parses it into tab-separated columns using consistent vertical spaces, starts the Microsoft Word application if it is not running, and pastes the data into a formatted table.</td>
</tr>
<tr>
<td>Text to Word</td>
<td>Copies the selected text, starts the Microsoft Word application if it is not running, and pastes the text into a Word document.</td>
</tr>
<tr>
<td>Bitmap to Word</td>
<td>Copies the selected area of the winIntegrate main window as a bitmap, starts the Microsoft Word application if it is not running, and pastes the bitmap into a Word document.</td>
</tr>
<tr>
<td>Screen to Word</td>
<td>Copies all the text currently displayed in the winIntegrate main window, which might be a backpage, starts the Microsoft Word application if it is not running, and pastes the displayed data into a Word document. You should format the text using a fixed pitch font such as Courier to see the screen properly, and perhaps put a border around it.</td>
</tr>
<tr>
<td>Screen to Printer</td>
<td>Prints all of the text currently displayed in the winIntegrate main window, which might be a backpage. The print job is routed to the winIntegrate-specific printer set in File &gt; Printer Setup or to your Windows default printer.</td>
</tr>
<tr>
<td>Create Pie Chart</td>
<td>Copies selected data and creates a winIntegrate pie chart. The selected data must be in two columns; the left column must be text, and the right column must be numbers.</td>
</tr>
<tr>
<td>Create Bar Chart</td>
<td>Copies selected data and creates a winIntegrate bar chart. The selected data must be in two columns; the left column must be text, and the right column must be numbers.</td>
</tr>
<tr>
<td>HTML to Editor</td>
<td>Copies the selected text, parses it into tab-separated columns using consistent vertical spaces, starts the HTML editor that you specified in Setup &gt; Application if it is not running, and pastes the table selection into the HTML editor window.</td>
</tr>
<tr>
<td>HTML to Browser</td>
<td>Copies the selected text, parses it into tab-separated columns using consistent vertical spaces, starts the HTML browser program that is associated with the .htm extension in the registry, and pastes the table selection into the HTML browser window.</td>
</tr>
</tbody>
</table>
Copying text with Copy Special to

wIntegrate allows you to copy text or images from the screen in a variety of formats and destinations by using the Copy Special To dialog box.

1. To copy with special options, select **Edit > Copy Special to.**

2. In the Copy Special To dialog box, select the destination from the **Copy to** options.
3. From the **Format** options, select the format for the copied data as described in the following table.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Includes Carriage Returns and Linefeeds when multiple lines are selected</td>
</tr>
<tr>
<td>Text Only</td>
<td>Omits Carriage Returns and Linefeeds when multiple lines are selected</td>
</tr>
<tr>
<td>Table</td>
<td>Looks for consistent vertical space in the selected lines and assumes that these are column breaks. These spaces are replaced with the tab character, which is used as a column delimited in spreadsheets.</td>
</tr>
<tr>
<td>Bitmap</td>
<td>Copies the selected area to the clipboard as a bitmap image. The image can be pasted into applications such as Windows Paint and Word.</td>
</tr>
<tr>
<td>HTML</td>
<td>Looks for consistent vertical space in the selected lines and assumes that these are column breaks. These spaces are removed, and the remaining text is embedded in HTML table code ready for use in an HTML editor.</td>
</tr>
</tbody>
</table>

4. Click **Copy Now** to copy the selected data immediately using the parameters specified.
5. If the destination is File or Editor, specify the file name or click **Browse** to select a file.
6. Select the **Reverse Colors** check box to print, for example, black as white and white as black. This saves printer ink.
7. Select the **Border** check box to have a border around the selected data.
8. Select the **Black and White** check box to convert the on-screen colors to monochrome black and white for easy legibility.
9. To save the settings, click **OK**.
10. When you are ready to copy text, select the text, then select **Edit > Copy Special**. The text is copied to the destination with the specified format options.

### Recording and playing back data

You can record data and send it to a file in various formats.

1. From the main toolbar, select **Edit > Record**.

![Figure 29: Record](image)

2. Select the **File** option to save recorded data to the hard disk with the displayed file name, or **Printer** to send the data to the printer.
   The **Printer** option does not save your recorded data to a file for later use.
3. From the **Format** section, select the purpose of recording the data:
   - **Raw data** records data exactly as the host sends to your computer, including terminal command sequences.
     You can use the **Edit > Play** menu option with the **Local** option to reproduce what was originally seen on screen. If you have an issue with terminal emulation, support might ask you to send a Raw Data recording so that they can reproduce what you saw.
   - **Screens** records a series of screens as each one was displayed just before the next screen was shown.
     This option might not work with all applications or terminal emulations because it relies on recognizing the FormFeed character.
   - **Keystrokes** records your keystrokes.
     In the **Edit > Play** menu option, you can send the keystrokes to the host as input. This is useful for repeating known keyboard sequences.
   - **Control Codes** records the incoming data analyzed in relation to the current terminal emulation.
     This option is used to isolate unknown or incorrect escape sequence definitions.
   - **Two Way** records the incoming and outgoing data so you can see your interaction with the host. Each line is prefixed by the date, time, and millisecond count, and all fields are delimited by tabs so you can easily paste into Excel.
4. In the **File name** field, enter a name to save the recording as.
5. The **Print direct** check box is cleared by default. If you want wIntegrate to send the recorded characters to the Windows printer driver as bytes rather than format them for the printer driver, select the **Print direct** check box.
6. To start recording, click **OK**.
Data is now recorded according to your settings. While recording is active, the Edit > Record menu option has a check mark, and REC appears in the Status bar.

7. To stop recording, select Edit > Record. When you stop the recording, the check mark is removed.

8. If appropriate to the type of recording you made, you can now select Edit > Play.

9. In the Play dialog box, enter the file name for the recording that you entered in step 4. Select the Local and Pause check boxes if necessary.

   The Local option displays the recorded data on the computer as though it had been received from the host. You would select this option when playing back a Raw Data recording. If this check box is cleared, the recorded data is sent to the host computer as input, for example, with a Keystrokes recording.

   The Pause option causes a delay before each new page displays. The Play File Pause dialog box will prompt you to display the next page.

   The Text Characters only option removes the terminal emulation escape sequence so only regular text characters are processed.

10. To start the playback, click OK.
Chapter 4: Transferring multivalued data

The Run menu provides options for transferring data to and from the host and your computer between two different host computers. You can select the appropriate transfer method for any task that requires moving information from one computer to another.

For example, you can transfer all or selected items to your PC, choosing which fields to transfer or all fields. The data is formatted for popular applications such as Excel and Word. This is called importing because data is brought from a remote host into your desktop. You can also export data from your desktop to the host. Check with your system administrator before transferring data to your host computer.

Generally, if you are importing data, the Query Builder menu option is preferable to Run > Import File. The Query Builder has more options and will, for example, open up Excel with the newly created spreadsheet. The Run > Import File menu option simply creates the file. Behind the scenes, the Query Builder uses the Run ImportFile processing to import the data before adding its own features to improve usability of the new file. For more information about the Query Builder, see Building queries with Query Builder, on page 70.

The following file transfer methods are available:

• Importing data, on page 50
• Exporting data, on page 58
• Transferring data from one host computer to another host computer, on page 64
• Transferring files by using FTP, on page 68

Importing data

You can import data from your host account to your PC. This is useful for using your host data in other applications such as creating marketing and accounting reports in Excel.

Prerequisite

You must first install the wIntegrate host programs in the database account. See Installing host programs, on page 23.
Procedure

1. From the main toolbar, select Run > Import File.

![Import File from Host](image)

Figure 30: Import File from Host

2. From the Import File from Host dialog box, click Files.

The File Selection dialog box lists files in the current account by default. If you want to see a list of files in a different account, type the name of the account in the Account field before you click the Files button. The Files list is blank, and the Status box displays progress information while the host computer transfers a list of files in the current account. Wait for the Status box to read, “File transfer finished OK” before continuing.

**Note:** You must be at your host database TCL/ECL prompt in order for the wIntegrate host program WIN.TRANSFER to run. Otherwise, the File Selection dialog box is blank and files cannot be transferred.

3. In the File Selection dialog box, select a file to import, then click OK.

The file name is added to the Host file field in the Import File from Host dialog box.

**Tip:** You can enter information in any text box if you know the name of the file, item, or other selection criteria. Otherwise, you can click a query button to search for the information that you need.

4. In the Import File from Host dialog box, click Items.

In the Items field, you can:
- manually enter specific item IDs,
- enter a selection statement (for example, `SELECT CUSTOMERS WITH STATE = "CA"`)  
- use the Item Selection dialog box. For more information, see Additional methods of selecting items for import, on page 57.
5. Click the **Items** button
   The Item Selection dialog box appears.

![Item Selection](image)

The Item Selection dialog box lets you view items according to certain criteria, and then choose which ones to transfer. After setting your search criteria, click **Start Search**.

**Note:** The item IDs are transferred to the Items box, but no other data is transferred at this point.

The **Status** box displays progress information while the host computer transfers a list of items in the selected file.

Select the **Clear last list** check box to clear the list that was previously generated; otherwise, the items that are found in the new search are added to the list of existing items.

Searching for specific items or ranges can reduce the search time on a large file. wIntegrate provides other options to narrow your search for items in the file, for example, **Begins** or **Ends** to search for beginning or ending characters in the **Value(s)** field. These methods can be especially useful when searching large blocks of data.

6. From the **Items** list, select the items that you want to transfer, and then click **Add**.
   The items appear in the **Selected items** list.

7. When you are done adding items, click **OK**.
   The selected items are added to the **Items** field in the Import File from Host dialog box.
8. In the Import File from Host dialog box, click **Fields**. The Field Selection dialog box appears.

![Figure 32: Field Selection](image)

**Tip:** Instead of using the Fields dialog box, you can manually enter the dictionary names of each field to import. For more information, see Additional methods of selecting fields for import, on page 57.

The **Dictionary fields** list is blank and the **Status** box displays progress information while the dictionary of your chosen file is transferred to your computer. Wait for the **Status** box to read, “File transfer finished OK” before continuing.

9. From the **Dictionary fields** list, select the fields that you want to transfer, and then click **Add >>**.
10. When you are done adding fields, click **OK**. The selected items are added to the **Fields** field in the Import File from Host dialog box.
11. In the **Local file** field, enter a name or click **Browse** to select the file to which you are importing data on your computer.
12. From the **Format** drop-down menu, select a format that is based on how you intend to use the data.

Normally, you specify the file format by entering an extension in the **Local file** field. wIntegrate automatically selects the appropriate format in the **Format** list that is based on the extension you enter. However, you can override the automatic selection in the **Format** field by selecting a different format from the list.

The available formats are described in the following table.

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASCII</td>
<td>ASCII file format. By default, each host field becomes a different line in the local file, and each item is separated by a Formfeed (ASCII character 12). You can change these defaults in the Translation dialog box.</td>
</tr>
<tr>
<td>Comma Separated</td>
<td>Comma-separated values. Each item becomes a line in the local file with fields separated by a comma. Text fields are in double quotation marks. Most spreadsheet and database applications can use this format.</td>
</tr>
<tr>
<td>Comma Quoted</td>
<td>Comma-separated values. Each item becomes a line in the local file with fields separated by a comma. All fields are in double quotation marks.</td>
</tr>
<tr>
<td>Excel (2003, 2007)</td>
<td>Microsoft Excel 2003 or 2007 file format. Each item imports into a row, and each field displays in a cell. You can use the NUMBER() and STRING() functions to modify the way wIntegrate imports data.</td>
</tr>
</tbody>
</table>
Chapter 4: Transferring multivalued data

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed length</td>
<td>Fields are padded to fixed lengths determined by the specified dictionary items. You can define the ASCII characters to insert as padding by using the ( \text{PAD}() ) function in the Fields field.</td>
</tr>
<tr>
<td>Lotus 123 (WK1)</td>
<td>Lotus 1-2-3 file format, WK1 extension. You can use the ( \text{NUMBER}() ) and ( \text{STRING}() ) functions in the Fields field to modify the way wIntegrate imports data.</td>
</tr>
<tr>
<td>Mail Merge</td>
<td>Mail merge file format. This format is similar to the Comma Separated format except that the first line contains the dictionary names that were specified when the file was imported.</td>
</tr>
<tr>
<td>Raw Data</td>
<td>Raw data file format. Stores data that is imported from the host exactly as received, with all delimiters and other special characters.</td>
</tr>
<tr>
<td>Tab Separated</td>
<td>Tab-separated values. Each item becomes a line in the local file with fields separated by tabs.</td>
</tr>
<tr>
<td>HEX</td>
<td>Transfers data in HEX format.</td>
</tr>
<tr>
<td>XML</td>
<td>Transfers data and creates a file in XML format.</td>
</tr>
<tr>
<td>HTML</td>
<td>Transfers data and creates a file in HTML format.</td>
</tr>
</tbody>
</table>

13. From the Overwrite drop-down menu, specify how file overwrites are handled. The available overwrite options are described in the following table.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>If the file already exists in the specified folder, it is overwritten.</td>
</tr>
<tr>
<td>No</td>
<td>If the file already exists in the specified folder, a wIntegrate dialog box gives you the choice of overwriting the file or canceling the transfer.</td>
</tr>
<tr>
<td>Append</td>
<td>If the file already exists in the specified folder, the imported data is appended to it. If the file does not exist, wIntegrate creates the file. This option is valid with ASCII, Comma Separated, Comma Quoted, Fixed length, and Raw data file formats only.</td>
</tr>
</tbody>
</table>

14. From the Translate drop-down menu, select the method wIntegrate uses to translate characters while transferring them. Each translate option is described in the following table.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>wIntegrate does not translate characters while importing them.</td>
</tr>
<tr>
<td>ASCII</td>
<td>wIntegrate translates characters only when importing a file into the ASCII format.</td>
</tr>
<tr>
<td>All</td>
<td>wIntegrate always translates characters regardless of the file format.</td>
</tr>
</tbody>
</table>

15. If translation is available for your current settings, click the Translation button to open the Translation dialog box. Here, you can set up the host characters wIntegrate translates.

**Warning:** When you import a file, wIntegrate translates values as it receives them before the editor converts values to specific file formats. Be careful not to translate remote characters that the editor requires to create the local file.

If you are using the ASCII translate option to import host data to an ASCII text file, use the system default translation for characters 254 and 255. The default translation is required to create line breaks and page breaks in the ASCII file. The attribute mark (character 254) is set up to translate
as a line break sequence, consisting of a carriage return and new line (represented as \r and \n respectively). The item mark (character 255) is set up to translate as a page break sequence, consisting of a carriage return, new line, new page, carriage return, and new line (represented as \r\n\f\r\n).

If you are using the All translate option, delete the system default translations for characters 254 and 255. For example, if you are importing host data to an Excel file, wIntegrate uses attribute marks (character 254) and record marks (character 255) to split incoming data into separate columns and rows of the spreadsheet. If you translate these characters, Excel cannot create a spreadsheet.

16. From the Mode section, select **Normal**, **Capture**, or **Reformat**.

17. Select any additional options as necessary.

### Table 10: Other options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suppress ID</td>
<td>Prevents the host item ID from displaying as the first field of each item.</td>
</tr>
<tr>
<td>Field descriptions</td>
<td>Transfers descriptions of specified fields as the first line. This option is useful when importing data into a spreadsheet.</td>
</tr>
<tr>
<td>Inform when done</td>
<td>A message informs you when the file import is complete. This option is useful if you want to run another application full-screen while wIntegrate transfers data.</td>
</tr>
<tr>
<td>Timeout</td>
<td>The maximum number of seconds wIntegrate waits for a response to a protocol message. The default value of five seconds is sufficient. Valid values range 1 - 9999 seconds.</td>
</tr>
<tr>
<td></td>
<td>A timeout occurs when wIntegrate sends a protocol message, and it does not get a response within a specified length of time. When a timeout occurs, wIntegrate resends the protocol message until the maximum number of retries is reached.</td>
</tr>
<tr>
<td>Retries</td>
<td>The maximum number of times that wIntegrate sends a protocol message before a file transfer is abandoned. The default value of three is sufficient, or five retries in any case. Valid values range 0 - 9999.</td>
</tr>
<tr>
<td></td>
<td>When transferring data in Capture mode, the Retries value applies only to the initial exchange of internal parameters. It is not relevant to the data transfer, which is dependent on capturing the output of a host query statement.</td>
</tr>
</tbody>
</table>
18. If you need to convert numbers from the display format that is used in your host data to a different display format on your computer, click **Advanced**. The Advanced Import Options dialog box appears.

![Advanced Import Options](image)

**Figure 33: Advanced Import Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number conversion</td>
<td>Allows you to enter the currency character, thousands separator character, and decimal character that is used in host data.</td>
</tr>
<tr>
<td>Explode values</td>
<td>Forces multi-values to appear one per line, rather than as a single long field all on the same line.</td>
</tr>
<tr>
<td>Repeat Values</td>
<td>Fills any blank values with the previous value in the same column so, for example, a single-value customer name will be repeated for all the matched multi-values.</td>
</tr>
<tr>
<td>Show Complete Field Headings</td>
<td>Column widths are determined by the length of the column heading rather than the length specified in the dictionary definition. This option is useful when the column heading is wider than the data.</td>
</tr>
<tr>
<td>Use Formatting Information</td>
<td>Use the conversion, length and justification information from host dictionary items where appropriate</td>
</tr>
<tr>
<td>Left-justified is Text</td>
<td>Forces left justified fields to be imported as a text/string type</td>
</tr>
<tr>
<td>Right-justified is Numeric</td>
<td>Forces right justified fields to be imported as numbers</td>
</tr>
</tbody>
</table>

19. Click **Save**. In the Save File Import settings dialog box, enter a file name with the extension `.wis`. Click **Save**.

20. In the Import File from Host dialog box, click **OK**. The File Import Monitor dialog box appears. When the status bar indicates that the file transfer is finished, click **Exit**.
Additional methods of selecting items for import

Use these methods to select items when you import a file from the host.

Using statements to select items

In the Import File from Host dialog box, in the Items field, you can enter a SELECT, SSELECT, GET.LIST, XEQ, or similar commands with sort criteria.

Enter REPORT to force a statement to execute. Using this method, you can run a SORT or SELECT statement and import the data all in one step. For example, to show a request for a report on the STAFF file in the UniData demo account, enter REPORT SORT STAFF LNAME SAL BY SAL.

UniData, UniVerse, Advanced Pick, and R83 Pick databases support two SELECT statements in the Items field, or one SELECT and one REPORT statement if you are using Capture mode. The format is as follows:

\[ <\text{sep\_char}>\text{first\_select}\langle\text{sep\_char}\rangle\text{last\_select}\]

where sep_char is either a slash (/) or pipe (|). You cannot have a space between the sep_char and the SELECT statement, for example:

For Normal or Reformat mode:

\[ /\text{SSELECT ORDER WITH CUSTOMER=“Artful Frames”}/\text{SELECT ORDER WITH PRODUCT= “COMPUTER”}\]

For Capture mode:

\[ /\text{GET-LIST PAYMENT.LIST}/\text{REPORT SORT ORDER BY CUSTNAME CUSTNAME PRODUCT QUANTITY VALUE ORDER.DATE}\]

Using host programs to select items

Another method for selecting items is to run a host program. You might create a host program to select items for a report when you need to get data from several files or perform any type of complex item selection.

You create the host program in the native database language, such as UniBasic or Pick BASIC. The last line of the program should be a SELECT statement that the file transfer program executes.

Enter the wIntegrate XEQ file name command in the Items field to tell the host to run the program. For example, you can run a host program to select items from a globally cataloged program that is named COURSES.SEL by entering XEQ COURSES.SEL.

Additional methods of selecting fields for import

Use these methods for selecting fields when you import a file from the host.

In the Fields field of the Import File from Host dialog box, you can enter the dictionary names of each field to import. If you use Normal mode, the fields must be simple attribute definitions, not virtual
fields or correlatives (also called calculated or derived fields). For example, in UniVerse and UniData, the fields must be D-type dictionary items, not V-type or I-type items.

With certain file formats, you can modify the way wIntegrate imports data by using the following functions:

- NUMBER()
- STRING()
- PAD()

The following sections describe these functions.

**Number fields**

With Microsoft Excel formats, you can force a field to be imported as numeric data instead of text characters by using the NUMBER() function in the Fields field. This is useful if the dictionary item does not specify a numeric format for the field.

**Syntax:** 
NUMBER(field.name {, number.of.decimal.places} )

**String fields**

With the Microsoft Excel and Lotus formats, you can force a field to be imported as text instead of numeric data by using the STRING() function in the Fields field. This is useful when importing, for example, long numeric part numbers that Excel would otherwise display with exponential notation.

**Syntax:** 
STRING(field.name)

**Padded fields**

With the Fixed length format, fields are padded to fixed lengths determined by the dictionary items. You can specify the ASCII characters to insert as padding by using the PAD() function in the Fields field.

**Syntax:** 
PAD(ASCII.character.number {, number.of.occurrences} )

**Formulas**

You can store a Microsoft Excel formula in your multivalued database, then import it to Excel with other fields. In Microsoft Excel, the formula takes effect and perform its calculations.

**Syntax:** 
FORMULA(field.name)

**Exporting data**

Use the Run > Export File menu option to transfer data from your computer to the host computer. Typically you would not export data to the main files in your database; data would be exported to a temporary file on the host for use by a program in your application.

**Prerequisite**

Exporting data from the computer to the host requires some planning. One reason is that you do not want to overwrite an existing database file that you need. Another reason is that the host data file to which you are exporting must exist and have a dictionary file that defines the data you are exporting. For example, you have dictionary items 1, 4, 5, and 7 in your computer file. You must have corresponding dictionary items in the host file.

- You must first install the wIntegrate host programs in the database account. See Installing host programs, on page 23.
Caution: You must be very careful when exporting data from the desktop to your host system, as you might overwrite critical files. To prevent or filter data transfers, you can use the service subroutine, as described in the Host Subroutines Reference.

Procedure

1. Create a temporary file so that you do not accidentally export data into a file that you need.
2. From the main toolbar, select Run > Export File.

Figure 34: Export File to Host

3. In the Export File to Host dialog box, navigate to and select the file that you want to export, and click Open. The file name is added to the Local file field in the Export File to Host dialog box.
4. From the Export File to Host dialog box, click Files. The File Selection dialog box lists files in the current account by default. If you want to see a list of files in a different account, type the name of the account in the Account field before you click the Files button. The Files list is blank, and the Status box displays progress information while the host computer transfers a list of files in the current account. Wait for the Status box to read, “File transfer finished OK” before continuing.

Note: You must be at your host database TCL/ECL prompt in order for the wIntegrate host program WIN.TRANSFER to run. Otherwise, the File Selection dialog box is blank and files cannot be transferred.

5. In the File Selection dialog box, select the temporary file that you created in step 1, then click OK. The file name is added to the Host file field in the Export File to Host dialog box.
6. In the Export File to Host dialog box, click Items. In the Items field, you can:
   • use the default * to use the item names from the local file as the host item IDs.
   • enter # if you want wIntegrate to assign sequential numeric IDs.
   • manually enter specific item IDs. wIntegrate assigns these names as the host item IDs until all of the items names are used. If you enter fewer item names than the number of items (or
records) in the local file, wIntegrate assigns sequential numeric IDs (beginning with 1) to the remaining host items.

- use the Item Selection dialog box.

7. Click the **Items** button
   The Item Selection dialog box appears.

   **Figure 35: Item Selection**

The Item Selection dialog box lets you view items according to certain criteria, and then choose which ones to transfer. After setting your search criteria, click **Start Search**.

**Note:** The item IDs are transferred to the Items box, but no other data is transferred at this point.

The **Status** box displays progress information while the host computer transfers a list of items in the selected file.

Select the **Clear last list** check box to clear the list that was previously generated; otherwise, the items that are found in the new search are added to the list of existing items.

Searching for specific items or ranges can reduce the search time on a large file. wIntegrate provides other options to narrow your search for items in the file, for example, **Begins** or **Ends** to search for beginning or ending characters in the **Value(s)** field. These methods can be especially useful when searching large blocks of data.

8. From the **Items** list, select the items that you want to transfer, and then click **Add**.
   The items appear in the **Selected items** list.

9. When you are done adding items, click **OK**.
   The selected items are added to the **Items** field in the Export File to Host dialog box.
10. In the Export File to Host dialog box, click **Fields**. The Field Selection dialog box appears.

**Figure 36: Field Selection**

Instead of using the Fields dialog box, you can manually enter the dictionary names of the destination fields. For more information, see *Additional methods of selecting fields for export, on page 63.*

The **Dictionary fields** list is blank and the **Status** box displays progress information while the dictionary of your chosen file is transferred to your computer. Wait for the **Status** box to read, “File transfer finished OK” before continuing.

11. From the **Dictionary fields** list, select the fields that you want to transfer, and then click **Add >>**.

12. When you are done adding fields, click **OK**. The selected items are added to the **Fields** field in the Export File to Host dialog box.

13. From the **Format** drop-down menu, select a format that is based on how you intend to use the data.

Normally, you specify the file format by entering an extension in the **Local file** field. **wIntegrate** automatically selects the appropriate format in the **Format** list that is based on the extension you enter. However, you can override the automatic selection in the **Format** field by selecting a different format from the list.

The available formats are described in the following table.

**Table 12: Format options**

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASCII</td>
<td>ASCII file format. By default, each host field becomes a different line in the local file, and each item is separated by a Formfeed (ASCII character 12). You can change these defaults in the Translation dialog box.</td>
</tr>
<tr>
<td>Comma Separated</td>
<td>Comma-separated values. Each item becomes a line in the local file with fields separated by a comma. Text fields are in double quotation marks. Most spreadsheet and database applications can use this format.</td>
</tr>
<tr>
<td>Comma Quoted</td>
<td>Comma-separated values. Each item becomes a line in the local file with fields separated by a comma. All fields are in double quotation marks.</td>
</tr>
<tr>
<td>Excel (2003, 2007)</td>
<td>Microsoft Excel 2003 or 2007 file format. Each item imports into a row, and each field displays in a cell. You can use the <strong>NUMBER()</strong> and <strong>STRING()</strong> functions to modify the way wIntegrate imports data.</td>
</tr>
<tr>
<td>Fixed length</td>
<td>Fields are padded to fixed lengths determined by the specified dictionary items. You can define the ASCII characters to insert as padding by using the <strong>PAD()</strong> function in the <strong>Fields</strong> field.</td>
</tr>
</tbody>
</table>
Chapter 4: Transferring multivalued data

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lotus 123 (WK1)</td>
<td>Lotus 1-2-3 file format, WK1 extension. You can use the <code>NUMBER()</code> and <code>STRING()</code> functions in the <strong>Fields</strong> field to modify the way wIntegrate imports data.</td>
</tr>
<tr>
<td>Mail Merge</td>
<td>Mail merge file format. This format is similar to the Comma Separated format except that the first line contains the dictionary names that were specified when the file was imported.</td>
</tr>
<tr>
<td>Raw Data</td>
<td>Raw data file format. Stores data that is imported from the host exactly as received, with all delimiters and other special characters.</td>
</tr>
<tr>
<td>Tab Separated</td>
<td>Tab-separated values. Each item becomes a line in the local file with fields separated by tabs.</td>
</tr>
<tr>
<td>HEX</td>
<td>Transfers data in HEX format.</td>
</tr>
<tr>
<td>XML</td>
<td>Transfers data and creates a file in XML format.</td>
</tr>
<tr>
<td>HTML</td>
<td>Transfers data and creates a file in HTML format.</td>
</tr>
</tbody>
</table>

14. From the **Overwrite** drop-down menu, specify how file overwrites are handled. The available overwrite options are described in the following table.

**Table 13: Overwrite options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>If the host file already exists in the specified directory, it is overwritten.</td>
</tr>
<tr>
<td>No</td>
<td>If the host file already exists, it is not overwritten.</td>
</tr>
<tr>
<td>Combine</td>
<td>This option integrates exported data with existing data according to the dictionary fields you specified in the <strong>Fields</strong> field, and adds any new multivalued attributes. If you did not specify dictionary fields, the data is appended to the host record.</td>
</tr>
</tbody>
</table>

15. From the **Translate** drop-down menu, select the method wIntegrate uses to translate characters while transferring them.

Each translate option is described in the following table.

**Table 14: Translate options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>wIntegrate does not translate characters while importing them.</td>
</tr>
<tr>
<td>ASCII</td>
<td>wIntegrate translates characters only when importing a file into the ASCII format.</td>
</tr>
<tr>
<td>All</td>
<td>wIntegrate always translates characters regardless of the file format.</td>
</tr>
</tbody>
</table>

16. When exporting a file to the host, you can specify characters that wIntegrate translates to ensure a match between the local and multi-valued data. If translation is available for your current settings, click the **Translation** button to open the **Translation** dialog box. Here, you can set up the host characters wIntegrate translates.

If you are using the **ASCII** translate option to export ASCII data to the host, use the system default translation for characters 254 and 255. The default translation is required to convert line breaks and page breaks in the ASCII file to attribute marks and item marks on the host.

The line break sequence, consisting of a carriage return and new line (represented as `\r\n`), is set to translate to the attribute mark (character 254).

The page break sequence, consisting of a carriage return, new line, new page, carriage return, and new line (represented as `\r\n\f\r\n`), is set up to translate to the record mark (character 255).

17. Select any additional options as necessary.
Table 15: Other options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple disks</td>
<td>wIntegrate prompts you to insert disks during the export if multiple disks are involved.</td>
</tr>
<tr>
<td>Inform when done</td>
<td>A message informs you when the file import is complete. This option is useful if you want to run another application full-screen while wIntegrate transfers data.</td>
</tr>
<tr>
<td>Timeout</td>
<td>The maximum number of seconds wIntegrate waits for a response to a protocol message. The default value of five seconds is sufficient. Valid values range 1 - 9999 seconds. A timeout occurs when wIntegrate sends a protocol message and it does not get a response within a specified length of time. When a timeout occurs, wIntegrate resends the protocol message until the maximum number of retries is reached.</td>
</tr>
<tr>
<td>Retries</td>
<td>The maximum number of times that wIntegrate sends a protocol message before a file transfer is abandoned. The default value of three is sufficient, or five retries in any case. Valid values range 0 - 9999. When transferring data in Capture mode, the Retries value applies only to the initial exchange of internal parameters. It is not relevant to the data transfer, which is dependent on capturing the output of a host query statement.</td>
</tr>
</tbody>
</table>

18. If you need to convert numbers from the display format that is used in your host data to a different display format on your computer, click **Advanced**. The Advanced Export Options dialog box appears.

**Figure 37: Advanced Export Options**

Select the **Use Formatting Information** check box to use the conversion information from host dictionary items where appropriate.

19. Click **Save**. In the Save File Export settings dialog box, enter a file name with the extension .wis. Click **Save**.

**Note:** If the local file you are about to export is open on your computer, be sure to close it before you start the file transfer process.

20. In the Export File to Host dialog box, click **OK**. The File Export Monitor dialog box appears. When the status bar indicates that the file transfer is finished, click **Exit**.

**Additional methods of selecting fields for export**

This section describes additional methods for selecting fields when you export a file to the host.
In the **Fields** field of the Export File to Host dialog box, you can enter the dictionary names of the source fields. The dictionary items must be simple attribute definitions, not calculated or derived fields. Otherwise, enter "*" to insert fields in the host records in the same sequence in which they appear in the local file. When you enter ", the first field in each record will be used as the host ID.

**Note:** With the Fixed length format, fields are padded to fixed lengths in the local file, so wIntegrate checks each host dictionary item to find the actual length of the field. To export padded fields, you must specify the dictionary items in the **Fields** field. You cannot enter "*" with the Fixed length format.

If you enter the dictionary names of the destination fields, wIntegrate checks the attribute number of each host dictionary item to position the local fields in the host file. If you enter a field that defines the host item ID (attribute 0), wIntegrate ignores instructions in the **Items** field and assigns this field as the host item ID. If you specify the dictionary items but none of the items define attribute 0, wIntegrate uses information in the **Items** field to assign the host item ID.

With the Fixed length format, you can skip over characters in the file by using the `IGNORE()` function in the **Fields** field. For example, if the file contains carriage returns and linefeeds, you can use the `IGNORE()` command to skip over them:

**▪** `ID IGNORE(1) NAME`: ignores one character between the ID and NAME fields.
**▪** `ID CUSTOMER IGNORE(3) ADDRESS IGNORE(10)`: ignores three characters between the CUSTOMER and ADDRESS fields, and ignores ten characters at the end of each record.

### Transferring data from one host computer to another host computer

With **Bridge Copy Files**, you can transfer data from one host computer to another. In a bridge copy transfer, one host provides the data for the transfer, and the other host receives the data.

**Prerequisite**

**▪** You must first install the wIntegrate host programs on both host computers. See [Installing host programs](#) on page 23.
**▪** You must be running two sessions of wIntegrate.

**Procedure**

1. Create a temporary file on the target host so that you do not accidentally overwrite critical data.
2. On the source host computer, from the main toolbar, select **Run > Bridge Copy File**.

   ![Host to Host Bridge Copy](image)

3. From the Host to Host Bridge Copy dialog box, click **Files** from the Source group. The File Selection dialog box lists files in the current account by default. If you want to see a list of files in a different account, type the name of the account in the **Account** field before you click the **Files** button. The **Files** list is blank, and the **Status** box displays progress information while the host computer transfers a list of files in the current account. Wait for the **Status** box to read, “File transfer finished OK” before continuing.

   **Note:** You must be at your host database TCL/ECL prompt in order for the wIntegrate host program WIN.TRANSFER to run. Otherwise, the File Selection dialog box is blank and files cannot be transferred.

   **File** is the name of the source file to be transferred. You can use a defined file or file synonym. If you are importing from a dictionary file, enter DICT before the file name (for example, DICT CUST).

4. In the File Selection dialog box, select the file containing the data that you want to copy to the other host, then click **OK**. The file name is added to the **File** field in the **Source** group of the Host to Host Bridge Copy dialog box.

   **Note:** Notice the asterisk (*) in the **Items** and **Fields** fields. The asterisk denotes that you want to transfer all of the items or fields in the file. Instead, you can select particular items or fields to transfer by clicking the **Items** or **Fields** button and selecting from a list. If you decide to use the default asterisks, the headings for the report will not appear because no dictionary items are specified.

5. In the **Account** field, enter the name of the account that contains the file on the source host computer. If you leave this field blank, the data transfer uses the current account.
6. In the Export File to Host dialog box, click **Items**. The Item Selection dialog box appears.

**Figure 39: Item Selection**

![Item Selection](image)

7. The Item Selection dialog box provides several ways to select items, or records, in the source file.
   - All items in the file in random order – Enter an asterisk (*).
   - Specific items – Enter the IDs of the source items separated by spaces.
   - Item selection – Enter a SELECT, SSELECT, GET.LIST, or similar command with sort criteria if required. If you are not using UniData, enter a similar selection command for your database.

8. When you are done adding items, click **OK**. The selected items are added to the **Items** field in the Host to Host Bridge Copy dialog box.

9. In the Host to Host Bridge Copy dialog box, click **Fields**. The Field Selection dialog box appears.

**Figure 40: Field Selection**

![Field Selection](image)

In the **Fields** field of the Host to Host Bridge copy dialog box, you can enter the dictionary names of the destination fields. The dictionary items must be simple attribute definitions, not calculated or derived fields. Otherwise, enter * to insert fields in the host records in the same sequence in which they appear in the local file. When you enter *, the first field in the host file is the host item ID.

10. From the **Dictionary fields** list, select the fields that you want to transfer, and then click **Add >>**.

11. When you are done adding fields, click **OK**. The selected items are added to the **Fields** field in the Host to Host Bridge Copy dialog box.
12. The **Target** drop-down menu shows other wIntegrate sessions. From the **Target** drop-down menu, select the wIntegrate session and the destination computer.

**Note:** The destination computer might be the same as the source computer.

13. From the **Target** group, click **Files**.
   In Target, this field specifies the destination file.

14. In the File Selection dialog box, select the temporary file that you created in step 1, then click **OK**. The file name is added to the **File** field in the **Target** group of the Host to Host Bridge Copy dialog box.

15. In the **Account** field, enter the name of the account on the target machine. If you leave this field blank, the data transfer uses the current account.

16. From the **Target** group, in the **Items** field, perform one of the following actions: click **Items**.
   - Leave the default * if you want to assign the original item IDs to the incoming records.
   - Enter # if you want wIntegrate to assign sequential numeric IDs to all records.
   - Click **Items** and in the Item Selection dialog box, select the names of the files on the target host. When you are done adding items, click **OK**.

   If you do not specify enough item IDs for the incoming records, wIntegrate uses sequential numeric IDs starting at 1 for the remaining records.

17. From the **Target** group, click **Fields**.
   The Field Selection dialog box appears. Fields contain the names for the incoming fields as defined in the dictionary file.

18. From the **Dictionary fields** list, select the fields that you want to transfer, and then click **Add >>**.

19. When you are done adding fields, click **OK**.
   The selected items are added to the **Fields** field in the **Target** group of the Host to Host Bridge Copy dialog box.

20. From the **Overwrite** drop-down menu, specify how file overwrites are handled.
   The available overwrite options are described in the following table.

   **Table 16: Overwrite options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>If the target file already exists in the specified directory, it is overwritten.</td>
</tr>
<tr>
<td>No</td>
<td>If the target file already exists, it is not overwritten.</td>
</tr>
<tr>
<td>Combine</td>
<td>This option integrates exported data with existing data according to the dictionary fields you specified in the <strong>Fields</strong> field, and adds any new multivalued attributes. If you did not specify dictionary fields, the data is appended to the host record.</td>
</tr>
</tbody>
</table>

21. Select any additional options as necessary.

   **Table 17: Other options**

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inform when done</td>
<td>A message informs you when the file import is complete. This option is useful if you want to run another application full-screen while wIntegrate transfers data.</td>
</tr>
</tbody>
</table>
### Chapter 4: Transferring multivalued data

#### Options

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Timeout</strong></td>
<td>The maximum number of seconds wIntegrate waits for a response to a protocol message. The default value of five seconds is sufficient. Valid values range 1 - 9999 seconds. A timeout occurs when wIntegrate sends a protocol message and it does not get a response within a specified length of time. When a timeout occurs, wIntegrate resends the protocol message until the maximum number of retries is reached.</td>
</tr>
<tr>
<td><strong>Retries</strong></td>
<td>The maximum number of times that wIntegrate sends a protocol message before a file transfer is abandoned. The default value of three is sufficient, or five retries in any case. Valid values range 0 - 9999. When transferring data in Capture mode, the Retries value applies only to the initial exchange of internal parameters. It is not relevant to the data transfer, which is dependent on capturing the output of a host query statement.</td>
</tr>
</tbody>
</table>

22. In the Host to Host Bridge Copy dialog box, click **OK**. The Bridge Copy Monitor dialog box appears. When the status bar indicates that the file transfer is finished, click **Exit**.

You can verify that the file transfer worked by listing the new file in the target wIntegrate session.

### Transferring files by using FTP

The wIntegrate FTP dialog lets you transfer files using the standard FTP file transfer protocol.

1. From the main toolbar, select **Run > FTP**.

   ![wIntegrate FTP](image)

2. Click **Connect**.

3. From the Connect to Remote Host dialog box, select a profile, or enter the name of the host, your user name, and your password for the host. You can also specify the initial local and remote folders, if necessary. Click **OK**. Profiles save the information that you enter in the Connect to Remote Host dialog box. For more information, see **Creating a host profile, on page 69**.

4. In the top dialog boxes, navigate to the required folders on the local machine and the remote host.
5. In the bottom list boxes on the left or right side, select one or more files that you want to transfer, and click the << or >> button.
   You can select multiple files from the list boxes by using Shift + click and Ctrl + click.
6. When you are done transferring files, click Close on the wIntegrate FTP dialog box.

Creating a host profile

The Profiles drop-down menu on the Connect to Remote Host dialog box allows you to save host information and create a profile. With a profile, you can quickly connect to the host using the FTP instead of entering host details each time.

1. To add a new profile, in the Connect to Remote Host dialog box, click Edit. The Edit Profiles dialog box appears.

2. Click Add.
3. In the blank row that appears, enter the information for each column: Profile Name, Host, so on.
4. Continue adding profiles as necessary. If you need to delete one, select the row and click Remove.
5. When you are done adding profiles, click OK.
Chapter 5: Building queries with Query Builder

The Query Builder helps you transfer data from your host computer to the desktop and use it in a variety of popular formats including Excel and Word Mailmerge. The functionality is scripted, making use of the Import File process to actually transfer the data. Because it is a script, it can be modified by capable users to customize the functionality.

You might want to display the results of the query on the terminal screen or in the Report Viewer. If you choose to import the data, the program opens the destination application such as Excel or Word Mailmerge by default, depending on your chosen format.

If you are importing data, the advanced options that control many aspects of how data is imported help you maximize the usability of multi-valued data into the desktop.

If you right-click the toolbar area, you can enable the Queries toolbar, which has four options:

- Select a saved query from a drop-down
- Execute the query selected in the drop-down
- Show the main Query Builder dialog box
- Show the Batch Queries dialog box

For more technical users, the Query Builder is provided as a script that you can customize to suit your needs. Behind the scenes, it uses the run ImportFile processing to import the date from the host to the PC.

After you create a query that generates a report, you can save the query as a script and submit it again later to retrieve updated data.

If you are not familiar with this type of database query, refer to your database documentation.

Building queries

You can quickly build queries to enter at the command prompt using the Query Builder. The Query Builder allows you to select items and decide the sorting of them, as well as add header and footer options, and then select an output option to display the results.
1. From the main toolbar, select **Run > Query Builder**.

![Query Builder](image)

**Tip:** You can type information in any field if you know the name of the file, item, or other selection criteria. Otherwise, you can click a query button to search for the information you need.

2. From the **Verb** drop-down menu, select a verb to start the query.
   You will usually use **SORT** to create a report. You might use **SSELECT** if you want to select items and save the list with a **SAVE-LIST** statement in the **After** field.

3. Click **File**.
   The Files dialog box lists the files in the current account. Depending on the number of files in the account, you might need to wait a few seconds for the complete list to appear.

4. Select a file, and then click **OK**.
   After choosing the data file, you can back into the Files dialog box to choose to use the dictionary of a different file. Select the required dictionary file and the appropriate option. In the main dialog box, the **File** field is updated accordingly.
5. Click **Items**.
The Selection of Items dialog box appears.

**Figure 44: Selection of Items**

6. In the Selection of Items dialog box, specify your selection criteria, as described in the following table.

**Table 18: Selection of Items options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>And</td>
<td>Select this check box if you want to precede the phrase with AND.</td>
</tr>
<tr>
<td>Field</td>
<td>wintegrate automatically obtains the fields in the selected file from the host the first time you open the Query Builder. These fields are retained until you select a different file.</td>
</tr>
<tr>
<td>Operator</td>
<td>Select a relational operator to be used to evaluate data in the selected field against a specified value.</td>
</tr>
<tr>
<td>Value</td>
<td>Enter a value to be used to evaluate data in the field.</td>
</tr>
<tr>
<td>Prompt</td>
<td>Prompt the user for selection criteria at runtime with your custom message if the pattern is not matched.</td>
</tr>
<tr>
<td>Dates</td>
<td>Select run-time resolution of predefined dates, such as <code>lastmonth</code> or <code>today</code>. You can also control the parentheses for complex AND/OR criteria.</td>
</tr>
<tr>
<td>Quote Value</td>
<td>Select this check box if you want to enclose the value in quotation marks in the query statement. Typically, you will add quotation marks around text, not number.</td>
</tr>
<tr>
<td>Add</td>
<td>Click this button to add the current line below the displayed lines.</td>
</tr>
<tr>
<td>Insert</td>
<td>Click this button to insert the current line above the highlighted line in the Selection list.</td>
</tr>
<tr>
<td>Replace</td>
<td>Click this button to replace the highlighted line with the current line in the Selection list.</td>
</tr>
<tr>
<td>Delete</td>
<td>Click this button to delete the highlighted line in the Selection list.</td>
</tr>
<tr>
<td>Edit</td>
<td>Click this button to display the highlighted line in the Field, Operator, and Value boxes for editing.</td>
</tr>
</tbody>
</table>
You can also list user-defined prompts, as described in User-defined prompts, on page 76.

Select the Field that you want to use in the selection criteria, the Operator, and the Value to apply. Click the Add button to add this filter to the Selection list.

You can also enter specific item IDs in the Field section, or enter an asterisk (*) to import all of the fields in the file. Note that because no dictionary items are specified, the data is imported without field headings.

7. When the selection box is complete, click OK.

8. On the Query Builder, click Sort.

9. In the Sort criteria dialog box, select the fields that you want to sort by, then click Add >.

You can sort on multiple fields by adding or inserting field names. The field at the top of the Sort sequence list is the primary sort. The Add button places the selected field at the bottom of the Sort sequence list. The Insert button places the selected field above the selected line in the Sort sequence list.

To insert a field, select the line in the Sort sequence list above where you want to place the new sort field, and click the Insert button.

When you are done sorting, click OK.

10. On the Query Builder, click Output or type an asterisk (*) in the Output field.

Note: When you type an asterisk, no dictionary items are included that you could use to find out anything about the data. Because of this reason, no headings appear for the fields.

11. In the Output Criteria dialog box, select a Modifier and a Field. The modifier controls the output type for a selected field. Click Add.

Note: The TOTAL modifier option works in numeric fields only. For example, you might want to list the names of all staff members, then total the number of staff members listed. The TOTAL option does not work in this case because the information in the column is not numeric. However, the total number of records is always listed at the end of every report. The BREAK.ON modifier option creates a break line in the report when the value changes in the selected field. If you select BREAK.ON, enter the text to appear on break lines in the Option Text field.

12. After you select the output criteria, click OK.

13. On the Query Builder, click Heading.

14. In the Heading dialog box, enter a descriptive title for the report.

Note: If you select PC/Process from the Output To group on the Query Builder, and use any format other than a chart, the heading is not used. However, if you use a chart format, the heading is used as the title of the chart.

15. Add options to the title, such as the date or time, by clicking the buttons in the Add Option group, described in the following table.

For example, if you want to add a blank line after the report title, in the Add Option group, click New Line. The ‘L’ command, used to add a blank line, appears after the report title in the Definition field.
Table 19: Heading and footing options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Break</td>
<td>Inserts a command to place the BREAK value in the report heading or footing. The command for a break is B.</td>
</tr>
<tr>
<td></td>
<td>If you use this option, you must also select the BREAK.ON modifier in the Output Criteria dialog box.</td>
</tr>
<tr>
<td></td>
<td>See your database query language documentation for information about using the BREAK option.</td>
</tr>
<tr>
<td>New Line</td>
<td>Inserts a command to add a blank line between heading lines or between the heading or footing and the body of the report. Click this button once for every blank line you need. The command for a new line is L.</td>
</tr>
<tr>
<td>Date</td>
<td>Inserts a command to add the host system date to the report heading or footing. The command for the date is D.</td>
</tr>
<tr>
<td>Center</td>
<td>Inserts a command for centering the text on this line of the report heading or footing horizontally. The command for a centered line is C.</td>
</tr>
<tr>
<td>Time</td>
<td>Inserts a command to add the host system time in the report heading or footing. The command for the time is T.</td>
</tr>
<tr>
<td>Page No.</td>
<td>Inserts a command to add the page number to the report heading or footing. The command for the page number is P.</td>
</tr>
<tr>
<td>File Name</td>
<td>Inserts a command to add the file name to the report heading or footing. The command for the file name is F.</td>
</tr>
<tr>
<td>Page Justification</td>
<td>Sets the number of characters for right-justification of the page number. For example, if you expect the report to be 100 pages or more, enter 3 in this field so the page number is right-justified in a field of three spaces.</td>
</tr>
<tr>
<td>File Justification</td>
<td>Sets the number of characters for left-justification of the file name. With this option, you can set up identical spacing for the report heading and footing in similar reports.</td>
</tr>
</tbody>
</table>

**Note:** If you select PC/Process, do not use options in the Add Option group. The commands that are added are interpreted as literal characters and appear in the chart title.

16. After you add a title for the report, click **OK**.
17. On the Query Builder, click **Footing**.
18. In the Footing dialog box, enter a footer. Add options to the footer in the same way that you added options for the heading.
   See the previous table for descriptions of each option.

**Note:** If you select PC/Process from the **Output To** group on the Query Builder, the footing is not used.

19. After you add a footer for the report, click **OK**.
20. On the Query Builder, click **Grand Total**.
   The Grand Total dialog box allows you to compute the grand total in a numeric column. Grand Total only works in numeric fields, and might not work on some host machines.
21. In the Grand Total dialog box, enter a descriptive label for the grand total field in the **Definition** field.
   The additional options that you can add are described in the following table.
Table 20: Grand Total options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Underline</td>
<td>Inserts a command to add a line between the final line of the report and the Grand Total line.</td>
</tr>
<tr>
<td>Page Eject</td>
<td>Inserts a command that forces the Grand Total line to be displayed on a new page. The command for page ejection is P.</td>
</tr>
<tr>
<td>Line Suppress</td>
<td>Inserts a command that suppresses the blank line between the last line of the report and the Grand Total line. The command for line suppression is L.</td>
</tr>
</tbody>
</table>

22. When you are done adding a Grand Total definition, click OK.

23. From the Output To group, select an output option as described in the following table.

Table 21: Output To options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Screen</td>
<td>Displays the results of the report to the screen.</td>
</tr>
<tr>
<td>Report Viewer</td>
<td>Displays the report in the built in Report Viewer grid. This is a good alternative to the emulation screen because it removes the height and width limitations of the terminal screen. In the Report Viewer, you can sort data, move columns, and copy to Excel.</td>
</tr>
<tr>
<td>Host Printer</td>
<td>Prints the report to the printer for which your host computer is set.</td>
</tr>
<tr>
<td>Local Printer</td>
<td>Prints the report to the printer for which your computer is set. This can be the Windows default printer or a printer you selected for use in this session, as described in Setting up the printer, on page 25.</td>
</tr>
<tr>
<td>PC/Process</td>
<td>Saves the report to a file in a specified application format, opens the application, and loads the report file. For example, you might select Excel worksheet format and name the file report.xls. Excel starts and opens report.xls. See Importing a report to an application, on page 77 for information about the PC button that becomes available when you select the PC/Process option.</td>
</tr>
</tbody>
</table>

24. From the Suppress group, select an option as described in the following table. Suppress prevents the printing of certain information on a report.

Table 22: Suppress options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detail lines</td>
<td>No detail lines are printed. The only lines that are printed are those that you specified with the BREAK.ON modifier and a final total.</td>
</tr>
<tr>
<td>Item ID</td>
<td>Does not print the item ID at the beginning of each line.</td>
</tr>
<tr>
<td>Page heading</td>
<td>Does not print the default page heading.</td>
</tr>
<tr>
<td>Col. heading</td>
<td>Does not print the default column heading.</td>
</tr>
</tbody>
</table>

25. In the Before field, type an ECL statement to execute before generating the report.
This might be a stand-alone program that, for example, configures a printer. Or you might want to use a GET-LIST or SELECT statement to retrieve an existing list of item IDs before running a report.

26. In the After field, type an ECL statement or command to execute after the report.
For example, you might want to use a SAVE-LIST statement to store a list of item IDs.

27. On the Query Builder, click Save. Enter a file name with the extension of .wis to save the query as a wIntegrate script file in the My Documents\wIntegrate\Queries directory, and click Save.
When you click **Open** next time, the dialog box will populate with the same values.

The Queries toolbar has a drop-down menu that automatically shows saved queries.

28. On the Query Builder, click **OK** to run the report.

   wIntegrate exits the WIN.SERVER host program and enters the query statement at the command prompt as you entered it.

**User-defined prompts**

You can set up a query to prompt for values each time it runs. To do so, enter prompts in the **Items** or **Before** fields.

Use the following format when entering a prompt:

**Table 23: User-defined prompts**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;&lt;</td>
<td>Symbol indicating the start of user prompt data.</td>
</tr>
<tr>
<td>label</td>
<td>The label for the field to appear in the dialog box.</td>
</tr>
<tr>
<td>length</td>
<td>The length of the input field (default = 10). This does not restrict the number of characters entered.</td>
</tr>
<tr>
<td>pattern</td>
<td>The pattern for validation. Pattern format:</td>
</tr>
<tr>
<td></td>
<td>• &quot;&quot; – No validation.</td>
</tr>
<tr>
<td></td>
<td>• nt – Can be repeated as often as necessary. 0 means 0 or more, and t is a type.</td>
</tr>
<tr>
<td></td>
<td>• N – Numeric.</td>
</tr>
<tr>
<td></td>
<td>• A – Alphabetic.</td>
</tr>
<tr>
<td></td>
<td>• X – Any character.</td>
</tr>
<tr>
<td></td>
<td>• 'text' – Specific text that is enclosed in single quotation marks.</td>
</tr>
<tr>
<td>error</td>
<td>The text of the error message to be displayed if validation fails. (The default is a generic error message.)</td>
</tr>
<tr>
<td>&gt;&gt;</td>
<td>Symbol indicating the end of user prompt data.</td>
</tr>
</tbody>
</table>

**User-defined prompts example**

This example uses the **ORDERS** file in the UniData demo database. In the Query Builder, enter information in the **Items** field as shown in the following example.

```
WITH STATE = "<<State:;2;1X0X;The State must be entered>>"
AND WITH QTY >= "<<Minimum quantity:;6;1N0N;Minimum quantity must be entered as a number>>" AND WITH ORD_DATE >
"<<Ordered after:;8;2N'.'2N'.2N;Date format must be NN.NN.NN>>"
```
Importing a report to an application

With Query Builder, you can import a report to a file by selecting the **PC/Process** option from the **Output To** group. **wIntegrate** gives you several choices of application file types, including Microsoft Word and Microsoft Excel.

1. From the main toolbar, select **Run > Query Builder**.
2. On the Query Builder, click **Open** to select a saved report, or create a new report as described in **Building queries, on page 70**.
3. From the **Output To** group, select the **PC/Process** option.
4. Click the **PC** button.
   The Local PC Destination Parameters dialog box appears.

**Figure 45: Local PC Destination Parameters**

5. In the Local PC Destination Parameters dialog box, enter or browse to a file name, select the output application, and select the format that you want.
6. Click **Advanced**.
7. On the Advanced PC/Process Options dialog box, enter the following information. When you are done, click **OK**.

**Table 24: Advanced options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeout</td>
<td>The maximum number of seconds <strong>wIntegrate</strong> waits for a response to a protocol message. The default value of five seconds is sufficient. Valid values range 1 - 9999 seconds.</td>
</tr>
</tbody>
</table>

A timeout occurs when **wIntegrate** sends a protocol message and it does not get a response within a specified length of time. When a timeout occurs, **wIntegrate** resends the protocol message until the maximum number of retries is reached.
Chapter 5: Building queries with Query Builder

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Retries</td>
<td>The maximum number of times that wIntegrate sends a protocol message before a file transfer is abandoned. The default value of three is sufficient, or five retries in any case. Valid values range 0 - 9999. When transferring data in Capture mode, the Retries value applies only to the initial exchange of internal parameters. It is not relevant to the data transfer, which is dependent on capturing the output of a host query statement.</td>
</tr>
<tr>
<td>Mode</td>
<td>Allows you to specify Normal, Capture, or Reformat mode. If you are saving to an Excel file and you want to show exploded values for multivalued attributes, select Reformat.</td>
</tr>
<tr>
<td>Translate Characters</td>
<td>Translates characters while importing them. If selected, you can click the Translation button to set up the host characters that wIntegrate translates.</td>
</tr>
<tr>
<td>Number conversion</td>
<td>Allows you to enter the currency character, thousands separator character, and decimal character that is used in host data.</td>
</tr>
<tr>
<td>Explode values</td>
<td>Forces multi-values to appear one per line, rather than as a single long field all on the same line.</td>
</tr>
<tr>
<td>Repeat Values</td>
<td>Fills any blank values with the previous value in the same column so, for example, a single-value customer name will be repeated for all the matched multi-values.</td>
</tr>
<tr>
<td>Show Complete Field Headings</td>
<td>Column widths are determined by the length of the column heading rather than the length specified in the dictionary definition. This option is useful when the column heading is wider than the data.</td>
</tr>
<tr>
<td>Inform when done</td>
<td>A message informs you when the file import is complete. This option is useful if you want to run another application full-screen while wIntegrate transfers data.</td>
</tr>
<tr>
<td>Timeout</td>
<td>The maximum number of seconds wIntegrate waits for a response to a protocol message. The default value of five seconds is sufficient. Valid values range 1 - 9999 seconds. A timeout occurs when wIntegrate sends a protocol message, and it does not get a response within a specified length of time. When a timeout occurs, wIntegrate resends the protocol message until the maximum number of retries is reached.</td>
</tr>
<tr>
<td>Retries</td>
<td>The maximum number of times that wIntegrate sends a protocol message before a file transfer is abandoned. The default value of three is sufficient, or five retries in any case. Valid values range 0 - 9999. When transferring data in Capture mode, the Retries value applies only to the initial exchange of internal parameters. It is not relevant to the data transfer, which is dependent on capturing the output of a host query statement.</td>
</tr>
</tbody>
</table>

8. On the Load PC Destination Parameters dialog box, select an option in the File use section.
   - Select Open Application to open in an application, for example, open Excel with the newly created spreadsheet.
   - Select Create Only to prevent the application from opening.
   - Select Send To to prompt for email addresses to send the report to.

9. Click OK to close the Load PC Destination Parameters dialog box.

10. On the Query Builder, click OK to run the report.

The File Import Monitor appears while wIntegrate imports the file. wIntegrate starts the requested application, and your report displays within the application.
Chapter 6: Viewing reports with the Report Wizard

The Report Wizard lets you view host print reports on the PC. It allows you to parse out rows and columns from reports, and send the output to popular file formats such as Excel, HTML, PDF, and more.

Importing a report with the Report Wizard

To view host print reports on the PC, you must first import them using the Report Wizard.

1. From the main toolbar, select Run > Report Wizard.

Figure 46: Report Wizard

The Hold Entry list box shows all hold entries in the current account. You can restrict the displayed hold entries to match user needs and privileges by creating a custom Service Subroutine. For more information about how to create a Service Subroutine, see the Host Subroutines Reference.
2. From the **Hold Entry** group, select a report. The **Preview** section populates with a preview of the report. You can select the **Thumbnail** check box to view the full report in a thumbnail.

![Figure 47: Report Wizard with preview](image)

If you have already saved the header/footer, column header, and column delimiter parameters as a template, you can select a template from the **Template** section.

3. **Optional:** Click **Options**.

![Figure 48: Report Wizard Options](image)

   a. In the **Form feed sequence** field, specify the character received to start each new page. Usually this will be the regular CHAR 10 known as form feed. On VT emulations, this value might be different.
   
   b. If your report has initial lines on the beginning of the report that should be ignored, specify the number of **Lines to skip**.
   
   c. If your report has initial pages at the beginning of the report that should be ignored, for example, a banner heading, specify the number of **Pages to skip**.
   
   d. In the **Character Mapping** section, you can specify character strings that should be deleted or replaced.
4. If you want to review the report without parsing columns, click **Quick View**. The Report Viewer shows your complete report with no parsing, so you see the report exactly as it is stored on the host.

**Figure 49: Report Viewer**

![Report Viewer](image)

Click the X to close the Report Viewer.

5. To continue with the import, click **Next**.

The program attempts to determine the header/footer, column header, and column delimiters of the report. The color key on the right describes what each color means.

The program needs the header and column information to parse the report properly. When the host report is brought into the PC, the program removes embedded headers and footers from the body of the report, leaving only the first page header and the last page footer. The column headings are used to determine how the columns are parsed in Excel.

**Note:** The results might not be correct and may require some manual adjustment.
To modify the borders for the report, perform the following steps.

a. Place your cursor over a horizontal border, and drag the border to complete the specified color area. Some areas might not appear; for example, if you are working in a header, but do not see the blue color appear, you can drag the border to the header area to make the color specified area appear.

b. Continue specifying the horizontal borders for the heading, column headings, the top of the footer, and the end of the page. When a multi-page report is imported, the embedded headings/footings between pages will be removed.

c. Before modifying the vertical column borders, click **Reparse Cols**. The columns realign based on the yellow column header area and the headings.

d. If you need to re-adjust the columns, place your cursor over one, and drag it to the correct location.

e. To insert new columns, right-click in the report where you want the column, and select **Insert Column**.
f. To delete a column, right-click a column and select **Delete Column**.
g. Click the **Reparse All** button to automatically recalculate the position of all borders.

6. When the report looks like you want it to, click **Next**.

**Figure 52: Report Wizard**

7. From the **Target** drop-down menu, select the target application for the report.
8. In the **Target File** field, accept the default file name or enter a new one. Click the ellipsis button (...) to modify the file path.
9. If you want to save the settings that you specified in the previous page of the wizard as a template, select the **Save settings as a template** check box and name a new template.
   When you use the Report Wizard again, the template name appears in the first page of the wizard.
   Templates are saved as scripts in the `My Documents/wIntegrate/RwTemplates` folder. You can edit templates in a text editor and copy them to user machines.
10. If you want to return to the first screen of the wizard after the selected report has been generated, select the **Download another report after processing** check box.
11. Click **Finish** to create the final local PC file.
    The report appears in your chosen application.
Chapter 7: Troubleshooting

The following sections contain information to help you troubleshoot wIntegrate.

Session Copy dialog box appears when starting a session

Description
When you first start wIntegrate, or attempt to start another wIntegrate session, the Session Copy dialog box appears asking you to make a temporary copy of the session.

Explanation
By default, wIntegrate shows the Session Copy dialog box when an attempt is made to use a \( .wic \) file already in use. If you cleared the option to Show the session copy dialog box in future, you will not be prompted to use a copy of the \( .wic \) file – it will occur automatically.

If the Session Copy dialog box is disabled, you can enable it by selecting Setup > Application > General, and then selecting the Show session copy dialog check box. This option applies to all wIntegrate sessions.

There are two situations when the Session Copy Dialog will be displayed:

- when you attempt to start a session using the \( .wic \) file in use by another running session; or
- when a wIntegrate session terminated abnormally.

Windows keeps track of the files that have been opened. If a wIntegrate session terminates abnormally, Windows might believe a \( .wic \) file is still in use when it really is not. If you try to open a session using a \( .wic \) file, Windows believes it is already in use and the Session Copy Dialog will be displayed.

Resolution
If a wIntegrate session terminated abnormally, and you have a \( .wic \) file still locked by Windows, you must reboot the PC to clear the lock. Once you have rebooted, you can open a session using the original \( .wic \) file.

There is nothing wrong with using a copy of a \( .wic \) file already in use. If you have a standard 'look' you always want to use in a session, opening a copy of an existing \( .wic \) file is an easy way to accomplish this. As noted above, just be sure to not save this copy as a default startup session when you exit wIntegrate.

Detecting scripts stuck in a loop

Description
The wIntegrate Server attempts to close a hung session in a thin client deployment that is stuck in a loop.
Explanation

The hung session might be because of a programming error causing the script to run indefinitely, make heavy use of resources, and consume a user license.

*Note:* Closing an apparent hung session might interrupt a valid script that is executing a legitimate, long-running process. Developers can use the scripting Yield statement occasionally to trigger polling and prevent this from happening.

Resolution

The Script Loop Timeout value can be changed in the Registry by using the DWORD value:

```
HKEY_LOCAL_MACHINE\SOFTWARE\Rocket Software\wIntegrate Server\Script \ScriptLoopTimeout
```

If the Registry entry is not present, the default value is 600,000 milliseconds (10 minutes). The DWORD setting allows a number of milliseconds in the range 0 to around 49 days. A reasonable maximum value for Script Loop Timeout might be 30 minutes. When the wIntegrate Server generates a poll, the poll is shown in the Administrator log and written to file if the Log To File option is turned on.

Issues with side-by-side assemblies (SxS, WinSxS, and Manifests)

Description

wIntegrate is compiled using Microsoft Visual Studio, which includes the Microsoft Foundation Classes (MFC) to handle low-level tasks. wIntegrate installs the required MFC modules automatically if they are not already present. Different versions of these same executables can be present on one machine, and sometimes it seems like the Registry is not properly in synch.

Explanation

When you upgrade to newer versions of Visual Studio, you have to use the newer version of MFC that comes with it. The release notes contain any changes to the version of Visual Studio and MFC. The simplest way to see which version of MFC is used with a particular version of wIntegrate is to search the documentation for comments containing “MFC.”

For example, VS 2010 was first used in wIntegrate 6.3.2, released in 2012. See the 6.3.2 Release Notes, case UWIN-873.

wIntegrate deliberately plans its releases far enough after Visual Studio releases so that any potential issues with the new MFC modules have been identified and resolved by some other application.

Resolution

If you see an issue that mentions Side-by-Side Assemblies, WinSXS, or something similar, the best course of action is to download the appropriate Microsoft Visual C++ Redistributable Package, which refreshes the MFC installation. Go to [www.microsoft.com](http://www.microsoft.com) and search for "visual c++ redistributable package." Select the one that matches your installation.
Sluggish performance and the Nagle option (TCP_NODELAY)

**Description**

TCP/IP was developed many years ago when networks were less capable than today. The Nagle algorithm was implemented to reduce the number of packets. It delays the sending of each packet by 200 milliseconds in case more data must be added to the packet. The Nagle algorithm is probably enabled by default.

**Explanation**

Turning off the Nagle algorithm (behind the scenes, this is the TCP_NODELAY option) causes packets to be sent immediately, resulting in a larger number of smaller packets. This can give a noticeable improvement in performance with tasks that involve exchanges across the network, for example, GUI interfaces and/or thin client deployment.

**Resolution**

In wIntegrate, you disable the Nagle algorithm in Setup > Communications by selecting the TCP No Delay check box.

You can also do the same on the U2 server as follows:

- **UniVerse**: SET.TELNET NODELAY ON
- **UniData**: UDT.OPTIONS 109 ON

Data import/export issues when running with Chinese host encoding

**Description**

When importing or exporting data with the Chinese host encoding enabled, wIntegrate cannot properly handle the data.

**Explanation**

If wIntegrate is working with the Chinese GB18030 character set on the host UniVerse system, the settings must be configured accordingly.

**Resolution**

Set the Host Encoding to GB18030 in Setup > Terminal. Ensure that the UniVerse terminal map setting is set to "GB18030+MARKS". Without the "+MARKS" setting, wIntegrate cannot split the data into the correct fields using data delimiters such as attribute marks.

The UniVerse terminal map can be set by the SET.TERM.TYPE command, for example:

```
SET.TERM.TYPE VT100 MAP GB18030+MARKS
```

See the UniVerse documentation for more information.
Appendix A: Scripts

Copy menu scripts

You can assign the script for any Copy menu option to a mouse button or keyboard key. The following table lists the options on the wIntegrate Copy menu and their script commands.

For descriptions of the Copy menu options and the functions they perform, see Copying text, on page 45.

Table 25: Copy menu scripts

<table>
<thead>
<tr>
<th>Copy menu option</th>
<th>wIntegrate script</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text to Notepad</td>
<td>Library 'wintsys\script\CopyMenu';CopyTextNotepad</td>
</tr>
<tr>
<td>Text to Wordpad</td>
<td>Library 'wintsys\script\CopyMenu';CopyTextWrite</td>
</tr>
<tr>
<td>Bitmap to Paintbrush</td>
<td>Library 'wintsys\script\CopyMenu';CopyBitmapPbrush</td>
</tr>
<tr>
<td>Table to Excel</td>
<td>Library 'wintsys\script\CopyMenu';CopyTableExcel</td>
</tr>
<tr>
<td>Table to Lotus 123</td>
<td>Library 'wintsys\script\CopyMenu';CopyTable123</td>
</tr>
<tr>
<td>Text to Word</td>
<td>Library 'wintsys\script\CopyMenu';CopyTextWord</td>
</tr>
<tr>
<td>Bitmap to Word</td>
<td>Library 'wintsys\script\CopyMenu';CopyBitmapWord</td>
</tr>
<tr>
<td>Screen to Word</td>
<td>Library 'wintsys\script\CopyMenu';CopyScreenWord</td>
</tr>
<tr>
<td>Screen to Printer</td>
<td>Library 'wintsys\script\CopyMenu';CopyScreenPrinter</td>
</tr>
<tr>
<td>Create Pie Chart</td>
<td>Library 'wintsys\script\CopyMenu';Script 'example\script\PieChart'</td>
</tr>
<tr>
<td>Create Bar Chart</td>
<td>Library 'wintsys\script\CopyMenu';Script 'example\script\Bar- Chart'</td>
</tr>
<tr>
<td>HTML to Editor</td>
<td>Library 'wintsys\script\CopyMenu';HTMLEdit</td>
</tr>
<tr>
<td>HTML to Browser</td>
<td>Library 'wintsys\script\CopyMenu';HTMLBrowse</td>
</tr>
<tr>
<td>Text to Mail</td>
<td>Library 'wintsys\script\CopyMenu';CopyTextMail</td>
</tr>
</tbody>
</table>

Other scripts

You can modify any of these additional scripts if you want another menu or dialog box to appear. For example, in the script Menu Popup Edit, Mouse(Get_X), Mouse(Get_Y), you can replace Edit with the name of another menu, such as Setup. With this modification, the script opens the Setup menu instead of the Edit menu.

The following table lists scripts that you can edit and assign to a mouse button or keyboard key.
Table 26: Other scripts

<table>
<thead>
<tr>
<th>Function</th>
<th>Script</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the Edit menu as a pop-up window at the point where the mouse was clicked</td>
<td>Menu Popup Edit, Mouse(Get_X), Mouse(Get_Y)</td>
</tr>
<tr>
<td>Display the Copy Special To dialog box</td>
<td>Show EditCopyTo</td>
</tr>
<tr>
<td>Send to the host as input the word under the mouse click</td>
<td>Enter ScreenWord(Mouse(Get_X),Mouse(Get_Y),0)</td>
</tr>
<tr>
<td>Send a character that the host highlighted within a word as input to the host</td>
<td>Enter ScreenWord(Mouse(Get_X), Mouse(Get_Y),1)</td>
</tr>
</tbody>
</table>
Appendix B: SSL and SSH

wIntegrate supports the industry-standard Secure Sockets Layer (SSL) and SSH (Secure SHell) protocols for secure connections. Be aware that managing security and the required certificates for SSL can be a significant task for system administration. The encryption processing adds an overhead that can slow down communications.

Overview of SSL

SSL is by far the most widely deployed security protocol on the World Wide Web. It is a protocol implemented in the communications transport layer, so most TCP/IP processes can support it. For example, HTTPS and FTPS are SSL-secured implementations of HTTP and FTP. In wIntegrate, SSL is used with the Telnet process. SSL is used by the U2 databases UniVerse and UniData for secure communications.

The disadvantage of SSL is that performance will suffer to some extent due to the complexity of the encryption process.

The primary goal of the SSL Protocol is to provide privacy and reliability between two communicating applications. It aims to ensure that:
• The client can authenticate the server (digital certificate)
• Optionally, the server can authenticate the client (digital certificate)
• A connection is private (data encryption)
• A connection is reliable (message integrity checks)

Data encryption is automatically negotiated during initial connection, and message integrity checks are also automatic. Once the peer identity has been authenticated, everything else is automatic.

Certificates

Certificates (sometimes called digital certificates or digital IDs) are used during initial connection as a kind of electronic passport so that the recipient can authenticate that the sender is who it claims to be. Certificates are issued by trusted authorities called certification authorities. These include VeriSign, Thawte, and GlobalSign.

Once a recipient has authenticated the connection peer and is satisfied that the peer’s certificate has been issued by a trusted authority, the connection can proceed.

Server certificates

When a client initiates a connection to a server, the server responds with its server certificate. This certificate allows the client to verify that the communication is coming from a trusted authority, not an imposter, so the connection can proceed. If the server certificate cannot be authenticated or the client chooses to reject it, the connection will be terminated. This process is called Server Authentication.

Client certificates

When a server responds to a client initiating a connection, in addition to sending its certificate to the client, the server might request Client Authentication. If this happens, the client must provide its client
Appendix B: SSL and SSH

certificate to the server for authentication after the client has successfully authenticated the server certificate. Client Authentication is not normally used.

Obtaining certificates

Both server and client certificates can be obtained from Certification Authorities. The procedure for obtaining and installing certificates is explained on Certification Authority websites. You will provide information to a Certification Authority such as your organization name, department, country, email address, and certificate name. The Certification Authority in turn provides a certificate as a disk file that can be installed either into the disk filing system or into the Windows Certificate Stores.

Installing certificates

All servers that use SSL must have at least one server certificate installed somewhere on their system. This is true of the wIntegrate Server when it is acting as a server to wIntegrate Clients. wIntegrate uses the Windows Certificate Stores for all certificate authentication purposes. The procedure for obtaining and installing certificates is explained on Certification Authority websites, and most browsers can also be used to install newly-acquired certificates. A server certificate must be installed with an Exportable Private Key.

Viewing certificates

If you are unsure about whether you have a particular certificate installed and whether it is in the correct place, you can use your browser to view the certificates in the Windows Certificate Store. For more information about viewing SSL certificates in wIntegrate, see Viewing certificates, on page 90.

Specifying certificates in wIntegrate

wIntegrate uses the Windows Certificate Stores for all certificate authentication purposes. Certificates are specified during wIntegrate configuration by name. This name is the certificate Common Name and will be the name you gave for the certificate when you requested one from a Certification Authority.

Protocols

Client and Server can use one of several protocols to communicate using SSL:

- SSL2 - SSL protocol version 2
- SSL3 - SSL protocol version 3
- TLS - Transport Layer Security is the emerging standard based on SSL3
- PCT - Private Communication Technology

The protocol is automatically negotiated during initial connection. No one protocol is better than another. The main criterion for deciding upon a protocol is that both client and server support it. The most common protocol is SSL3.

Viewing certificates

You can view the SSL certificates and their details in the certificate chain. In each case below, the certificates in the certificate chain are shown in a grid with the following fields:

- Issued To
- Issued By
- Valid From date
- Valid To date
You can select a line and click the Details button to see all the fields contained in the certificate.

Errors during initial connection

Certificates are checked during the initial connection between wIntegrate (or wIntegrate Server) and the U2 host, and between the Windows/Java thin client and the wIntegrate Server. If a certificate is found to be invalid for any reason, a warning dialog appears and you can click a button to see the certificate details before making the connection.

Certificates between wIntegrate and the U2 host

To see the certificate chain between the U2 server and wIntegrate (or the wIntegrate Server), click the SSL Certificates button from the wIntegrate Help > Support Information menu option.

Certificates between wIntegrate thin clients and wIntegrate Server

To see the certificate chain between the Windows/Java thin client and the wIntegrate Server, click the SSL Certificates button from the wIntegrate Setup > Thin Client menu. This is a special menu option available only on the Windows and Java thin clients.

SSL options in wIntegrate

SSL support in wIntegrate is created by U2 Engineering, and based on the OpenSSL libraries. The same functionality is used by all U2 clients with the benefits of a common interface and easier debugging of any issues.

The following U2 database releases support SSL. Use the U2 Extensible Administration Tool (XAdmin) to configure SSL on your U2 server.

- UniVerse 10.1 and later
- UniData 6.1 and later

Communications can be secured between:

- wIntegrate as client to a U2 server
  
  This applies equally to the wIntegrate local install and the wIntegrate Server. The server certificate is mandatory. The client certificate is optional. To configure wIntegrate for SSL this way, see Setting up U2 SSL communications, on page 18.

- the wIntegrate Server and the Windows/Java thin client
  
  The server certificate is mandatory. Client certificates are not supported in this release. To configure wIntegrate for SSL this way, see Configuring the wIntegrate Server and thin client for SSL, on page 91.

The connection between the U2 server and wIntegrate uses Telnet, which runs over TCP/IP. However, the connection between the wIntegrate Server and the Windows/Java thin client is a simple TCP/IP connection. The difference in these communication protocols is irrelevant to SSL as it works at a lower layer. A certificate should work equally for any protocol based on TCP/IP.

Configuring the wIntegrate Server and thin client for SSL

This section applies to the connection between the wIntegrate Server and wIntegrate thin clients.

As with all wIntegrate Server options, SSL options are configured by running the Server Administrator program. SSL options are only available when the Server Administrator program is connected to a wIntegrate Server on the same computer.

There are two configurable SSL options under the Server tab:
SSL lets you specify that communications between the wIntegrate Server and the Windows/Java thin clients should be secured using SSL.

- **SSL Certificate** specifies which certificate to use as the Server Certificate. The name specified here will be a certificate Common Name. See [Specifying certificates in wIntegrate, on page 90](#).
  
  There is an option to browse for and select a certificate. The Select Certificate dialog box allows you to select a certificate from one of two certificate stores, Root or CA, in one of two locations, Machine Stores or User Stores. The Root certificate store is sometimes referred to as Trusted Root Certification Authorities and the CA certificate store as Intermediate Certification Authorities.

If SSL is enabled in the **Server** tab, the Java and Windows thin clients will negotiate with the wIntegrate Server which SSL protocol to use. The Java client will use either the SSL3 or TLS1 protocol.

**SSL tracing when using the Windows thin client**

If you have configured the wIntegrate Server to use SSL for the thin client connections, you can set the Windows thin client to trace SSL communications. This is useful in troubleshooting problematic connections (although the majority of SSL connection problems are caused by an invalid or inappropriate server certificate).

The thin client login dialog box has an **Advanced** button that lets you enable tracing before you log in to a wIntegrate Server. The Advanced Settings dialog box has the **SSL Tracing** options to determine the level of detail to be recorded in the trace file.

The options are:

- **None** – turns off all trace activity
- **Basic** – simple SSL information
- **Detailed** – more detailed SSL information
- **All** – detailed SSL information plus all incoming and outgoing data.

Tracing should be used with extreme caution as the trace files can grow to any size on disk. Trace files will grow continuously while the connection is open, even though you are not active on the session. Note that the tracing option only remains enabled for the duration of the connection with a wIntegrate Server. The next time you show the thin client login dialog, the tracing options will be set to **None**. The default location of the trace file is the Documents folder on the local computer.

**Overview of SSH**

SSH is a cryptographic network protocol that is used for secure data communication, remote command-line login, remote command execution, and other secure network services between two networked computers. It connects a server and a client running SSH server and SSH client programs, respectively, via a secure channel over an insecure network.

SSH differs from SSL in that the latter is a transport layer protocol that can be used by other network services to add a level of security. These network services are not considered part of the SSL specification.

The best-known application of SSH is for access to shell accounts on UNIX-like operating systems, but it can also be used in a similar fashion for accounts on Windows. SSH was designed as a replacement for Telnet and other insecure remote shell protocols such as the RSH and REXEC protocols, which send information (notably passwords) in plain text, rendering them susceptible to interception.

The protocol specification distinguishes between two major versions that are referred to as SSH-1 and SSH-2. The protocol has been continually evolving, but because a number of security flaws were discovered in the earlier versions of the protocol, it was decided to create a more secure, more feature-rich but incompatible protocol, SSH-2, to address these issues. Because of the inherent flaws
in SSH-1, its use should be avoided if possible. The default server port number of SSH connections is 22.

**SSH options in wIntegrate**

SSH can be used by wIntegrate or the wIntegrate Server for secure communications between it and a host server.

- **Protocol**: wIntegrate works with either SSH-1 or SSH-2 protocols, but because of the inherent flaws in SSH-1, SSH-2 should always be used if possible, for example, if the SSH server supports it.
- **Terminal Type**: Because SSH servers provide a secure shell, it might be necessary to set the terminal type for shell terminal emulation.
- **Client Authentication Key Filename**: This is the name of the file containing the key that will be used for public-key client authentication (see Authentication, on page 94). If no key file is specified, then public-key client authentication will not occur.

**Keys**

SSH uses Keys for client/server authentication and data encryption/decryption.

**Public-key cryptography**

Public-key cryptography, also known as asymmetric cryptography, is used in SSH connections for client/server authentication. It is a class of cryptographic algorithms that require two separate keys, one of which is secret (or private), and one of which is public.

Although different, the two parts of this key pair are mathematically linked. The public key is used to encrypt plaintext or to verify a digital signature; whereas the private key is used to decrypt ciphertext or to create a digital signature. The important feature of public and private keys is that data encrypted by one can only be decrypted by the other. Systems that use this type of cryptography rely on the freedom to share the public key.

**Secret-key cryptography**

Secret-key cryptography, also known as symmetric cryptography, is similar to public-key cryptography except that the same key is used to encrypt plaintext as is used to decrypt ciphertext. It is used in SSH connections for encrypting and decrypting session data, but only after server authentication has taken place and both client and server have agreed on a key to use.

**Certificates**

Certificates (sometimes called Digital Certificates, Public Key Certificates, or Digital IDs) are electronic documents that are used to verify the identity of an individual. They are used by SSH to authenticate server and client, one to the other.

Certificates are issued by trusted authorities called Certification Authorities such as VeriSign, Thawte, or GlobalSign. A certificate contains information about the certificate holder, a serial number, expiration dates, a copy of the certificate holder’s public key, and the digital signature of the Certification Authority that issued it.
Authentication

An important part of establishing a secure client/server connection using SSH is authenticating the identity of each end of the connection. The client should be confident that the server it is attempting to connect to is not an imposter and vice versa. With SSH, several different authentication methods can be available depending on specific implementations.

Server authentication

Server authentication is the process whereby the server identifies itself to the client and the client authenticates the server.

▪ **Public-key authentication**
  Implementation of this is required by the SSH specifications. Each SSH server has a public and private key pair that uniquely identifies the server. The first time an SSH client connects to a server, the client prompts the user to accept a copy of the server’s public key. If accepted, the client uses this public key to authenticate the SSH server on subsequent connections.

▪ **Authentication with certificates**
  This is similar to public-key authentication except that certificates are used to verify the name and public key combination of an SSH server. The SSH server name-to-key association is certified by a trusted Certification Authority. The SSH client knows only the Certification Authority root key and can verify the validity of all server keys certified by accepted Certification Authorities.

Client authentication

This is the process whereby the client identifies itself to the server and the server authenticates the client. The server identifies to the client which authentication methods it supports, and the client chooses which method, or methods, to adopt.

▪ **Public-key authentication**
  Implementation of this is required by the SSH specifications. In essence, the client sends a message to the server that contains the client’s public key with the message signed by the client’s private key. When the server receives this message, it checks to see whether the supplied key is acceptable for authentication and, if so, it checks to see whether the digital signature is correct.

▪ **Authentication with certificates**
  The client sends a certificate, which includes the client’s public key, to the server. The packet also contains random data that is unique to the session and signed using the client’s private key. The server uses the Certification Authority certificate to check that the client’s certificate is valid. It also verifies that the client has a valid private key by checking the digital signature in the packet.

▪ **Password authentication**
  The client user enters a log in name and password, which the client sends to the server for authentication.

▪ **Keyboard-interactive authentication**
  A versatile authentication method where an SSH server sends one or more prompts to enter information, and the client displays them and sends back responses keyed-in by the user. Often used in conjunction with a Pluggable Authentication Module (PAM).

▪ **Authentication with Generic Security Service Application Programming Interface (GSSAPI)**
  This is an extensible scheme to perform SSH authentication using external mechanisms such as Kerberos or NTLM, providing single sign on capability to SSH servers.

▪ **Host-based client authentication**
  Authentication is performed on the client’s host rather than the client itself. Thus, a host that supports multiple clients would provide authentication for all of its clients. This method works by having the client send to the server a digital signature created with the private key of the client.
Rather than directly verifying the user’s identity, the SSH server verifies the identity of the client host, trusting that the user has already authenticated on the client side.
Appendix C: Common network communication error codes

The following section describes the errors that might appear in Windows Sockets and U2 SSL communications.

Connection closed by host (1)
An existing connection was forcibly closed by the remote host. This normally results if the peer application on the remote host is suddenly stopped, the host is rebooted, the host or remote network interface is disabled, or the remote host closes the connection.

Connection closed by host (2)
The remote host was found to be out of action during a network operation on the connection.

Network failure
Indicates that a serious network failure has occurred.

Host unreachable (1)
The remote host is not accessible on the network. This usually occurs when an attempt is made to connect to a remote host that exists but cannot be reached.

Host unreachable (2)
The remote host is on a network that is not accessible. This usually occurs when an attempt is made to connect to a remote host.

Host failure
The remote host reset itself causing the connection to be closed. This typically means the remote host has been rebooted.

Connection closed
The local host has closed the connection because it encountered a problem or it detected that the remote host is not responding.

Connection refused
A connection to a remote host has been actively refused. This can occur when the service associated with the port number used to make the connection is unavailable or inactive. It typically occurs because the remote host name/alias or the port number used to make the connection are not specified as intended.

Connection request timed out
Indicates that the remote host has not responded after a predetermined amount of time. This can occur during a connection attempt or after a connection has been established (typically the former).
Host not found (1)

The remote host could not be located on the network. This typically occurs when an attempt was made to connect to a remote host with an invalid name/alias or with a name/alias that could not be resolved into a network address.

Host not found (2)

An invalid argument was supplied for a network operation. This can occur when an attempt is made to connect to a remote host using an invalid specification.