Notices

Edition

Publication date: March 2014
Book number: SBX-624-SBC-IM-01
Product version: Rocket SystemBuilder Extensible Architecture v6.2.4

Copyright

© Rocket Software, Inc. or its affiliates 1989-2014. All Rights Reserved.

Trademarks

Rocket is a registered trademark of Rocket Software, Inc. For a list of Rocket registered trademarks go to: www.rocketsoftware.com/about/legal. All other products or services mentioned in this document may be covered by the trademarks, service marks, or product names of their respective owners.

Examples

This information might contain examples of data and reports. The examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

License agreement

This software and the associated documentation are proprietary and confidential to Rocket Software, Inc., are furnished under license, and may be used and copied only in accordance with the terms of such license.

Note: This product may contain encryption technology. Many countries prohibit or restrict the use, import, or export of encryption technologies, and current use, import, and export regulations should be followed when exporting this product.

Contact information

Website: www.rocketsoftware.com
Rocket Software, Inc. Headquarters
77 4th Avenue, Suite 100
Waltham, MA 02451-1468
USA
Tel: +1 781 577 4321
Fax: +1 617 630 7100
Contacting Global Technical Support

If you have current support and maintenance agreements with Rocket Software, you can access the Rocket Customer Portal to report and track a problem, to submit an enhancement request or question, or to find answers in the U2 Knowledgebase. The Rocket Customer Portal is the primary method of obtaining support.

To log in to the Rocket Customer Portal, go to:

www.rocketsoftware.com/support

If you do not already have a Rocket Customer Portal account, you can request one by clicking Need an account? on the Rocket Customer Portal login page.

Alternatively, you can contact Global Technical Support by email or by telephone:

Email: u2support@rocketsoftware.com

Telephone:

North America +1 800 729 3553
United Kingdom/France +44 (0) 800 773 771 or +44 (0) 20 8867 3691
Europe/Africa +44 (0) 20 8867 3692
Australia +1 800 707 703 or +61 (0) 29412 5450
New Zealand +0800 505 515
# Table of Contents

## Chapter 1: Before Installing SBClient
- SBClient installation types .................................................. 1-3
- SBClient version numbering ................................................... 1-4
- Setting up the environment to support SBClient
  - Hardware requirements ....................................................... 1-5
  - Operating system requirements .......................................... 1-6
  - Software requirements ..................................................... 1-6

## Chapter 2: Installing SBClient on a Stand-alone PC
- Exporting settings before installing SBClient (optional) ............. 2-3
- Installing SBClient ............................................................. 2-6
- Importing settings after installing SBClient (optional) ............... 2-8
- Licensing information
  - Location of license files .................................................. 2-10
  - Displaying licensing information ....................................... 2-10
- Uninstalling SBClient ......................................................... 2-12
- Upgrading SBClient 4.x or earlier ......................................... 2-13

## Chapter 3: Installing SBClient in Silent Mode
- Creating a silent setup for SBClient ........................................ 3-3
- Accessing the SBClient setup.exe file ..................................... 3-3
- Creating the response file .................................................... 3-3
- Running the silent setup ...................................................... 3-5
- Checking for errors ............................................................ 3-6

## Chapter 4: Troubleshooting Installation Issues
- Installation issues .............................................................. 4-3
- Getting information about installation errors ......................... 4-3
- Resolving problems with installation ..................................... 4-4
# Chapter 5: Introduction to SBClient

The SBClient launch screen ........................................... 5-3
Accessing the launch screen ........................................... 5-3
Choosing a launch screen preference ................................. 5-3
Old launch screen ......................................................... 5-5
New launch screen ......................................................... 5-8
Changing the launch screen preference ............................... 5-16
Choosing the old launch screen after installation ................. 5-16
Choosing the new launch screen after installation ................. 5-17
Selecting options from the SBClient menu bar ..................... 5-19
Opening a session ......................................................... 5-20
  Opening a session from a profile .................................... 5-20
  Opening a document-based session ................................. 5-21
  Opening additional sessions ........................................ 5-21
Closing a Session ........................................................ 5-23
  Closing an active session from the session window ............. 5-23
  Closing an active session from within the session .......... 5-24
  Closing an inactive session ......................................... 5-25

# Chapter 6: Basic Session Configuration

Session types ............................................................... 6-3
Saving settings as a session configuration ......................... 6-4
  Creating a new session configuration ............................. 6-4
  Changing a session configuration .................................. 6-7
Configuring sessions ..................................................... 6-8
Setting up communication .............................................. 6-10
  Setting up serial communication ................................... 6-10
  Setting up network communication ................................. 6-12
  Setting up modem communication .................................. 6-13
Setting up a dialing directory ....................................... 6-19
  Adding entries in the dialing directory .......................... 6-20
  Changing a number in the dialing directory .................... 6-21
  Specifying additional numbers in an entry .................... 6-21
  Changing communication or login settings for an entry .... 6-21
Chapter 1: Before Installing SBClient

SBClient installation types ........................................ 1-2
SBClient version numbering ..................................... 1-3
Setting up the environment to support SBClient .......... 1-4
  Hardware requirements ......................................... 1-4
  Operating system requirements .............................. 1-5
  Software requirements ........................................ 1-5
SBClient installation types

SBClient 6.x offers two types of installations:

- **Stand-alone PC installation**
  Installs SBClient in its entirety to the local PC’s hard disk. For details, see Chapter 2, “Chapter 2: Installing SBClient on a Stand-alone PC.”

- **Silent installation**
  A silent setup automates distribution of SBClient software. When running the SBClient setup in silent mode, users do not need to monitor the setup or enter information. For details, see Chapter 3, “Chapter 3: Installing SBClient in Silent Mode.”
SBClient version numbering

This section explains the version numbering methodology for SBClient. It is important to understand this when upgrading to newer versions of SBClient.

6.2.0.4056

- Build number. This is a unique number used to identify each build of SBClient. This number is unique for each SBClient version.

- Minor release number. This is sometimes referred to as a Delta revision. This is the patch release of SBClient. It may come as a small executable or as a CD distribution. You are not required to upload a new version of the host library.

- Major release number. This indicates that there have been minor revisions and additions to SBClient. These changes require limited testing to ensure that SBClient works with your software or environment. You are required to load a new version of the host library.

- Version number. This indicates that there have been major revisions and additions to SBClient. These may include architectural or interface changes that may require additional testing to ensure that SBClient works with your software or within your environment. You are required to load a new version of the host library.
Setting up the environment to support SBClient

Before installing SBClient, you must complete several setup tasks.

**Procedure**

1. Check that you have the hardware required to support SBClient. See “Hardware requirements” on page 1-5.
2. Be sure that the computer’s operating system supports SBClient. See “Operating system requirements” on page 1-6.
3. Be sure you have other software that is compatible with this version of SBClient. See “Software requirements” on page 1-6.

**Hardware requirements**

The following table shows the hardware required to run SBClient. SBClient works best with the recommended components, but it requires at least the minimum components.

<table>
<thead>
<tr>
<th>Component</th>
<th>Recommended</th>
<th>Minimum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer</td>
<td>Pentium or better</td>
<td>Pentium</td>
</tr>
<tr>
<td>Disk drives</td>
<td>Hard disk with 45MB or more available disk space) and CD-ROM</td>
<td>Hard disk (minimum of 35MB to 45MB available disk space) and CD-ROM</td>
</tr>
<tr>
<td>RAM for Windows 2003 or Windows XP</td>
<td>256 MB</td>
<td>128 MB</td>
</tr>
<tr>
<td>Monitor</td>
<td>Super VGA</td>
<td>VGA or compatible</td>
</tr>
<tr>
<td>Communication</td>
<td>Network card</td>
<td>Network card or serial port</td>
</tr>
</tbody>
</table>

Hardware Requirements
Operating system requirements

The following table lists the operating systems that support SBClient on Windows. SBClient works best with the recommended components, but you may test SBClient on earlier service packs at your own discretion. SBClient is not supported on the beta version of any operating system.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Windows Server 2008</td>
<td>R2 Service Pack 1 or later</td>
</tr>
<tr>
<td>Microsoft Windows Server 2012</td>
<td>Standard edition (64-bit)</td>
</tr>
<tr>
<td>Microsoft Windows 7</td>
<td>Professional, Enterprise, or Ultimate edition, Service Pack 1 or later</td>
</tr>
<tr>
<td>Microsoft Windows 8</td>
<td>Enterprise edition (64-bit)</td>
</tr>
</tbody>
</table>

Software requirements

Software compatibility statement

The version of all SB/XA V6.x.x components must be an exact match, from the same version, major release, point release, and build number. To be certain that you have matching versions of SB/XA software, install all SB/XA V6.x.x components from the same SB/XA product download directory.

In V6.2.x, SB/XA Browser Client and SB/XA Rich Client do not support certain functionality that you need for application development work:

- Developing screens
  Not available in SB/XA Browser Client
- Developing reports
  Not available in SB/XA Browser Client or SB/XA Rich Client

SBClient V6.x.x provides support for the functionality that is not available in SB/XA Browser Client or SB/XA Rich Client. SBClient V6.x.x is also required to complete the script portion of the SB/XA Application Server installation.
SBClient V6.x.x is not sold as a separate product; it is included on the SB/XA 6.x.x product CD and is covered by the same product license. SBClient V6.x.x does not run with SB+ Server V5.x or earlier; it is compatible only with SB/XA V6.x.x and later.

SBClient V6.x.x is installed as an option of the SB/XA product CD menu. For instructions, see Chapter 2, “Chapter 2: Installing SBClient on a Stand-alone PC” on page 2-1. SBClient software authorizes automatically.
Chapter 2: Installing SBClient on a Stand-alone PC

Exporting settings before installing SBClient (optional) ... 2-2
Installing SBClient ........................................... 2-5
Importing settings after installing SBClient (optional) .... 2-7
Licensing information ....................................... 2-9
  Location of license files .................................. 2-9
  Displaying licensing information ...................... 2-9
Uninstalling SBClient ...................................... 2-11
Upgrading SBClient 4.x or earlier ....................... 2-12
Exporting settings before installing SBClient (optional)

This section describes an optional task to export settings before installing SBClient 6.0.2 or later on Windows.

Existing customers who installed SBClient 6.0.1 or earlier might have session configurations, scripts, phone books, toolbars, and Smart Query definitions that can be used in SBClient 6.0.2 or later.

If you want to save settings from SBClient 6.0.1 or earlier, you can export the settings to a file before installing SBClient 6.0.2 or later. After installing the latest version of SBClient, you can then import the files containing the settings that you saved.

**Procedure**

1. On the computer on which SBClient 6.0.1 or earlier is installed, create a temporary folder for storing your existing SBClient settings. For example, create a folder such as C:\temp\SBClientsettings
2. Open your existing SBClient version 6.0.1 or earlier.
3. Start a session to log on to the host computer on which SB/XA Application Server 6.0.2 or later is installed.
4. Log to the SB or SB+ account.
5. From the **Admin** menu, select **Export SBClient Settings**.
6. In the **Export SBClent Settings** dialog box, select the settings you want to save.

   ![Export SBClent Settings dialog box]

   In the **Export Path** field, enter the full path of the temporary folder you created in step 1.

   Select all of the settings check boxes:
   - Session Configurations
   - Scripts
   - Phone Books
   - Toolbars
   - Smart Query Definitions

   **Tip:** You must export all of your SBClent settings. You can selectively import any or all of these settings later.

   If you want to overwrite previously exported settings, select the **Overwrite Existing SB** check box. If this check box is cleared and you previously exported settings to the same folder, a prompt is displayed to ask if you want to overwrite existing settings.

   To export the SBClent settings, press **F2**.

7. In the “Completed” message dialog box, press the **Continue** button.
Next steps

The next task is to install SBClient 6.0.2 or later. For instructions, see “Installing SBClient” on page 2-6.

After installing SBClient 6.0.2 or later, you can import the saved settings. For instructions, see “Importing settings after installing SBClient (optional)” on page 2-8.
Installing SBClient

When installing SBClient, the InstallShield Wizard guides you through the process.

The installation process performs the following tasks:

- Installs the SBClient files at a location you specify during the installation process.
- Creates an SBClient folder in the Start menu.
- Adds the SBClient Manager to the Start group if requested during the installation process.

If you are upgrading from a previous version of SBClient, some dialog boxes are skipped because InstallShield detects the information on your computer. The instructions in this section cover both new installations and upgrades.

Procedure

1. Log on to Windows Server 2003, Windows Vista, Windows XP, or Windows 7 on the computer on which you want to copy SBClient.
2. Turn off any virus protection software because it can interfere with the installation.
3. Close all Windows programs. This frees up memory for installation and prevents possible conflicts between the SBClient installation program and other programs.
   Warning: If Microsoft Outlook is running on your computer, you need to close the program now. Microsoft Outlook interferes with the installation process.
4. In the SB/XA product download directory, navigate to the SB/XA installation program, AutoRun.exe, and open it.
5. From the SystemBuilder Extensible Architecture Setup Menu, select the Install SBClient option.
6. Follow the steps in the installation wizard.
   If SBClient is already installed on your computer, you are given the option to continue the installation and overwrite the existing version of SBClient, or quit the installation.
   SBClient offers a new launch screen, but the old one is still available. In a Setup Type dialog box, you can choose which launch screen to use. For information on both variations of the launch screen, see “The SBClient launch screen” on page 5-3.
   In a second Setup Type dialog box, you can choose whether to run multiple sessions of SBClient on a single instance of the SBClient engine:
   - The Use single instance of SBClient engine option is selected by default. With this option, multiple sessions of SBClient run on one instance of the SBClient engine. If one session terminates, all other sessions terminate.
   - As an alternative, you can select the Use multiple instances of SBClient engine option to run each session of SBClient on its own instance of the SBClient engine. With this setting, if one session terminates, the other sessions continue running.

7. When the program has finished copying files, the InstallShield Wizard Complete dialog box indicates that the installation completed successfully.
   The View Release Notes check box is selected by default. If you do not want to read the SBClient release notes, clear the check box.
   To close the wizard, click Finish.
   If you requested to view release notes, the file opens. After reading the release notes, close the file.
Importing settings after installing SBClient (optional)

If you exported settings from SBClient 6.0.1 or earlier, you can complete the following steps to import those settings to SBClient 6.0.2 or later.

Procedure

1. Open SBClient 6.0.2 or later.
2. From the File menu, select Import Configuration.
3. In the **Import Configuration** dialog box, select the settings that you want to import, as detailed below.

In the **Files to Import** area, select the check box for each file containing saved settings that you want to import to SBClient 6.0.2 or later.

From the **Import Data Type** list, select **SBClient**.

In the **Import Files from Folder**, browse to the temporary folder in which you saved your settings from SBClient 6.0.1 or earlier.

If you want to overwrite your existing settings, select the **Overwrite Existing** check box.

To begin importing the selected settings to SBClient 6.0.2 or later, click the **Import** button. Respond to prompts regarding file overwrites and imported configuration messages.
Licensing information

SBClient 6.1.x is not sold as a separate product; it is included on the SB/XA
6.1.x product CD and is covered by the same product license. SBClient 6.1.x
software authorizes automatically.

Location of license files

Terms of the license agreement for SBClient 6.1.x are stored in license files,
one for each supported language. The name of each license file is xxx.txt,
where xxx is the name of the language in which the license agreement is
written.

When you install SBClient 6.1.x, the license .txt files are placed in the
\License folder in the SBClient installation directory. By default, the license
files are installed in the following folder:

C:\U2\SBClient6\License

You may have specified a different installation directory when you installed
SBClient 6.1.x. To check the location of your license files, select Help > About
SBClient from the SBClient main menu. The splash screen accessed from this
menu option displays the location of the folder in which your license .txt files
were placed at installation. For an example of the splash screen, see
“Displaying licensing information” below.

In SBClient 6.1.x, the license .txt files are also included on the SB/XA product
CD. If the license files in your installation directory are later missing or
corrupted, you can access the files on the product CD.

Displaying licensing information

To get information about your version of SBClient, choose Help > About
SBClient from the SBClient main menu.
As shown in this example, the splash screen displays the version number of the software, a generic serial number, and generic license information. It also displays the full path of the folder containing your SBClient license files.
Uninstalling SBClient

This section contains instructions for uninstalling SBClient.

Procedure

1. Make sure that SBClient and the SBClient Manager are not running.
2. Click Start > Control Panel.
3. Click Uninstall a program.
4. In the list, right-click SBClient and click Uninstall.

Note: SBClient uses some shared Windows dynamic link libraries (DLLs). When SBClient is uninstalled and no other program has registered itself as using these DLLs, SBClient asks whether you want to remove the DLLs. If you are not sure whether other programs need the DLLs, do not delete them.
Upgrading SBClient 4.x or earlier

Prior to SBClient 5.0, the installation program did not perform self-upgrades. To upgrade from versions of SBClient earlier than 5.0, you must install SBClient to a new location. The first time you run SBClient, it prompts you to import your configuration from your previous version into the current configuration. Software that repackages and deploys SBClient can disable this upgrade prompt through the NoUpgrade registry entry. This entry is a string and should be set to “1” to disable the upgrade prompt. This entry is part of the SBClient key found in the following directory:

HKEY_LOCAL_MACHINE\SOFTWARE\Rocket Software\SBClient

In versions 5.0 and later, SBClient can self-upgrade: it can install a new version on top of an earlier version and maintain user configurations.

By default, SBClient 6.x.x will not overwrite earlier versions of SBClient. This is by design, since SBClient 6.x.x is not compatible with SB+ Server 5.4.4 or earlier. You may want to keep a matching version of SBClient 5.4.4 or earlier for use with SB+ Server. When installing SBClient 6.x.x, you can change the default installation directory to overwrite an earlier version of SBClient, if desired.

If you install a new version on top of an earlier version, SBClient files that were part of the older version and are no longer required will be removed. If the group you select for your program icons is the same as a previous version, the older icons that are no longer used will be removed.
Chapter 3: Installing SBClient in Silent Mode

Creating a silent setup for SBClient ........................................ 3-2
Accessing the SBClient setup.exe file ................................. 3-2
Creating the response file .................................................. 3-2
Running the silent setup ..................................................... 3-4
Checking for errors .......................................................... 3-5
Creating a silent setup for SBClient

SBClient V6.x.x allows automated electronic software distribution, also called silent setup. When running SBClient installation in silent mode, users do not need to monitor the setup or enter information in dialog boxes. The silent setup runs on its own, without user input.

Creating a silent setup is accomplished in four tasks:

1. Accessing the SBClient setup.exe file
2. Creating the response file
3. Running the silent setup
4. Checking for errors

Accessing the SBClient setup.exe file

As the first step, you need to access the SBClient setup.exe file, which you will then run to create a response file.

Procedure

1. Navigate to setup.exe in the product download directory or in the SBClient installation directory of an installed copy of the product. The default installation directory is:
   C:\U2\SBClient6
2. If you want to run the setup.exe from the SBClient installation directory on a local computer, install SBClient using the normal setup. For instructions, see chapter 2, “Chapter 2: Installing SBClient on a Stand-alone PC.”

Creating the response file

In the normal installation process using InstallShield Wizard, the setup process gets its input from the user’s responses in dialog boxes. A silent setup gets its input from an InstallShield Silent response (.iss) file.
The response file contains information that a user would normally input in response to dialog boxes when running a normal setup. A response file is a plain text file with sections that contain data. The SBCClient silent setup reads the input from the response file when the installation is executed at run time.

SBCClient 6.x.x provides a response file called setup.iss. You can find this file in the product download directory or in the SBCClient installation directory if you have installed the product. The setup.iss file contains the SBCClient default responses. You can use the setup.iss file out of the box if all the default responses are the correct ones for your users.

In most cases, you will want to use your own response file. You can create a response file by running the setup in record mode and entering the desired responses in each dialog box. When you run setup.exe in record mode, the process creates a response (.iss) file. You can create as many response files as necessary to cover new installations, upgrades, and the specific needs of groups of users.

Procedure

1. In the Command Prompt window, at the command line prompt change directories to the folder that contains the SBCClient setup.exe.
2. Run the setup in record mode by entering a command with appropriate parameters at the prompt.
   
   The command syntax is as follows:
   
   ```
   setup.exe -r [-f1"response_file_name_and_path"]
   ```
   
   The -r parameter starts the setup.exe program in record mode. With the -r parameter alone, a response file called setup.iss is created in the system’s Windows folder by default.

   The -f1 parameter allows you to specify an alternative file name and location where the response file is to be created. When you specify an alternative file name and path for the response (.iss) file, enter an absolute path; using a relative path yields unpredictable results.

3. The setup starts. It displays all run-time dialog boxes the same as a normal setup. In each dialog box, enter the desired response of users who will run the silent setup. Each response is stored in the .iss file.

   **Note:** While working in record mode, any registration details entered in the **Registration** dialog box are not stored in the response file.
4. When you finish entering responses in the last dialog box, the response (.iss) file is complete. The file is saved automatically.

**Running the silent setup**

After you have created a response file, the next step is to run the setup in silent mode, using the response file as input to the silent setup.

**Procedure**

1. In a DOS window, launch a test run of the silent setup by entering a command with appropriate parameters at the command line prompt.

   The command syntax is as follows:
   ```
   setup.exe -s [-f1 "response_file_name_and_path"]
   [-f2 "log_file_name_and_path"]
   ```

   The `-s` parameter runs the `setup.exe` program in silent mode. Without the `-f1` parameter, the command by default uses responses stored in the `setup.iss` file in the system’s Windows folder. Without the `-f2` parameter, the command by default creates a `.log` file in the same directory and with the same name as the response file (except for the extension).

   The `-f1` parameter allows you to specify an alternative file name and path where the response file is located. When you specify an alternative file name and path for the response file, enter an absolute path; using a relative path yields unpredictable results.

   The `-f2` parameter allows you to specify an alternative file name and path where the log file is to be created. When you specify an alternative file name and path for the log file, enter an absolute path; using a relative path yields unpredictable results.

2. The silent setup starts. No dialog boxes or messages are displayed. In silent mode, `setup.exe` gets its input from the response (.iss) file and captures setup information in a `.log` file, including whether the setup ran successfully.
Checking for errors

After you have completed a test run of the silent setup, the next task is to check for errors in the log file generated by the silent setup.

The default name of the silent setup log file is setup.log. The log file is by default created in the same directory and with the same name as the response file (except for the extension). However, you may have used the \(-f1\) and \(-f2\) parameters to specify a different name and location for the log file.

Procedure

1. Check the following three sections of the setup.log file:
   - **InstallShield Silent** is the first section. It states the version of InstallShield Silent used in the silent setup.
   - **Application** is the second section. It identifies the name and version of the installed application and the company name.
   - **Response Request** is the third section. It contains the result code, which indicates whether the silent setup was successful. If the silent setup failed, the result code indicates the reason for the error.

<table>
<thead>
<tr>
<th>Result Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>The silent setup was successful.</td>
</tr>
<tr>
<td>-1</td>
<td>General error.</td>
</tr>
<tr>
<td>-2</td>
<td>Invalid mode.</td>
</tr>
<tr>
<td>-3</td>
<td>Required data was not found in the InstallShield response (.iss) file.</td>
</tr>
<tr>
<td>-4</td>
<td>Insufficient memory available.</td>
</tr>
<tr>
<td>-5</td>
<td>The file does not exist.</td>
</tr>
<tr>
<td>-6</td>
<td>Cannot write to the response (.iss) file.</td>
</tr>
<tr>
<td>-7</td>
<td>Unable to write to the log file.</td>
</tr>
<tr>
<td>-8</td>
<td>Invalid path to the InstallShield response (.iss) file.</td>
</tr>
</tbody>
</table>

Silent setup result codes
2. If the result code indicates an error, find the source of the error indicated by the code, make corrections, and test the silent setup again.

If the silent setup completed successfully, you are ready to package it for deployment to users in a manner that meets the needs of your organization.

<table>
<thead>
<tr>
<th>Result Code</th>
<th>Description (continued)</th>
</tr>
</thead>
<tbody>
<tr>
<td>-9</td>
<td>Not a valid list type (string or number).</td>
</tr>
<tr>
<td>-10</td>
<td>Data type is invalid.</td>
</tr>
<tr>
<td>-11</td>
<td>An unknown error occurred during the silent setup.</td>
</tr>
<tr>
<td>-12</td>
<td>Dialog boxes are out of order.</td>
</tr>
<tr>
<td>-51</td>
<td>Cannot create the specified folder.</td>
</tr>
<tr>
<td>-52</td>
<td>Cannot access the specified file or folder.</td>
</tr>
<tr>
<td>-53</td>
<td>Invalid option selected.</td>
</tr>
</tbody>
</table>

Silent setup result codes (continued)
Chapter 4: Troubleshooting
Installation Issues

Installation issues ............................................. 4-2
Getting information about installation errors .... 4-2
Resolving problems with installation .............. 4-3
Installation issues

This section contains information on troubleshooting problems encountered while installing SBClient:

- Getting information about installation errors
- Resolving problems with installation

Getting information about installation errors

If you encounter problems while installing SBClient, a description of the problem is displayed in a Warning dialog box at the end of the installation process:

![Warning dialog box]

The following errors were detected during installation:

- Error copying file PSAFI.DLL to C:\WINDOWS\SYSTEM
- Error registering WVFREE.DCX

Make a note of these errors in case you need to describe the nature of the problem to a technical support analyst.
Resolving problems with installation

If you have trouble installing SBClient, try one or more of the following:

■ Turn off any virus protection software or other utilities on your computer.
■ Close all Windows applications.
■ Check the Readme file on the product CD in the \install directory for any additional information about installing SBClient.
■ Try rebooting the PC and going through the installation steps again.

If you still have trouble, contact Global Technical Support.
Chapter 5: Introduction to SBCClient

The SBCClient launch screen ........................................... 5-2
  Accessing the launch screen ........................................... 5-2
  Choosing a launch screen preference ................................. 5-2
  Old launch screen .......................................................... 5-4
  New launch screen .......................................................... 5-7
Changing the launch screen preference ................................. 5-15
  Choosing the old launch screen after installation ................. 5-15
  Choosing the new launch screen after installation ............... 5-16
Selecting options from the SBCClient menu bar ........................ 5-18
Opening a session ............................................................. 5-19
  Opening a session from a profile ...................................... 5-19
  Opening a document-based session .................................... 5-20
  Opening additional sessions ............................................ 5-20
Closing a Session .............................................................. 5-22
  Closing an active session from the session window .............. 5-22
  Closing an active session from within the session ............... 5-23
  Closing an inactive session ............................................. 5-24
The SBClient launch screen

The SBClient launch screen provides a graphical user interface in which you can start a session or perform common setup tasks. It is typically the first interactive screen displayed when you log on to SBClient.

Accessing the launch screen

The launch screen is displayed when you:

- Initially log on to SBClient, with the following exceptions:
  - Depending on how your implementation of SBClient is configured, the application may bypass the launch screen and take you directly into the application.
  - If you have previously used the File > Save Desktop option to save details of your open sessions, the launch screen does not appear when you log on to SBClient. The screen of the saved session is displayed instead.
- Select File > New Session. A separate launch screen is displayed for each new session you open.
- Click the New Session button on the dialog box displayed when you exit the active session (if only one session is open).

Choosing a launch screen preference

SBClient 6.x.x supports two variations of the launch screen. You can choose either launch screen as a preference:

- Old launch screen – The legacy interface, also known as SBClient Office.
- New launch screen – The standard interface.
You can select which launch screen you want to use at installation or later:

- Choosing it during installation. When you install SBClient 6.1.x, you are given the choice of using the new launch screen or the old one. If you use the SBClient setup.exe program out of the box, the new launch screen is the default selection. For instructions on choosing the launch screen during installation, see Chapter 2, “Chapter 2: Installing SBClient on a Stand-alone PC.”

- Changing your preference later. You can change your preference after installation by setting the NEWLAUNCHSCREEN parameter in the SBOPEN.INI file, as detailed in “Changing the launch screen preference” on page 5-16.
Old launch screen

The old launch screen (also known as SBClient Office) remains the same as it was in previous versions of SBClient. The screen is made up of a collection of graphics that serve as active areas. When you click an active area, it performs a function, as shown in the illustration below.

Using the old launch screen

The active areas on the launch screen provide you with an alternative means of selecting commonly used options from the SBClient menu bar. For example, clicking on the PC keyboard opens the PC Keyboard Setup dialog box (as if you had selected Setup > Keyboard).
As you move your mouse pointer around the launch screen, you will see your standard pointer change to a small hand. This indicates you are in an active area. A description of the active area is displayed in the status line at the bottom of the screen.

The active areas of the old launch screen are divided into two parts: PC active areas on the left and host active areas on the right. Active areas are as follows:

- Session Name List
- Communication
- Terminal
- Keyboard
- Color
- Dialing Directory
- About SBClient
- Start Session
- Exit

**Session Name List**

This active area is located in the picture frame above the telephone. It provides a list of connection profiles for your session configurations saved previously. Click a session configuration name to select that configuration. Double-clicking a session configuration name opens a session with that configuration, as if you had clicked the Start Session active area (the switch next to the telephone), or you had selected **File > Open Session > Classic**.

**Communication**

This active area is located on the telephone. Communication types (based on the means of physical connection: serial, network or modem) are shown embossed on the front of the phone, with the communication type of the current session highlighted. Click on an unselected communication type to select it. Click the telephone or double-click a communication type to display the **Communication Setup** dialog box (as if you had selected **Setup > Communication**).
Terminal

This active area is located on the PC to the left of the telephone. It displays the Terminal Setup dialog box (as if you had selected Setup > Terminal). This dialog box displays a selection list of the types of terminal that SBClient emulates, with the terminal type for the current session highlighted.

Keyboard

This active area is located on the PC keyboard. It displays the PC Keyboard Setup dialog box (as if you had selected Setup > Keyboard).

Color

This active area is located on the framed picture above the PC. It displays the Color Setup dialog box (as if you had selected Setup > Color).

Dialing Directory

This active area is located on the satellite. It displays the Dialing Directory dialog box, where you can maintain details of modem phone numbers (as if you had selected Setup > Dialing Directory). This is active only if Modem is selected as the communication type.

About SBClient

This active area is located on the base of the telephone. It displays information about your version of SBClient (as if you had selected Help > About SBClient).

Start Session

This active area is located on the switch to the right of the telephone. It opens a session using the currently selected session configuration (as if you had double-clicked the session list or selected File > Open Session).

Exit

This active area is located on the window above the PC. It allows you to exit SBClient (as if you had selected File > Exit All).
New launch screen

The new launch screen in SBClient 6.1.x gives you the standard look and feel of U2 software products. It is the option selected by default when you install SBClient.

This launch screen contains fewer buttons than the old version. Only the most commonly used items were carried forward to the new screen.

If an option was no longer relevant or used only rarely, the button was not included on the new launch screen. However, the functionality of those buttons is still accessible from the main menu when you use the new launch screen. For detailed instructions, see “Accessing less-used tasks” on page 5-13.

The remaining options have been renamed and have a new look. These options are detailed in “Using the new launch screen” on page 5-9.
Using the new launch screen

The following sections provide instructions for using each button on the new launch screen:

- Selecting a connection profile
- Setting up terminal emulation
- Starting a session
- Setting up scripts for a session
- Exiting SBClient

Selecting a connection profile

The Select Connection Profile list allows you to select the name of a previously saved connection profile to use when you start your next session.

Procedure

1. In the Select Connection Profile list, click the arrow to see a list of saved connection profiles.
2. Select the name of a saved connection profile to use in your next session.
Setting up terminal emulation

The Set Up Terminal Emulation option allows you to specify the type of terminal your computer emulates in a session defined by a connection profile.

This button provides the same functionality as clicking the terminal graphic in the old launch screen, as shown on page 5-5. It opens the Terminal Setup dialog box (as if you had selected Setup > Terminal from the main menu). This dialog box contains a selection list of the types of terminals that SBClient emulates.

Procedure

1. Click the Set Up Terminal Emulation button.
2. In the Terminal Setup dialog box, select a terminal type from the Emulation list.
3. The Configure button opens a dialog box that allows you to configure the selected terminal type for the session. The dialog box remains the same as it was in previous versions of SBClient. If you need instructions, see “Terminal Setup” in Chapter 2, “Configuring a Session,” in Using SBClient.
4. When you have finished, click OK to save your changes.
Starting a session

After you have selected a connection profile from the list at the top of the launch screen, use the Start a Session button to open a session defined by the connection profile. A session is a connection between SBClient and the server.

This button provides the same functionality as clicking the switch next to the telephone in the old launch screen, as shown on page 5-5. It opens a session (as if you had selected File > Open Session > Classic Session from the main menu).

Procedure

1. Click the Start a Session button.
   - If you have assigned a login script to the session, the script runs automatically and logs you in to SBClient.
   - If you have not assigned a login script, the login process requires you to enter information manually at each prompt.

Setting up scripts for a session

The Set Up Script for a Session option allows you to assign login and logout scripts to a session defined by a connection profile.
This button provides the same functionality as clicking the host graphic in the old launch screen, as shown on page 5-5. It opens the Script Setup dialog box (as if you had selected Setup > Script from the main menu). The dialog box remains the same as it was in previous versions of SBClient.

Procedure

1. Click the Set Up Script for a Session button.
2. In the Script Setup dialog box, from the Login Script list, select an existing login script to assign to the session. If you do not want to use a login script for the session, select <No Script>.
3. From the Logout Script list, select an existing logout script to assign to the session. If you do not want to use a logout script for the session, select <No Script>.
4. You can also assign script replacement strings and for specifying the behavior of the session while the script(s) are running. If you need instructions, see “Script Setup” in Chapter 2, “Configuring a Session” in Using SBClient.
5. When you have finished, click OK to save your changes.

Exiting SBClient

Use the Exit button to quit the SBClient program.

This button provides the same functionality as clicking the sky graphic in the old launch screen, as shown on page 5-5.

Procedure

- Click the Exit button. A confirmation dialog box appears, verifying that you want to exit.
Accessing less-used tasks

The new launch screen contains fewer buttons for performing tasks than the old one. All functionality that was accessible by clicking a graphic on the old launch screen is still available from the main menu. This section describes the less-used tasks that are do not have a button on the new launch screen:

- Setting up colors
- Setting up the communication type
- Using the dialing directory
- Displaying information about SBClient

Setting up colors

In the past, SBClient used proprietary colors, which gave you control in selecting colors. You could set up colors by clicking the picture frame graphic in the old launch screen, as shown on page 5-5. This opened the Color Setup dialog box (as if you had selected Setup > Color from the main menu).

SBClient now inherits colors from Windows, so the button was not included on the new launch screen. However, you can still access the Color Setup dialog box by selecting Setup > Color from the main menu. The dialog box remains the same as it was in previous versions of SBClient. If you need instructions, see “Color Setup” in Chapter 2, “Configuring a Session,” in Using SBClient.

Setting up the communication type

SBClient continues to support three communication types: serial, network, and modem.

In the old launch screen, you could set up the communication type by double-clicking Serial, Network, or Modem on the telephone graphic in the old launch screen, as shown on page 5-5. This opened the Communication Setup dialog box for the selected communication type (the same is if you had clicked Serial, Network, or Modem on the telephone graphic and then selected Setup > Communication from the main menu).
Serial and modem communications are now used only rarely, so a button for setting up communications is not included on the new launch screen. However, you can still access the same Communication Setup dialog box by selecting Default Serial, Default Network, or Default Modem from the Select Connection Profile list on the new launch screen, and then selecting Setup > Communication from the main menu.

**Using the dialing directory**

The dialing directory allows you to specify telephone numbers for use when opening a session using a modem.

In the old launch screen, you could set up the dialing directory by clicking the satellite graphic, as shown on page 5-5. This opened the Dialing Directory dialog box, in which you clicked the Edit button to enter directory details (as if you had selected Setup > Dialing Directory from the main menu).

Because modem communication is used infrequently, a button for the dialing directory is not included on the new launch screen. You can access the same Dialing Directory dialog by selecting Setup > Dialing Directory from the main menu.

**Displaying information about SBClient**

In the old launch screen, you could display information about your version of SBClient by clicking the About SBClient active area at the base of the telephone graphic, as shown on page 5-5.

Regardless of whether you use the old launch screen or the new launch screen in SBClient 6.1.x, you can access a splash screen that provides information about your version of SBClient by choosing Help > About SBClient.
The splash screen displays the version number of the software, a generic serial number, and generic license information. It also shows the full path of the folder containing your SBClient license files.
Changing the launch screen preference

This section contains steps for changing your preference to use the old or new launch screen after installing SBClient.

- Choosing the old launch screen after installation
- Choosing the new launch screen after installation

Choosing the old launch screen after installation

If you opt to use the new launch screen and later decide you want to use the old one instead, you can change your settings to call the old launch screen.

Procedure

1. If you have an open session running the version of SBClient you want to change, close your session so you can check the effect of your change when finished.
2. From the Setup menu, select Environment Variables. The Environment Settings dialog box appears.

3. Under user variables, change the value of NEWLAUNCHSCREEN to 0, which specifies the old launch screen.

4. Click OK to save your changes.

5. Close SBClient.

6. Start SBClient. After the splash screen appears briefly, the old launch screen should be displayed.

Choosing the new launch screen after installation

If you initially choose to use the old launch screen and later decide you want to try the new one, you can change your settings to call the new launch screen.
Procedure

1. If you have an open session running the version of SBClient you want to change, close your session so you can check the effect of your change when finished.

2. From the Setup menu, select Environment Variables. The Environment Settings dialog box appears.

3. Under user variables, change the value of NEWLAUNCHSCREEN to 1, which specifies the new launch screen.

4. Click OK to save your changes.

5. Close SBClient.

6. Start SBClient. After the splash screen appears briefly, the new launch screen should be displayed.
Selecting options from the SBClient menu bar

The main menu provides a range of options for maintaining your session configurations, opening sessions, and writing scripts.

Some of the menu options can also be invoked by selecting an active area in the old launch screen (see “Using the old launch screen” on page 5-5) or by selecting a button in the new launch screen (see “Using the new launch screen” on page 5-9).

Options that are available only from the session window menu bar (displayed when you open a session) are shown in gray.

You can select an option by using your mouse or the arrow keys (when the menu is activated using the mouse or the ESC key) or by pressing ESC and typing the letter underscored in the option and any suboptions. SBClient displays a short help prompt on the status line for each option you highlight.
Opening a session

This section explains how to open sessions in SBClient:

- Opening a session from a profile
- Opening a document-based session
- Opening additional sessions

Opening a session from a profile

This task assumes that one or more session configurations have already been set up for your system.

Procedure

1. Select a configuration profile.
   - In the old launch screen, select a configuration profile from the Session Name List, as shown on page 5-5.
   - In the new launch screen, select configuration profile from the Configuration Profile List, as shown on page 5-8.

2. You can change the configuration settings for this session by clicking on the appropriate active area or by choosing the appropriate option from the Setup menu. Any changes you make will apply only to the current session unless you save those changes.

3. When you are satisfied with your session configuration, open the session:
   - In the old launch screen, click on the Start Session active area.
   - In the new launch screen, click the Start a Session button.

   Tip: You can also open a session by double-clicking the session name in the Session Name List, or by choosing File > Open Session.
SBClient opens the session using its current configuration settings. If you have selected a modem connection and a telephone number, SBClient connects to the modem, dials the number, and then establishes a connection to the remote host. If you have selected a network connection, SBClient establishes a connection over the local area network to the specified host. If you have selected a serial connection, SBClient establishes a connection to the host through the serial port.

When the session has been successfully opened (a logical connection to the host system has been established), SBClient displays a session window for that particular session. The full range of menu options are available from the session window.

*Tip:* After you have opened a session, you cannot get back to the launch screen for that session. The launch screen is displayed only if you select *File > New Session*, or if you close a session and click the *New Session* button.

**Opening a document-based session**

SBClient provides two ways to open document-based sessions.

**Procedure**

- From the main menu, select *File > Open Session > Document* and click *OK*.
  Otherwise, double-click a .sbc file in the Windows Explorer to open that saved session.

**Opening additional sessions**

SBClient allows you to open more than one session concurrently. You can open additional sessions that use the same configuration as your active session, or that use a different configuration. Each additional session is displayed in its own session window.
Procedure

- From the session window menu, select **File > Duplicate Session**. SBClient opens another session using the active session's configuration. SBClient uses the same session name as that duplicated, but appends a different number to it, so that you can differentiate between sessions.
Closing a Session

You can close a session in the following ways:

- Closing an active session from the session window
- Closing an active session from within the session
- Closing an inactive session

Closing an active session from the session window

Complete the following steps to close an active session from the session window.

Procedure

1. Select the session window for the session you want to close, if there is more than one session open.
2. Select File > Close Session. This displays the following dialog box:

   ![Dialog box](image)

   If you have made changes to the session configuration and have not saved them, SBClient displays an additional Save Changes check box. Select this to save changes made to the session configuration.
3. Click one of the buttons:
   - **Close** button – Closes your connection to the host system and returns you to the previous active session, if you have more than one session open. If you are closing the only open session, SBClient exits.
   - **New Session** button – Closes the active session and displays the launch screen, where you can open a new session or create a new session configuration.
   - **Cancel** button. Returns you to the session.

**Closing an active session from within the session**

Complete the following steps to close an active session from within the session.

**Procedure**

1. Enter the appropriate exit or quit command in the session area.
2. This displays the following dialog box:

   ![Session Disconnected Dialog Box]

   If you have made changes to the session configuration and have not saved them, SBClient displays an additional **Save Changes** check box. Select this to save changes made to the session configuration.
3. Click one of the displayed buttons:
   - **Close** button closes your connection to the host system and returns you to the previous active session, if you have more than one session open. If you are closing the only open session, SBClient exits.
   - **New Session** button closes the active session and displays the launch screen, where you may select a new session or create a new session configuration.
   - **Re-Connect** button. Reconnects you to the session.

### Closing an inactive session

Complete the following steps to close an inactive session.

**Procedure**

1. Select **File > Close Session**.
   
   If you have made changes to the current session configuration and have not saved them, SBClient displays a dialog box with a **Save Changes** check box:

   ![Save Changes Dialog Box]

   If you select the **Save Changes** check box, any existing session configurations will be replaced.

2. Click the **Close** button. SBClient displays the session window for the previous active session, if you have more than one session open. If you are closing the only open session, SBClient exits.
## Chapter 6: Basic Session Configuration

| Session types | 6-2 |
| Saving settings as a session configuration | 6-3 |
| Creating a new session configuration | 6-3 |
| Changing a session configuration | 6-6 |
| Configuring sessions | 6-7 |
| Setting up communication | 6-9 |
| Setting up serial communication | 6-9 |
| Setting up network communication | 6-11 |
| Setting up modem communication | 6-12 |
| Setting up a dialing directory | 6-18 |
| Adding entries in the dialing directory | 6-19 |
| Changing a number in the dialing directory | 6-20 |
| Specifying additional numbers in an entry | 6-20 |
| Changing communication or login settings for an entry | 6-20 |
Session types

SBClient offers two styles of configuration: Classic and Document. Classic sessions are held internally within SBClient, whereas document sessions are saved as files with a .sbc file extension.

SBClient V4.x introduced the concept of .sbc files for storing session configurations. In SBClient V5.x, storing configurations as .sbc files is the default behavior of the product.

The old behavior of storing configurations within database files that only SBClient can access is now known as “Classic” session maintenance.

The default behavior is known as “Document” session maintenance. SBClient is keeping pace with Microsoft's objective for making the operating system and applications more document-centric.
Saving settings as a session configuration

After you have tested the settings for a session configuration, you can save them permanently. You can save a session configuration from either the launch screen or the session window.

Creating a new session configuration

To create a new session configuration, modify an existing configuration and save it under a different name.

- Saving settings as a new configuration for a Document session
- Saving settings as a new configuration for a Classic session

**Saving settings as a new configuration for a Document session**

Complete the following steps to save the current settings as a new configuration for a Document session.
Procedure

1. Select File > Save Configuration As. This displays the Save Configuration As dialog box.

2. A default Save path is provided. This path is the path to your SBClient data in your user profile. It is possible to amend this path to any location on the machine for which you have both read and write permissions. The default Save path is:

   C:\Documents and Settings\username\Application Data\Rocket Software\SBClient\SESSIONS

   The path can be amended by either typing in a changed path or by using the Browse button at the right side of the Save in text box.

3. Either select a file name from the list provided by double-clicking it or enter a new File Name.

4. Select the Add a Shortcut to this Configuration to the Start Menu check box if you would like the configuration to be added to the Windows Start menu. This creates an SBClient group in your personal settings. The SBClient group contain shortcuts to all SBClient configurations that have been added to the Windows Start menu.

5. Click OK.
Saving settings as a new configuration for a Classic session

Complete the following steps to save the current settings as a new configuration for a Classic session.

Procedure

1. Select File > Save Configuration As. The Save Configuration As dialog box appears.

2. Enter a New Session Name. If you select an existing session configuration, a warning dialog box explains that the session will be overwritten.

3. Select the Add a Shortcut to this Configuration to the Start Menu check box if you would like the configuration to be added to the Windows Start menu. This will create an SBClient group in your personal settings. This group will contain shortcuts to all SBClient configurations that have been added to the Start menu.

4. Click OK.
Changing a session configuration

Use the following procedure to replace the existing session configuration with an updated configuration.

Procedure

- Select File > Save Configuration.

The session configuration is updated.

If you make changes to a session configuration, and then select another session configuration without having saved your changes, the following dialog box prompts you to save your changes:

![Question Dialog]

Your Script Details For HostNewton Have Not Been Saved
Do You Wish To Save Them?

- Yes
- No
Configuring sessions

When SBClient is first installed, it provides a set of default serial, network, and modem configurations. If you are running SBClient on a network, your system administrator may have added to or modified the default configurations.

You can use the Setup menu to change the existing configurations to meet your particular communication requirements. If you make changes to an existing session configuration, you can discard them at the end of the session, permanently save them as the new settings for the session configuration, or permanently save them as a new session configuration.

To configure a session correctly you need some knowledge of the host computer, your connection to the host and the terminal you are emulating. If you are unsure of any parameter (or if you have difficulties in operating a session after configuration), consult the appropriate hardware, network, or terminal documentation and check your configuration, or consult your system administrator.

The Setup menu is available from both the launch screen and the session window. (Some of the Setup options are also active areas on the old launch screen or icons on the new launch screen. For more information, see “The SBClient launch screen” on page 5-3.)

Options are:

- Communication. Allows you to configure the communication method used by the session to connect your PC with the host computer. The communication method chosen depends on the type of physical connection used: serial, network, or modem.
- Terminal. Allows you to configure the session to emulate the characteristics of a particular terminal type (such as VT220).
- File Transfer. Allows you to configure some overriding flow control options for file transfer.
- Font. Allows you to select the initial font to be used during a session.
- Color. Allows you to associate color with video attributes, such as foreground, background, and reverse video.
- **Keyboard.** Allows you to reprogram any key on the keyboard to send a different sequence to the host. With this option, you can emulate many different types of keyboards.

- **Toolbar.** Allows you to customize the toolbar located at the top of your session window. For example, you might create buttons for commonly used menu options, host commands, or DOS/Windows programs.

- **Status Line.** Allows you to select the items to be displayed on the status line at the bottom of your session window.

- **Nationality.** Allows you to define the character set to be used during a session.

- **Script.** Allows you to specify additional script data substitution parameters, to be used for all scripts run from a session.

- **Miscellaneous.** Allows you to define additional settings such as the characteristics of your cursor and window resize behavior.

- **Dialing Directory.** Allows you to specify the telephone numbers to use when opening a session via a modem.

- **GUI Parameters.** Allows you to define the GUI parameters.

- **Smart Query.** Allows you to build, save, and run report queries for a host computer that is running a nested relational database system.

- **Environment variables.** Allows you to change or add environment variables.
Setting up communication

The Communication option on the Setup menu allows you to configure the communication method used by the session to connect your PC to the host computer.

When you select this option, SBClient displays a configuration dialog box specific to the type of communication used in the current session. The configuration dialog box enables you to modify settings for one of the following (depending on communication type selected):

- **Setting up serial communication**
  Configuring the serial port (for example, COM1 or COM2).
- **Setting up network communication**
  Configuring the host network connection.
- **Setting up modem communication**
  Configuring the initialization commands and dialing options for your modem, as well as the configuration of the serial port that the modem is to use.

### Setting up serial communication

In the Serial Communication Setup dialog box, you can change the communication settings for your serial port.

Parameters are:

*Port*

The serial port you are using to connect to the host. Valid serial ports are COM1 through COM9.
Baud Rate

The baud rate for transmission. When you set the baud rate, ensure that the port on the host computer connected to your PC is set to the same baud rate. You can select a baud rate from 300 through 115200. For more information, consult your system administrator or the appropriate host documentation.

Data Bits

The number of data bits, together with the number of stop bits, determines how a character is encoded (see “Stop Bits” below). In addition, the number of data bits is usually set together with a given parity type (see “Parity” below). Valid data bits settings are 4 through 8. Normally you would select 8 data bits per character. If you are using parity, the link may support only 7 data bits.

Stop Bits

The number of stop bits, together with the number of data bits, determines how a character is encoded (see “Data Bits” above). Valid stop bits settings are 1, 1.5, and 2. Normally you would set Stop Bits to 1 (the default), regardless of the number of data bits.

Parity

Parity is one of several methods the communication program uses for detecting transmission errors. Normally you would select no parity (None). If the communication link can be made only with parity, select the parity method required: Odd, Even, Mark, or Space.

Parity, data bits, and stop bits are normally set using either of the following combinations:

- 8 data bits, 1 stop bit, no parity
- 7 data bits, 1 stop bit, even parity

For more information, consult your system administrator or the appropriate host documentation.
Setting up network communication

The **Telnet Setup** dialog box allows you to change the settings for the network software you use to connect to your host.

Parameters are:

**Host Name or IP Address**
The name or IP address of the host computer.

**Term Type**
The type of terminal to be used.

**Port**
The port type to use.
Setting up modem communication

The **Modem Communication Setup** dialog box allows you to change the communication settings for your serial port.

Parameters are:

**Port**

The serial port you are using to connect to the host. Valid serial ports are COM1 through COM9.

**Baud Rate**

The baud rate for transmission. When you set the baud rate, ensure that the port on the host computer connected to your PC is set to the same baud rate. You can select a baud rate from 300 through 115200. For more information, consult your system administrator or the appropriate host documentation.

**Data Bits**

The number of data bits, together with the number of stop bits, determines how a character is encoded (see “Stop Bits” below). In addition, the number of data bits is usually set together with a given parity type (see “Parity” below). Valid data bits settings are 4 through 8. Normally you would select 8 data bits per character. If you are using parity, the link may support only 7 data bits.
Stop Bits

The number of stop bits, together with the number of data bits, determines how a character is encoded (see “Data Bits” above). Valid stop bits settings are 1, 1.5, and 2. Normally you would set Stop Bits to 1 (the default), regardless of the number of data bits.

Parity

Parity is one of several methods the communication program uses for detecting transmission errors. Normally you would select no parity (None). If the communication link can be made only with parity, select the parity method required: Odd, Even, Mark, or Space.

Parity, data bits, and stop bits are normally set using either of the following combinations:

- 8 data bits, 1 stop bit, no parity
- 7 data bits, 1 stop bit, even parity

For more information, consult your system administrator or the appropriate host documentation.
The Modem button in the Modem Communications Setup dialog box opens the Modem Configuration dialog box. Here you can change the communication settings of the serial port you use to connect to your modem.

The dialog box displays the current modem settings assigned to your session. The term (Current Config) prefixes the modem model name on which the current settings are based. This differentiates your settings from the permanent settings in the modem database. The modem database contains the default settings for each modem that SBClient supports and is unaffected by any changes you make in this dialog box. For example, if you select the model name GENERIC HIGH SPEED and change a setting, SBClient retains the original GENERIC HIGH SPEED settings in the Model list and assigns the name (Current Config) GENERIC HIGH SPEED to your new settings. This helps you identify which modem you used for the base settings. The original GENERIC HIGH SPEED modem settings are unaffected.

If you want to save your changes, first save your session configuration. If you do not save your changes, they apply only for the duration of your session. Your changes do not affect any other user's modem settings.

**Note:** You should make changes to these modem settings only if you understand modem operations and are familiar with the specific characteristics of your modem. Consult your modem documentation for an explanation of the settings displayed in this dialog box.
Parameters are:

*Model*

This is the list of modems that SBClient maintains in its modem database. Select the modem that most closely resembles the settings you require from this list. The selected modem appears in the Model text box, prefaced with the term (Current Config).

*Speaker Mode*

You can turn the modem speaker permanently off (Off), permanently on (On), or on until a connection has been established (Until Connected).

*Speaker Volume*

You can adjust the modem speaker volume to Low, Medium, or High. This parameter may not work with some modems.

*Initialization String*

The initialization string is a series of commands used to initialize and configure your modem. SBClient sends this command string to the modem before establishing a connection.

*Reset String*

The command(s) used to reset your modem to its default settings.

*Hangup String*

The control character and command sequence required to instruct your modem to hang up.

*Connect String*

The message sent by the modem to your PC indicating a connection has been established.
**No Connect Strings**

The messages (separated by commas) that your modem sends to your PC, indicating a connection attempt has failed.

**Pulse Dial**

Uses pulse instead of tone dialing.

*Note: National telecommunications authorities may impose restrictions on the use of pulse dialing.*

**Detect Busy Tone**

Checks for a busy signal from the dialed number.

**Detect Dial Tone**

Does not attempt to dial a telephone number until a dial tone is detected.

**Dial Retries**

The number of times SBClient redials a number (or set of numbers) before aborting the connection attempt.

**Retry Every**

The number of seconds SBClient waits before redialing a number.

**Wait For Carrier**

The number of seconds SBClient waits before deciding a connection has failed.

*Note: National telecommunications authorities impose restrictions on the number of times a phone number may be redialed. Check the regulations for your country before altering the setting of Dial Retries, Retry Every, or Wait for Carrier.*
Auto Answer
The modem automatically answers if the telephone rings.

Answer After Rings
The number of rings the modem waits before answering an incoming call.

Drop DTR to Hangup
Select this option if your modem requires the DTR signal to be lowered to make it hang up.
Setting up a dialing directory

The Dialing Directory dialog box appears when you click the phone button in the Modem Communications Setup dialog box, or if you have a modem connection and select File > Dial a Number.

You can select the telephone number you want to dial from the list of saved numbers. The telephone number associated with the selected name is displayed in the Prefix and Number fields.
The **Edit** button displays the **Dialing Directory Maintenance** dialog box, allowing you to add or edit modem phone numbers.

**Adding entries in the dialing directory**

- Changing a number in the dialing directory
- Specifying additional numbers in an entry
- Changing communication or login settings for an entry

### Adding entries in the dialing directory

In the dialing directory, you can add more contacts to the list.

**Procedure**

1. Click the **New** button. The **Directory Details** fields are cleared.
2. In the **Directory Details** fields, enter the new name, prefix, telephone number, and any additional comments.
3. Click the **Add** button.
Changing a number in the dialing directory

Complete the following steps to change a telephone number and the associated details.

**Procedure**

1. Highlight the name in the *Phone Book* list. The details of the selected entry are displayed in the *Directory Details* text boxes.
2. Change the details.
3. Click the *Update* button to save the changes. The *Update* button becomes active when you click on any of the *Directory Details* text boxes.

Specifying additional numbers in an entry

Each entry in the *Phone Book* list can have up to ten additional numbers associated with it. These are used in cases where the service provider or bulletin board has more than one access line. If you specify additional numbers, SBClient will attempt to get through to the service provider by trying each number in turn until a connection is made.

**Procedure**

1. Highlight the name in the *Phone Book* list.
2. Click the *No's* button. This displays the *Additional Telephone Numbers* dialog box.
3. Enter any additional numbers and their prefixes.
4. Click the *OK* button.

Changing communication or login settings for an entry

You can associate specific communication and login configuration settings to a selected entry in the dialing directory. These settings may be different from the settings you selected using the *Communication* and *Login* options from the *Setup* menu.
Procedure

1. Highlight the name in the **Phone Book** list.

2. To change communication settings, click the **Comms** button to access the **Serial Communication Setup** dialog box.
   To change login settings, click the **Login** button to display the **Host Login Details** dialog box.

3. Any changes you make to either of these dialog boxes apply only to the selected phone book entry. They override the settings defined in the **Communications** or **Script** options in the **Setup** menu for that phone book entry.